1. Ranel 25.03.20 10:45 Сейчас в теме

перенос ЗУП 2,5 в ЗУП 3,1

Переношу данные возникает ошибка. Как решить? Ошибку в модули нашёл, что там надо добавить или где закомментировать ?
Делал перенос на прямую, а так же через файл, ошибку выдаёт одну и туже:

// Корректируем список ведущих по базовым и вытесняющим начислениям.
	Для Каждого КлючИЗначение Из ПакетВидовРасчета Цикл
		ВидРасчета = КлючИЗначение.Значение;
		ВедущиеНачисления = Новый Массив;
		
		// Собираем уже имеющиеся ведущие начисления.
		Для Каждого Строка Из ВидРасчета.ВедущиеВидыРасчета Цикл
			ВедущиеНачисления.Добавить(Строка.ВидРасчета);
		КонецЦикла;
		
		// Если расчетная база определяется за текущий период, 
		// то базовые виды расчета являются также ведущими.
		Если ЕстьПоказательВКоллекции(ВидРасчета.Показатели, "РасчетнаяБаза") Тогда
			Для Каждого Строка Из ВидРасчета.БазовыеВидыРасчета Цикл
				ВедущиеНачисления.Добавить(Строка.ВидРасчета);
			КонецЦикла;
		КонецЕсли;
		
		// Ведущие начисления
		СвойстваНачисления = СвойстваНачислений[ВидРасчета.КатегорияНачисленияИлиНеоплаченногоВремени];
		ОтборВедущих = СвойстваНачисления.ОтборВедущих;
		Если ОтборВедущих <> Неопределено
			И НачислениеРассчитываетсяПоЧасам(ВидРасчета) 
			И ЗарплатаКадрыРасширенныйКлиентСервер.ЗачетОтработанногоВремени(ВидРасчета.ВидВремени) Тогда
			
			// Начисления по условию из коллектора.
			ОбщегоНазначенияКлиентСервер.ДополнитьМассив(
				ВедущиеНачисления, ПланыВидовРасчета.Начисления.ВидыРасчетаКоллектораПоОтбору(ПакетВидовРасчета, ОтборВедущих));
				
			// ..Дополняются по условию из базы данных.
			ОбщегоНазначенияКлиентСервер.ДополнитьМассив(
				ВедущиеНачисления, ПланыВидовРасчета.Начисления.НачисленияПоОтбору(ОтборВедущих), Истина);
		КонецЕсли;
		
		// Заполняем табличную часть полученными вытесняющими начислениями.
		Для Каждого ВедущееНачисление Из ВедущиеНачисления Цикл
			Если ВидРасчета.ВедущиеВидыРасчета.Найти(ВедущееНачисление, "ВидРасчета") = Неопределено 
				И КлючИЗначение.Ключ <> ВедущееНачисление Тогда
				
				ВидРасчета.ВедущиеВидыРасчета.Добавить().ВидРасчета = ВедущееНачисление;
			КонецЕсли;
		КонецЦикла;
	КонецЦикла;
Показать
Прикрепленные файлы:
Найденные решения
11. user705522_constantin_h 21 25.03.20 11:05 Сейчас в теме
(10)С ЗУП 3.1.13.120 не сталкивался. А можете перенос сделать в ЗУП 3.1.12.144?
Остальные ответы
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
8. user705522_constantin_h 21 25.03.20 10:59 Сейчас в теме
(1)
Переношу данные возникает ошибка. Как решить? Ошибку в модули нашёл, что там надо добавить или где закомментировать ?

Переноситься должно всё нормально. Сам делал не один раз. Какие у вас версии ЗУП 2.5 и ЗУП 3.1?
10. Ranel 25.03.20 11:01 Сейчас в теме
(8)Зарплата и Управление Персоналом, редакция 2.5 (2.5.130.2) (http://v8.1c.ru/hrm/)
Copyright (С) ООО "1C-Софт", 2007 - 2018. Все права защищены
(http://www.1c.ru)


Зарплата и управление персоналом, редакция 3.1 (3.1.13.120) (http://v8.1c.ru/hrm/)
Copyright © ООО "1С-Софт", 2010 - 2020. Все права защищены
(http://www.1c.ru)
11. user705522_constantin_h 21 25.03.20 11:05 Сейчас в теме
(10)С ЗУП 3.1.13.120 не сталкивался. А можете перенос сделать в ЗУП 3.1.12.144?
12. uriah 12 25.03.20 11:09 Сейчас в теме
(10) Согласен с (11), нужно попробовать на более раннем релизе - может быть в последнем релизе правила выгрузки не доработаны под изменение релиза.
13. Ranel 25.03.20 11:20 Сейчас в теме
14. VAAngelov 41 25.03.20 13:21 Сейчас в теме
(1) Попробуйте следующее:

Вначале протестируйте базу ЗУП 2 (думаю, вы знаете, как это сделать)
Далее обновите ЗУП 2 максимально.
Потом установите ЗУП 3.1.12.144

Я недавно переводил. и напрямую к базе подключением. и через файл. Все четенько перенеслось остатками, как положено.

Пробуйте.

Напишите потом результат.
15. Ranel 25.03.20 15:22 Сейчас в теме
(14)Всех благодарю за советы,
я по рекомендация и тут и другую до последних обновил и перенос не удавался.
По совету предыдущего специалиста начал делать перенос в релизе 3.1.12.144 и всё получилось. Овации и благодарность тем кто ответил правильно, )
VAAngelov; +1 Ответить
2. xSavantx 11 25.03.20 10:46 Сейчас в теме
Правильно сформулируйте вопрос и может быть кто-нибудь подскажет
5. Ranel 25.03.20 10:58 Сейчас в теме
(2)что то не так нажал, и вопрос по шаблону с формулировался, я не хотел ещё его публиковать, поэтому такая чехорда получилась, сейчас скорректировал
3. uriah 12 25.03.20 10:48 Сейчас в теме
перенос ЗУП 2,5 в ЗУП 3,1
Подскажите пожалуйста, как из БП 7 перенести справочники в БП 8.

Расшифруйте, из какой конфигурации и в какую нужно переносить данные - заголовок не коррелирует с сообщением.
7. Ranel 25.03.20 10:59 Сейчас в теме
(3)что то не так нажал, и вопрос по шаблону с формулировался, я не хотел ещё его публиковать, поэтому такая чехорда получилась, сейчас скорректировал
4. THEBESTolo4b 6 25.03.20 10:50 Сейчас в теме
тут же Зуп тут же БП , Может комплексная ?
6. uriah 12 25.03.20 10:58 Сейчас в теме
Перенос данных стандартный или ЗУП 2.5 с доработками. ЗУП 2.5 какой релиз используете для выгрузки? ЗУП 3.1 какой используете для загрузки?
9. Ranel 25.03.20 11:01 Сейчас в теме
(6)дальше не обновляется, типовая

Зарплата и Управление Персоналом, редакция 2.5 (2.5.130.2) (http://v8.1c.ru/hrm/)
Copyright (С) ООО "1C-Софт", 2007 - 2018. Все права защищены
(http://www.1c.ru)
Прикрепленные файлы:
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Product Owner (Менеджер по продукту 1С)
Москва
зарплата от 100 000 руб. до 170 000 руб.
Полный день

Тим лид по разработке 1С (Team Lead 1С)
Москва
зарплата от 100 000 руб. до 200 000 руб.
Полный день

Программист, аналитик, эксперт 1С
Санкт-Петербург
По совместительству

Программист 1С
Новосибирск
зарплата от 30 000 руб.
Временный (на проект)

Программист 1С
Москва
зарплата от 100 000 руб. до 150 000 руб.
Полный день