1. 33lab 471 08.10.16 21:44 Сейчас в теме

НачатьПомещениеФайла, ПоместитьФайл

НачатьПомещениеФайла, ПоместитьФайл в Андроиде работает как то странно (или я не понимаю логики). При использовании данных методов (с параметром Интерактивно=Истина) открывается окно выбора файла (замечательно красивое окно) и даже выбирает файл, но вот путь к файлу какой-то странный, точнее имя файла (т.е. если название файла например "МояКартинка.jpg" то вернется название "78395" причем без расширения. ЗапуститьПриложение(стрПуть) отрабатывает данный путь(файл) без проблем, а вот Файл.Существует(стрПуть) ругается на отсутствие такого файла (что логично) - отсуда вопрос, что за имя возвращает система?!

P.S. знаю, что в СП написано про мобильную платформу и параметр "интреактивно", но все таки (раз уж работает, то может кто знает ответ на вопрос выше).
Вознаграждение за ответ
Показать полностью
Найденные решения
6. spacecraft 09.10.16 20:16 Сейчас в теме
(5) 33lab, какая платформа 1С установлена?
В 8.3.9 много изменений появилось. Вот такое, например:
    Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
    Если Диалог.Выбрать() Тогда
        Данные = Диалог.ПолноеИмяФайла;
        Файл = Новый Файл(Диалог.ПолноеИмяФайла);
        Сообщить("" + Файл.ПолучитьПредставлениеФайлаБиблиотекиМобильногоУстройства());
    КонецЕсли;
Остальные ответы
Избранное Подписка Сортировка: Древо
2. Xershi 542 09.10.16 13:49 Сейчас в теме
(1) 33lab, очевидно это особенности андроида.

А по воду
Файл.Существует(стрПуть)
то вы не путаете ничего? У данного метода нет параметров.
3. 33lab 471 09.10.16 16:48 Сейчас в теме
(2) Xershi, с параметром конечно же погорячился :) Имелось ввиду Файл=Новый Файл(стрПуть); и далее по списку...
Меня терзают смутные сомнения (с) , что это особенность 1С а не андроида :)
4. spacecraft 09.10.16 18:28 Сейчас в теме
(1) 33lab, Это не путь к файлу, а его URI.
Может что и поменялось в 8.3.8. Во всяком случае в описании есть изменения работы с файлом.
А так можно работать с файлом:
НовВз=Новый ЗапускПриложенияМобильногоУстройства("android.intent.action.GET_CONTENT"); 
НовВз.Тип = "file/*"; 
Результат = НовВз.Запустить(Истина); //0 - ошибка получения/открытия файла
Если НЕ Результат Тогда 
    //Можно работать с файлом
КонецЕсли; 


PS. доступ к файлу через НовВз.Данные
5. 33lab 471 09.10.16 19:01 Сейчас в теме
(4) spacecraft, Знаю про эту возможность, но хотелось использовать именно 1Совский диалог выбора файла (уж больно он привлекательно выглядит)
6. spacecraft 09.10.16 20:16 Сейчас в теме
(5) 33lab, какая платформа 1С установлена?
В 8.3.9 много изменений появилось. Вот такое, например:
    Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
    Если Диалог.Выбрать() Тогда
        Данные = Диалог.ПолноеИмяФайла;
        Файл = Новый Файл(Диалог.ПолноеИмяФайла);
        Сообщить("" + Файл.ПолучитьПредставлениеФайлаБиблиотекиМобильногоУстройства());
    КонецЕсли;
7. 33lab 471 09.10.16 21:36 Сейчас в теме
(6) spacecraft,
Файл.ПолучитьПредставлениеФайлаБиблиотекиМобильногоУстройства()
то, что доктор прописал. Спасибо.
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Специалист техподдержки 1С
Иркутск
зарплата от 28 000 руб. до 34 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 48 000 руб. до 96 000 руб.
По совместительству

Программист 1С
Ставрополь
зарплата от 40 000 руб. до 60 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 120 000 руб. до 150 000 руб.
Полный день

Программист 1С
Благовещенск (Амурская область)
зарплата от 40 000 руб. до 70 000 руб.
Полный день