1. bobreks 109 13.07.16 13:28 Сейчас в теме

Подходящие SDK для сборки 1С мобильного приложения Android

Не секрет что 1С не работает с новыми SDK. Нашел старую версию 22.1, копировал файлы по совету форума и все равно ничего не получилось, сборка не завершается, в логах причины не пишутся.

Если у кого есть SDK, с которым отлично все собирается, скопируйте, пожалуйста в архив и выложите в облако, много кому будет полезно.
Вознаграждение за ответ
Показать полностью
Найденные решения
19. dj_serega 359 14.07.16 07:18 Сейчас в теме
1. У вас API 24 ->> [info] Используется Android SDK : 24
2. Каталоги SDK и ANT предлагаю перенести в каталог "c:\sdk" и "c:\ant" соответственно.

Все что можно перенести в адрес без пробелов и только с латиницей лучше это сделать. Java не любит все окроме латинницы.

3. Проверьте доступы к каталогам: java, sdk и т.д.

4. А лучше почитать схожую тему. http://forum.infostart.ru/forum92/topic146763/ . Там этот вопрос (с таким же логом) - решился.
Остальные ответы
Избранное Подписка Сортировка: Древо
8. Xershi 414 13.07.16 16:26 Сейчас в теме
(1) bobreks, дело не в СДК, а сборщике, у вас все сдк должны быть только с цифрами. Если установлены с буквенным кодом, просто их удалите и все взлетит!
2. bobreks 109 13.07.16 15:15 Сейчас в теме
Добавлено вознагрождение
3. DitriX 1614 13.07.16 15:34 Сейчас в теме
Эммм,https://dl.google.com/android/installer_r24.4.1-windows.exe
Установил. запустил менеджер, выбрал нужную SDK, хоть для 6 андроида и вперед
4. DitriX 1614 13.07.16 15:35 Сейчас в теме
(0) и что это за секрет такой? Раньше, давно. еще на 8.3.5 - 1С поддерживала только 17 АПИ, теперь, им вообще пофиг какая стоит, они тулзы юзают, но вот на старых SDK, те что ниже 22 версии - таки может и не сораться, а на новых - все собирается на ура.
5. bobreks 109 13.07.16 16:07 Сейчас в теме
(4) DitriX, ну не совсем работает. Беру с последнего диска ИТС MobileAppWizard.epf для сборки apk, указываю путь к SDK, а он ругается что sdk не найдено, вижу что он проверяет файл android-sdk/tootls/aapt.exe.
Копирую этот файл в нужную директорию, запускаю сборку и начинаются сыпаться ошибка, то о том что apkbuilder.bat не найден, то еще какие-то.
По данным с форума понимаю что apkbuilder.bat был только в sdk до 22.1.
Скачал sdk 22.1, опять с бубном копировал файлы и опять ничего не взлетело, apk файл сборки не появляется.
Пробовал и на sdk 24.4.1, также ничего не получилось.
13. bobreks 109 13.07.16 19:08 Сейчас в теме
(4) DitriX,
Тем не менее из коробки ничего не заработало версия Build-tools 24.2 rc1 вызвало ошибку преобразования к числу)) в 1С никогда ничего из коробки не работает
14. Xershi 414 13.07.16 20:00 Сейчас в теме
(13) bobreks, нет, просто вы хотите использовать, то чего не нужно!
15. bobreks 109 13.07.16 20:18 Сейчас в теме
(14) Xershi, Вы говорите загадками. Имеете ввиду что мне нужно выбрать другую версию Build-tools в SDK Manager? Но другого варианта в последнем SDK как раз нет, только версия 25.2 rc1
16. Xershi 414 13.07.16 20:32 Сейчас в теме
(15) bobreks, тогда у вас ничего не выйдет. гс это тестовые релизы как я понимал. Их нужно в любом случае удалить.
6. DitriX 1614 13.07.16 16:13 Сейчас в теме
Ну так кроме СДК надо еще тулзы ставить
7. DitriX 1614 13.07.16 16:20 Сейчас в теме
эммм. погодите
Беру с последнего диска ИТС MobileAppWizard.epf для сборки apk,
Что это за бред? Обработкой сборка была еще года 3 назад. Сейчас ставится отдельная конфигурация и в ней идет компиляция.
dj_serega; +1 Ответить
9. bobreks 109 13.07.16 16:35 Сейчас в теме
(7) DitriX, Ну я полностью доверился ИТС, не охота было еще одну конфу в списке держать, сейчас попробую)
10. Xershi 414 13.07.16 16:51 Сейчас в теме
(9) bobreks, т.е. речь идет не о сборщике? Ставьте сборщик в чем проблема.
11. dj_serega 359 13.07.16 17:35 Сейчас в теме
(9) bobreks, Видимо последний диск ИТС очень устарел :) (на года 3 так точно :) )
12. bobreks 109 13.07.16 19:05 Сейчас в теме
(11) dj_serega, я уже понял причину - диск предназначен для Украины, видимо для них забыли обновить.
17. DitriX 1614 14.07.16 01:02 Сейчас в теме
Чето я вообще нифига не понял. Вот я для вас персонально, сделал скрин, с этими настройками у меня все отлично работает.
Прикрепленные файлы:
18. bobreks 109 14.07.16 02:11 Сейчас в теме
(17) DitriX, а можно скрин установленных API?

у меня все так же, но все же имею ошибку при сборке

[info] Дата и время начала сборки : 14.07.2016 2:09:02
[info] Версия ОС : Windows x86,version 6.2 (Build 9200)
[info] Версия 1С:Предприятия : 8.3.8.1652
[info] Версия сборщика : 1.0.4.46
[info] Версия мобильной платформы : 8.3.6.220
[info] Графическая информация :
[info] Аудиоинформация :
[info] Путь к Android SDK : C:\Program Files (x86)\Android\android-sdk
[info] Используется Android SDK : 24
[info] Путь к Apache Ant : C:\Users\Bullet\Documents\1С\Мобильная платформа\apache-ant-1.9.7
[info] Путь к Java : C:\Program Files\Java\jdk1.8.0_92
[info] Рабочий каталог (и кеш) : C:\Temp
[info] Распаковка мобильной платформы
[info] Конфигураций в мобильном приложении: 1
[info] Распаковка мобильной конфигурации: 0,МобильныйСклад 0.01 b
[info] Распаковка картинки: Android\icon-36x36.png (res\drawable-ldpi\icon.png) - ОТСУТСТВУЕТ
[info] Распаковка картинки: Android\icon-48x48.png (res\drawable-mdpi\icon.png) - ОТСУТСТВУЕТ
[info] Распаковка картинки: Android\icon-72x72.png (res\drawable-hdpi\icon.png) - ОТСУТСТВУЕТ
[info] Распаковка картинки: Android\icon-96x96.png (res\drawable-xhdpi\icon.png) - ОТСУТСТВУЕТ
[info] Распаковка картинки: Android\icon-144x144.png (res\drawable-xxhdpi\icon.png) - ОТСУТСТВУЕТ
[info] Распаковка картинки: Android\splash-320x480.png (assets\logo\logo_320x480.png) - ОТСУТСТВУЕТ
[info] Распаковка картинки: Android\splash-480x854.png (assets\logo\logo_480x854.png) - ОТСУТСТВУЕТ
[info] Распаковка картинки: Android\splash-640x960.png (assets\logo\logo_640x960.png) - ОТСУТСТВУЕТ
[info] Распаковка картинки: Android\splash-768x1024.png (assets\logo\logo_768x1024.png) - ОТСУТСТВУЕТ
[info] Распаковка картинки: Android\splash-800x1280.png (assets\logo\logo_800x1280.png) - ОТСУТСТВУЕТ
[info] Распаковка картинки: Android\splash-854x480.png (assets\logo\logo_854x480.png) - ОТСУТСТВУЕТ
[info] Распаковка картинки: Android\splash-1024x768.png (assets\logo\logo_1024x768.png) - ОТСУТСТВУЕТ
[info] Распаковка картинки: Android\splash-1280x800.png (assets\logo\logo_1280x800.png) - ОТСУТСТВУЕТ
[info] Распаковка картинки: Android\splash-1536x2048.png (assets\logo\logo_1536x2048.png) - ОТСУТСТВУЕТ
[info] Распаковка картинки: Android\splash-2048x1536.png (assets\logo\logo_2048x1536.png) - ОТСУТСТВУЕТ
[info] Установка полного идентификатора приложения: com.yacubovvs.warehouse
[info] Установка версии приложения: 0.0.1
[info] Установка номера сборки приложения: 1
[WARN] Ключ для работы с картами Google не задан в настройках. Работа с картами будет невозможна
[info] Проверка версии мобильной платформы, а также установка разрешений (если это необходимо):
[info] В файле permissions.xml заменено значение %application.package% на "com.yacubovvs.warehouse"
[info] В файле permissions.xml заменено значение %application.package% на "com.yacubovvs.warehouse"
[info] В файле permissions.xml заменено значение %application.package% на "com.yacubovvs.warehouse"
[info] В файле permissions.xml заменено значение %application.package% на "com.yacubovvs.warehouse"
[info] В файле permissions.xml заменено значение %application.package% на "com.yacubovvs.warehouse"
[info] Устанавливаются разрешения, используемые мобильными конфигурациями:
[info] Обрабатывается разрешение: PushNotification,Нет
[info] Обрабатывается разрешение: Location,Нет
[info] Обрабатывается разрешение: Contacts,Нет
[info] Обрабатывается разрешение: Multimedia,Нет
[info] Обрабатывается разрешение: LocalNotification,Нет
[info] Обрабатывается разрешение: Telephony,Нет
[info] Обрабатывается разрешение: Print,Нет
[info] Обрабатывается разрешение: Calendars,Нет
[info] Обрабатывается разрешение: InAppPurchases,Нет
[info] Подготовка файла управления сборкой: local.properties.xml
[info] Подготовка файла управления сборкой: build.xml
[info] Подготовка файла управления сборкой: make.bat
[info] Начинается сборка
���⥬� �� 㤠���� ���� 㪠����� ����.
Показать
19. dj_serega 359 14.07.16 07:18 Сейчас в теме
1. У вас API 24 ->> [info] Используется Android SDK : 24
2. Каталоги SDK и ANT предлагаю перенести в каталог "c:\sdk" и "c:\ant" соответственно.

Все что можно перенести в адрес без пробелов и только с латиницей лучше это сделать. Java не любит все окроме латинницы.

3. Проверьте доступы к каталогам: java, sdk и т.д.

4. А лучше почитать схожую тему. http://forum.infostart.ru/forum92/topic146763/ . Там этот вопрос (с таким же логом) - решился.
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Руководитель проектов 1С
Санкт-Петербург
По совместительству

Ведущий разработчик 1С
Санкт-Петербург
Полный день

Программист 1С
Санкт-Петербург
Полный день

Консультант-аналитик 1С (ЗУП)
Санкт-Петербург
Полный день

Программист 1С
Санкт-Петербург
зарплата от 100 000 руб.
Полный день