INFOSTART EVENT 2018 EDUCATION

Второй тур голосования за доклады.
Окончание 5 сентября.

Александрович Андрей | Генеральный директор | ALEXROVICH

«Визуализация бизнес-показателей из 1С на TV-панели»

• Что может быть лучше отчетов и графиков 1С:Предприятие 8? • Какие бизнес-показатели нужно визуализировать и зачем? • Как за 30 минут сделать TV-панель с ключевыми цифрами из 1С для собственника компании? • Создание TV-панели на примере показателей отдела продаж. • Повышение выполнения планов продаж на +10% за счет контроля активности менеджеров используя TV-панель. • В чем отличие BI-систем (систем бизнес-аналитики) от дашбордов (панелей визуализации данных)? • TV-панель с показателями работы сотрудников как инструмент контроля и повышения эффективности компании.

1. Meteorage 11 28.03.15 11:54 Сейчас в теме

Отправка и получение почты на мобильном приложении

Доброе время суток. У меня возникла проблема при отправке и получении почты со смартфона. Ситуация такая: На платформе 8.3.5.* написана конфигурация, которая при отработке в толстом клиенте отрабатывает на ура, но как только стоило перенести ее на мобильное платформу, то возникли ошибки при получении/отправке почты.
	Почта = Новый ИнтернетПочта;
	
	Профиль = Новый ИнтернетПочтовыйПрофиль;
	Профиль.АдресСервераPOP3 = Константы.АдресСервераPOP3.Получить();
	Профиль.Пользователь = Константы.ЭлектронныйАдресАгента.Получить();
	Профиль.Пароль = Константы.ПарольОтЭлектронногоАдресаАгента.Получить();
	Профиль.АутентификацияPOP3 = СпособPOP3Аутентификации.Обычная;
	Профиль.ПортPOP3 = 995;
		
	Попытка
		Почта.Подключиться(Профиль);
		МассивСообщений = Новый Массив;
		МассивСообщений	= Почта.Выбрать(Ложь); 
	Исключение
		Сообщить("Ошибка подключения к серверу.",СтатусСообщения.ОченьВажное);
		Сообщить(""+ОписаниеОшибки());
		Почта.Отключиться();
		Возврат Ложь;
	КонецПопытки;
Показать


Перепробовал массу вариантов. Самое печальное что свойство ИспользоватьSSLPOP3 доступно только на сервере, но не на мобильное-приложение сервер.
Ответы
Сортировка: Древо
2. Meteorage 11 29.03.15 17:58 Сейчас в теме
Или как организовать передачу файла данных от сервера до мобильной платформы? Были мысли о использовании почтового клиента, а потом в мобильном приложении указывать полученный через почтовый клиент файл.
3. DitriX 2764 29.03.15 18:04 Сейчас в теме
Ну обычно для этих целей использую веб или хттп сервисы.
А вообще - почту отправлять так:
Если СредстваПочты.ПоддерживаетсяОтправка() Тогда
				Письмо = Новый ИнтернетПочтовоеСообщение;
				
				СтрокаПолучатели = СтрЗаменить(Получатели, ",", Символы.ПС);
				Для Счетчик=1 По СтрЧислоСтрок(СтрокаПолучатели) Цикл
					Письмо.Получатели.Добавить(СокрЛП(СтрПолучитьСтроку(СтрокаПолучатели, Счетчик)));
				КонецЦикла;
				
				Письмо.Тексты.Добавить(ТекстСообщения);
				Письмо.Тема = ТемаСообщения;		
				Если Документ.Пустая() Тогда
					Письмо.Вложения.Добавить(ПолучитьАдресФайла(),"Картинка");
				Иначе
					ИмяДока = СтрЗаменить(Документ,":","_");
					ИмяДока = СтрЗаменить(ИмяДока,".","_");
					АдресФайла = КаталогВременныхФайлов() + ИмяДока + ".mxl";
					Сообщить(АдресФайла);
					ОтправитьСообщениеФрагмент(АдресФайла);
					
					Письмо.Вложения.Добавить(АдресФайла,Строка(Документ));
				КонецЕсли; 
				
				Для каждого Эл Из ТаблицаВложений Цикл
					Письмо.Вложения.Добавить(Эл.ПутьКФайлу);
				КонецЦикла; 
				СредстваПочты.Послать(Письмо,ОбработкаТекстаИнтернетПочтовогоСообщения.Обрабатывать);
Показать
4. Meteorage 11 29.03.15 18:47 Сейчас в теме
(3) DitriX,
а если нет возможности использовать вэб и хттп-сервисы? работу с ФТП мобильная платформа тоже не поддерживает.
5. DitriX 2764 30.03.15 12:12 Сейчас в теме
(4) работу с ftp поддерживает при помощи утилит http://infostart.ru/public/310565/
6. Invis91 01.11.15 01:58 Сейчас в теме
(5) У всех необходимых свойств и методов классов ИнтернетПочта и ИнтернетПочтовыйПрофиль есть доступность как на Мобильном приложении-Клиенте, так и на Мобильном приложении-Сервере. Но при подключении к ящику - ошибка.
Глюк ?
7. Brook 76 19.01.16 11:30 Сейчас в теме
(6) Invis91, у меня такая же проблема. Не нашли решение?
8. Meteorage 11 29.03.16 07:29 Сейчас в теме
(7) Brook, смотри 5 сообщение, это поможет
9. Meteorage 11 16.07.16 20:19 Сейчас в теме
(3) DitriX, слушай, а как тогда получать почту?
10. DitriX 2764 24.07.16 13:10 Сейчас в теме
(9) что бы получать - тут уже только через почтовик 1С.
Конечно можно заморочится и сделать получение через API, через OAuth авторизацию, но я не делал такого, если честно.
12. silver_a 28.02.17 07:57 Сейчас в теме
(10) заморочился и настроил чтение файлов через API, через OAuth авторизацию на ЯндексДиске. Хотел получить xml файл для дальнейшего обновления информационной базы мобильного приложения. Но выходит "ошибка работы с Интернет: внутренняя ошибка сервера (500)", ошибка при выполнении файловой операции "https://downloader.disk.yandex.ru/....". Возможно, не удаётся зайти или ещё что-то. Буду разбираться. Попробую пока вариант (11).
11. sergbsv 61 03.01.17 04:08 Сейчас в теме
(3) - это для использования встроенного клиента.
для прямого обращения к почтенашел тут
http://1clancer.ru/article/otpravka_pochty_iz_mobilnogo_prilozheniya_1s_815
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Санкт-Петербург
Полный день

Программист 1С
Москва
Полный день

Удаленный программист 1С (от 800 до 1200 руб в час)
Санкт-Петербург
По совместительству

Программист 1С
Ростов-на-Дону
Полный день

Программист 1С
Москва
зарплата от 65 000 руб.
Полный день