INFOSTART EVENT 2018 EDUCATION

Второй тур голосования за доклады.
Окончание 5 сентября.

Кучма Дмитрий | Руководитель сектора программирования | Консорциум "Беркат"

«Автоматизация сети магазинов, централизация. Методика, приёмы, обучение персонала, решение проблем.»

- Причины необходимости автоматизации сети супермаркетов (ввиду децентрализации - большие затраты на персонал, снижение эффективности, отсутствие инструментов у руководителей служб и учредителей влиять на ситуацию в магазинах, плохой контроль распределения финансовых потоков и состояние фирмы в целом). - Выбор подходящего программного обеспечения, торгового оборудования, максимально эффективные и малозатратные сопряжения имеющегося оборудования и бизнес-процессов магазина с новой программой. - Определение сроков, команды внедрения, цели и задачи, средние и глобальные. - Подготовка к проекту, закуп оборудования (возможно, перетяжка сетей и замена оборудования), выбор оборудования с расчетом многолетней эксплуатации, достаточного запаса прочности. - Непосредственное внедрение, инвентаризация, ввод остатков, введение карточек товара, работа с операторами и обучение персонала. - Работа с бухгалтерской службой, настройка планов обмена, обучение персонала. - Работа с коммерческим отделом, установки цен, акции, ценники, закуп у поставщиков, категорийный менеджмент, взаимодействие с поставщиками, система лояльности покупателей. - Работа со службами магазина, по приемке товара, этикетированию, фасовкой, электронными весами, обучение кассиров и старшего кассира. -Сопровождение программы в течение первых месяцев, отладка взаимодействия служб, разбор проблем и задач. Заключение.

1. ka3a4ok 25.03.15 09:22 Сейчас в теме

Определение местоположения

Как заставить службу GPS работать в фоне постоянно?
Т.е. смысл чтоб при повторном вызове СредстваГеопозиционирования.ОбновитьМестоположение() устройство не задумывалось на 2 минуты как при первом вызове...

Версия платформы для разработки 8.3.4.437, версия мобильной платформы 8.3.4.22
Ответы
Сортировка: Древо
2. vasyak319 130 25.03.15 10:24 Сейчас в теме
(1) ka3a4ok, есть и другие способы посадить батарею за час, но раз вы выбрали именно этот, то самый очевидный способ - опрашивать чаще. Там довольно развесистые алгоритмы, которые решают, сколько всего сделать для очередного определения координат, а зависит это от времени и смещения с момента предыдущего определения.
3. ka3a4ok 25.03.15 10:44 Сейчас в теме
(2) vasyak319, за час это конечно вы утрируете... ведь например навителл не садит за час и на весь рабочий день хватает ездить по навигатору. Да это и не важно - эксплуатация в основном в автомобиле, а там есть зарядка. Важно то, что определение местоположения подвешивает программу пока провайдер не вернет координаты - это не удобно с точки зрения юзабилити. А если последнее определение местоположения было например полчаса назад, а пользователь вместе с устройством переместился за это время на энное количество километров, то устройству иногда может понадобиться ни минута и ни две, чтоб снова найти спутники.

Вобщем хочу чтоб пользователь в тот момент когда программе понадобятся координаты, не втыкал на крутящийся кружочек!
4. dj_serega 353 25.03.15 11:09 Сейчас в теме
(3) ka3a4ok, Так определение местоположения происходит в фоновом режиме. Не нужно ждать "развиса" приложения. Я советую обновить релиз приложения. Последний (92й вроде) стабильный.
5. ka3a4ok 25.03.15 11:56 Сейчас в теме
(4) dj_serega, может я просто не правильно пользуюсь...
У меня вот так:
 СредстваГеопозиционирования.ОбновитьМестоположение(ТекущийПровайдер, 60); // даже за 60 сек иногда не успевает найти спутники
 Местоположение = СредстваГеопозиционирования.ПолучитьПоследнееМестоположение(ТекущийПровайдер);

Андроидовский значек GPS вверху экрана сначала отсутствует, потом когда вызываю ОбновитьМестоположение() появляется и начинает моргать, если местоположение определено он загорается и горит еще пару сек, потом опять тухнет (т.е. устройство отключает gps). я так понимаю, он должен гореть постоянно как при использовании навитела например
6. dj_serega 353 25.03.15 14:07 Сейчас в теме
(5) ka3a4ok, У меня вот такой код есть работоспособным.
// Процедура в модуле управляемого приложения
Процедура ПриНачалеРаботыСистемы()
	#Если МобильноеПриложениеКлиент Тогда
		РаботаСГеоданнымиКлиент.ПодключитьОпросКоординат();
	#КонецЕсли
КонецПроцедуры

// Процедуры в общем модуле РаботаСГеоданнымиКлиент
#Если МобильноеПриложениеКлиент Тогда
Процедура ПодключитьОпросКоординат(Провайдер = "network") Экспорт 
	Попытка
		СекундыНаОбновление = РаботаСГеоданнымиСервер.ПолучитьПериодОпросаКоординат(); // По умолчанию 30 минут, задается в константах
		МассивПровайдеров = СредстваГеопозиционирования.ПолучитьПровайдеров();
		Инд = 0;
		Для Каждого ТекущийПровайдер Из МассивПровайдеров Цикл
			Если ТекущийПровайдер.Имя = "passive" Тогда
				Продолжить;
			КонецЕсли;
			ЧастотаОбновления = СекундыНаОбновление + Инд;
			ОписаниеОповещения = Новый ОписаниеОповещения("ОпросКоординат", РаботаСГеоданнымиКлиент);
			СредстваГеопозиционирования.ПодключитьОбработчикИзмененияМестоположения(ОписаниеОповещения, ТекущийПровайдер.Имя, , ЧастотаОбновления);
			Инд = Инд + 1;
		КонецЦикла;
		
	Исключение
		РаботаСОшибками.ЗаписатьВЛогРаботы("Ошибка получения координат. Причина: " + ОписаниеОшибки());
	КонецПопытки;
КонецПроцедуры // ПодключитьОпросКоординат
Процедура ОпросКоординат(ИмяПровайдера, ДанныеМестоположения, ДополнительныеДанные) Экспорт 
	РаботаСГеоданнымиСервер.ЗафиксироватьКоординаты(ИмяПровайдера, ДанныеМестоположения); // Тут запись в регистр сведений
КонецПроцедуры // ОпросКоординат
#КонецЕсли
Показать
matashin; tunesoft; ka3a4ok; +3 Ответить
7. ka3a4ok 25.03.15 15:48 Сейчас в теме
(6) dj_serega, благодарю! буду пробовать
10. DeniNikitin 31 08.09.16 14:09 Сейчас в теме
(6) dj_serega,
А что у вас в ДанныеМестоположения возвращается?
11. dj_serega 353 08.09.16 15:38 Сейчас в теме
(10) DeniNikitin, Посмотрите в СП по "ДанныеМестоположения" :)
8. DitriX 2764 26.03.15 11:00 Сейчас в теме
(1) я бы еще посоветовал утилиты для этой задачи использовать. Да, внешний софт, однако - работает полностью в фоне, забирать данные можно тогда, когда нужно, не будет проблем, если в середине дороги - 1с выпало в крит и ее сразу не запустили, так как в этом случае - теряется часть маршрута. Тоже самое и если вы просто свернете 1С, то андроид ее может просто убить, если ему будет мало памяти.
9. Al-77 61 31.05.16 21:20 Сейчас в теме
(8) DitriX, Какие например? если не секрет
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Санкт-Петербург
Полный день

Удаленный программист 1С (от 800 до 1200 руб в час)
Санкт-Петербург
По совместительству

Программист 1С
Ростов-на-Дону
Полный день

Программист 1С
Москва
зарплата от 65 000 руб.
Полный день

Бизнес-аналитик 1С
Санкт-Петербург
Полный день