Вопроизвести звук в мобильном приложении 1С

1. 02.04.14 17:30 Сейчас в теме
Собственно, суть
Есть мобильное приложение (под android)
Необходимо проиграть звук (хотя бы Beep), но звук не воспроизводится, если использовать ЗапуститьПриложение, то открывается сторонее окно.
Кто-нибудь решал подобную проблему?
chemezov; +1 Ответить
Вознаграждение за ответ
Показать полностью
Найденные решения
22. QuirkyKot 11.09.20 10:16 Сейчас в теме +1 $m
(20) Во первых. Звуки кидайте в папку "Android". Никаких "assets" - "Android"!
Просто в папку "Android" кидаете звуки и его архивируете, после подпихиваете ему.
В коде используете подсказку от (18),
#ЕслиМобильноеПриложениеКлиент Тогда
СредстваМультимедиа.ВоспроизвестиЗвуковоеОповещение("moizvuk",истина);
#КонецЕсли

Название звука писать без расширения.
chemezov; +1 Ответить
Остальные ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
2. Boneman 270 02.04.14 17:47 Сейчас в теме
(1) mar82, а стандартный Сигнал() на мобильном не прокатывает ?
3. mar82 02.04.14 18:05 Сейчас в теме
нет, я же написал, что Beep() не прокатывает
4. mar82 03.04.14 10:08 Сейчас в теме
По итогам вчерашних тестов могу добавить, что все 100500 методов воспроизведения, которые используют HTML 5, прекрасно работают на ПК, но нифига не работают на андроид девайсах, проверялось и на 2.3.5, и на 4.2
5. maxx 913 05.05.15 15:44 Сейчас в теме
Тоже возился со звуком на Androide не получилось файл проиграть через HTML
6. platon_ 10 05.05.15 17:26 Сейчас в теме
Доступность:

Тонкий клиент, толстый клиент, мобильное приложение(клиент).


Точно на стороне клиента выполняете?
7. DitriX 1829 10.05.15 19:49 Сейчас в теме
Можешь утилиты использовать :)
Ну или ждать пока 1с все исправит.
Это раз, а два - сигнал вроде как работает с ассетами, которые надо добавлять в компиляторе.
8. flyer 232 14.05.15 15:48 Сейчас в теме
да кстати странное поведение разработчиков не добавлять элементарные вещи которые не помешали бы.
9. mar82 19.05.15 15:19 Сейчас в теме
да в итоге проще стороннюю утилиту использовать для этого и все. Так я и сделал
будем ждать, пока 1С сделет что-то такое.
adhocprog; +1 Ответить
21. chemezov 35 25.08.20 09:53 Сейчас в теме
(9)Подскажите пожалуйста какую вы утилиту использовали?
10. Tigreno 22.06.16 19:02 Сейчас в теме
Есть информация : Что-нибудь поменялось за год ????
adhocprog; +1 Ответить
11. flyer 232 23.06.16 08:53 Сейчас в теме
ждем 8.3.9 там будем лепить внешние компоненты
12. Tigreno 23.06.16 10:44 Сейчас в теме
(11) Походу в 8.3.9 можно будет обойтись и без внешних компонент

Объекту СредстваМультимедиа мы добавили новый метод ВоспроизвестиЗвуковоеОповещение(). Он воспроизводит краткий звуковой и/или вибросигнал на мобильном устройстве. Вы можете выбрать либо стандартный звуковой сигнал, либо использовать звуковой файл, который вы включили в состав пакета мобильного приложения.
adhocprog; flyer; +2 Ответить
13. Tigreno 24.06.16 12:15 Сейчас в теме
А есть информация когда ждать эту 8.3.9 ???
14. flyer 232 24.06.16 15:54 Сейчас в теме
не думаю что летом выпустят. им лучше осенью.
15. Tigreno 16.08.16 15:04 Сейчас в теме
УРААА, оно запело.... 8.3.9.64
adhocprog; dj_serega; +2 Ответить
16. bubus 18.08.16 07:12 Сейчас в теме
(15) Tigreno, то есть мы можем в макет свой звуковой файл поместить в двоичных данных и проигрывать его? Или вы стандартный проигрывали?
adhocprog; +1 Ответить
19. chemezov 35 21.08.20 13:26 Сейчас в теме
(15) Как??? Вообще не срабатывает). Я сделал папку assets в неё положил две папки Android и iOS. В Android положил мои звуки в формате mp3. Заархивировал assets в зип. Положил в сборщике этот зип в Аудиоресурсы. Но всеравно при попытке воспроизвести звук, выдает ошибку что этого файла нету.
17. user1034395 20.08.18 10:12 Сейчас в теме
А можете написать пример процедуры, спасибо!
chemezov; +1 Ответить
18. bogdan_king 101 24.10.18 16:02 Сейчас в теме
(17) Здесь важно где и как выполняется:
1. Процедура или функция #НаКлиенте, затем внутри...

#ЕслиМобильноеПриложениеКлиент Тогда
СредстваМультимедиа.ВоспроизвестиЗвуковоеОповещение();
#КонецЕсли
AndrewVik; +1 Ответить
20. chemezov 35 21.08.20 13:55 Сейчас в теме
(18) У вас получилось? Я ваш код учел. И в сборке вроде все верно сложил, но пишет что файл такой не найден.
22. QuirkyKot 11.09.20 10:16 Сейчас в теме +1 $m
(20) Во первых. Звуки кидайте в папку "Android". Никаких "assets" - "Android"!
Просто в папку "Android" кидаете звуки и его архивируете, после подпихиваете ему.
В коде используете подсказку от (18),
#ЕслиМобильноеПриложениеКлиент Тогда
СредстваМультимедиа.ВоспроизвестиЗвуковоеОповещение("moizvuk",истина);
#КонецЕсли

Название звука писать без расширения.
chemezov; +1 Ответить
23. chemezov 35 11.09.20 23:11 Сейчас в теме
(22) ПОЛУЧИЛОСЬ!!!! СПАСИБО! Оно наконец то зазвучало :)).
Теперь надо разобраться как передать вознаграждение из этой ветки. Попробую написать топикстартеру.
На всякий случай для будущих собирателей приложения. Конфигурация мобильного приложения с режимом совместимости 8.3.14, собирал на мобильной платформе 8.3.15.105. В разрешениях включал "Воспроизведение аудио и вибрация". Возможно это всё не имеет значения, но на всякий случай оставлю эту информацию тут.
24. chemezov 35 15.09.20 09:42 Сейчас в теме
Просьба к топик стартеру, передать вознаграждение пользователю user972060
Оставьте свое сообщение
Вопросы с вознаграждением