Вывести итоги в подвал табличного поля

7. 26.09.12 13:46 Сейчас в теме
(5) PeRom, А какие именно галочки? Я что-то ничего не могу найти...
Ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
8. Cryless 05.10.12 02:50 Сейчас в теме
Воспользовался следующей конструкцией:

Процедура ПосчитатьИтогиНажатие(Элемент)
	// Вставить содержимое обработчика.
	ОбъемПродукцииВсего = 0;
	
	Для Каждого Строка Из продажиноменклатуры Цикл
		Если ЭлементыФормы.Продажи.ПроверитьСтроку(Строка) тогда
			ОбъемПродукцииВсего = ОбъемПродукцииВсего+Строка.ОбъемПродукции;
		КонецЕсли;  
	КонецЦикла;
	ЭлементыФормы.Продажи.Колонки["ОбъемПродукции"].ТекстПодвала = ОбъемПродукцииВсего;
	
КонецПроцедуры
Показать


Где продажиноменклатуры - Табличная часть
ЭлементыФормы.Продажи - Табличное поле

          Если ЭлементыФормы.Продажи.ПроверитьСтроку(Строка) тогда
			ОбъемПродукцииВсего = ОбъемПродукцииВсего+Строка.ОбъемПродукции;
		КонецЕсли;
- этот кусок нужен, если на Табличное поле задан фильтр.
1c-kt; Yasasha; Mentok; intehof; MasterTonLab; Scukosan; +6 Ответить
9. deaddy64 25 29.10.12 07:28 Сейчас в теме
Для табличного поля ставим галочку Подвал, а для колонки по которой необходимо показать итог, ставим галку ОтображатьИтогиВПодвале.
Maito; vladimir-89; О.Ж; Xo66ut; AndrewKop; nekit_rdx; sogesti; kabanoff; user621724_Dimav1979; user811769; berezin84; Yasasha; Jeka44; igor-pn; Wefast; Igor981; Dvornik; madonov; alina0587; Alex17; doctorov_s; jif; ichhh; grum01; speleolog; l2qweit; Cube033; vce@ukr.net; Xytras; Andryza; kraynev-navi; MasterTonLab; Tolpinski; +33 Ответить
28. user970589 4 21.11.20 07:27 Сейчас в теме
(9)
авим галочку Подвал, а для колонки по к

а обратное сделать можно? взять итоги из подвала и использовать в расчетах?
29. user970589 4 21.11.20 10:29 Сейчас в теме
(28)нашел
в таблице РасходПоВалу колонка СуммаКраски суммируется, итого:
ЭлементыФормы.РасходПоВалу.Колонки.СуммаКраски.ТекстПодвала;
10. Altone1976 08.11.16 08:00 Сейчас в теме
Для колонки не являющейся реквизитом , галку подвала не ставим
обращаемся к ней ЭлементыФормы.ТабПоле.Колонки.ИмяПоля.ТекстПодвала =
nekit_rdx; sogesti; Yasasha; freeek; +4 Ответить
11. serros 05.08.08 12:02 Сейчас в теме
Каким образом вывести итоги в подвал по колонке, не являющейся реквизитом документа?
12. vasilykushnir 05.08.08 13:20 Сейчас в теме
Земеля - не позорь державу. Ты поконкретней спрашивай: куда вывести, что вывести (неужели пальцы надо в дверь зажимать, чтобы ты раскололся, че те надобно?). А то получается (без обид): вот решил что-то сделать в 1с - не подскажете, как это что-то сделать.
AlexK_2012; +1 Ответить
13. CheBurator 05.08.08 14:11 Сейчас в теме
Код
ИтогПоСумме = 0;
Для ы=1 по Дофига
  ИтогПоСумме = ИтогПоСумме + ЧтоТо;
КонецЦикла;
Сообщить("итог по чему-то")
Показать полностью
14. dotBY 19.08.08 18:11 Сейчас в теме
Гы... Противная задачка, сам такие решал... Попробуй суммировать и выводить в подвал обработчиком ПриВыводеСтроки(), а еще лучше пишешь функцию, которая суммирует и вызываешь ее из обработчиков, которые отрабатывают при изменении данных, а также ПриПолученииДанных() у табличного поля... а надпись в подвале = строка и доступна она через ЭлементыУправления.ТабПоле.Колонки.ДальшеНеПомню.
15. PeRom 51 19.08.08 18:31 Сейчас в теме
Если в 8.1 в табличной части формы(тип Число), то достаточно 2 галочки поставить, и даже если не реквизит док-та.
sogesti; user712426; sules; TheIndian; +4 Ответить
16. serros 20.08.08 18:51 Сейчас в теме
Написал запрос и в наглую писал в подвал... потому как "выводить итоги в подвал" не активно...
17. lcnet 20.08.19 13:48 Сейчас в теме
Приветствую!
Вопрос тот же, но для 8.3.
Как мне вывести результат суммы в подвал колонки с числами, сумму которых надо получить?
18. AntonS 15.09.19 11:47 Сейчас в теме
(17) Не уверен, что ещё актуально, но для 8.3 у поля табличной части есть свойство "Путь к данным подвала", в нём нужно выбрать выводимое в подвал значение. При выборе "Объект" - "Имя табличной части" в списке по мимо реквизитов ТЧ если служебные поля итоги по числовым полям и количество строк - "Итог Сумма". Если его выбрать итоги сами будут выводиться в подвал
Светлый ум; +1 Ответить
19. lcnet 16.09.19 10:51 Сейчас в теме
(18)
Это справедливо для динамической таблицы?
27. Светлый ум 261 25.02.20 19:49 Сейчас в теме
(18) Еще как актуально - спасибо за съекономленое время!
20. lcnet 16.09.19 11:43 Сейчас в теме
Сори, для динамической формы
21. AntonS 16.09.19 14:13 Сейчас в теме
(20) А что Вы называете динамической формой? Вы табличную часть динамически (программно) выводите на форму или что-то другое?
22. lcnet 16.09.19 19:39 Сейчас в теме
Нет, все-таки список динамический.
Есть документ, у которого есть числовой реквизит "Стоимость".
У документа есть форма списка, содержимое которого выводиться на главную страницу.
23. lcnet 16.09.19 19:47 Сейчас в теме
Если я правильно понимаю, то нужно создать управляемую форму.
А из формы списка этого сделать нельзя.
24. Shishkibam 4 27.09.19 20:19 Сейчас в теме
Если платформа 8.2, 8.2, можно здесь посмотреть https://infofront.su/1c-vivod-itogov-v-podval-tablichnoi-chasti/
Meson; user895546; Nowa; vitonya; +4 Ответить
25. vitonya 79 23.10.19 17:50 Сейчас в теме
Единственно верный нормальный ответ.
26. ALLES 67 30.11.19 20:08 Сейчас в теме
Ну нет в табличной части в конфигураторе этого реквизита по которому надо итог посчитать
Реквизит добавлен на форме в эту таб часть
по нему НЕЛЬЗЯ в конфигураторе поставить итог через путь к данным подвала
Там просто суммы не будет в опциях из которых что то можно выбрать
Оставьте свое сообщение
Вопросы с вознаграждением