Определить тип объекта

5. 41 16.08.12 11:29 Сейчас в теме
СсылкаНаСОМОбъект.Метаданные().Name - вернет имя объекта, например "РеализацияТоваровИУслуг"
bugtester; asdfgcom; +2 Ответить
Ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
6. Sph1nX 15.05.13 15:37 Сейчас в теме
Типовая "Управление Торговлей для Украины" - есть Справочник с именем: "ЗначенияСвойствОбъектов" и РегистрСведений с тем же именем. Для конкретной идентификации типа объекта значения нужен дополнительный анализ
:(
7. Zabba 26.07.13 16:54 Сейчас в теме
8. YODDHA 49 09.08.13 00:46 Сейчас в теме
или вот так ))))

Лев(Реквизит1.Метаданные().ПолноеИмя(),5) = "Справ"

Реквизит1.Метаданные().ПолноеИмя() это даст например "Справочник.Валюты", ну и вуаля
для документов так же

Лев(Реквизит1.Метаданные().ПолноеИмя(),5) = "Докум"
GonziK_KIV; b00ker; Galimova_Alsou; +3 Ответить
9. taiba 81 12.08.13 13:51 Сейчас в теме
10. 7OH 66 11.01.14 01:23 Сейчас в теме
только ТипЗнч(ВыбранныйОбъект.Ссылка)
11. natarezn 17.05.16 14:29 Сейчас в теме
Если ТипЗнч(ЗаказыПоставщикамУТ.СтруктурнаяЕдиница) = Тип("СправочникСсылка.Кассы") Тогда
	ПостБух.СтруктурнаяЕдиница = Справочники.Кассы.НайтиПоКоду(Код);	
	Иначе	
    ПостБух.СтруктурнаяЕдиница = Справочники.БанковскиеСчета.НайтиПоКоду(Код);	

    КонецЕсли;
GonziK_KIV; +1 Ответить
12. v044771 16.06.08 12:25 Сейчас в теме
Добрый день! Реквизит может принимать значение как справочника, так и документа. Подскажите пожалуйста как определить, что значение документ, не важно какого вида.
13. Elochka 16.06.08 13:46 Сейчас в теме
ТипЗначения = ТипЗнч(ВыбранныйОбъект);
ОбъектМетаданных = Метаданные.НайтиПоТипу(ТипЗначения);
Если Метаданные.Справочники.Содержит(ОбъектМетаданных) Тогда
Сообщить("Справочник");
ИначеЕсли Метаданные.Документы.Содержит(ОбъектМетаданных) Тогда
Сообщить("Документ");
КонецЕсли;

user847462; GonziK_KIV; adhocprog; lost1623; soda; Manticor; veiuper; wolfsoft; +8 Ответить
14. O-Planet 6381 16.06.08 20:21 Сейчас в теме
И это - только один из восмерочных "улучшенных" вариантов. Ведь в 7.7 было жутко неудобно:
Если ТипЗначенияСтр(Объект)="Документ" Тогда
...
:)
ne_en; GonziK_KIV; griff19; nad0_hto; +4 Ответить
15. poppy 27.06.08 01:15 Сейчас в теме
Можно еще так написать:

Код
Если ВыбранныйОбъект = Неопределено Тогда
ИначеЕсли Справочники.ТипВсеСсылки().СодержитТип(ТипЗнч(ВыбранныйОбъект)) Тогда
   Сообщить("Справочник");
ИначеЕсли Документы.ТипВсеСсылки().СодержитТип(ТипЗнч(ВыбранныйОбъект)) Тогда
   Сообщить("Документ");
КонецЕсли;
Показать полностью
user847462; Symbiat; IlyaSR; Ivanov_OM; GonziK_KIV; Gasilin; semp89; adhocprog; Vary; ClockMaster; +10 Ответить
Оставьте свое сообщение
Вакансии
Администратор 1C
Москва
зарплата до 110 000 руб.
Полный день

Консультант-аналитик 1С
Москва
зарплата до 130 000 руб.
Полный день

Программист 1С
Москва
зарплата до 150 000 руб.
Полный день

Ведущий программист 1С
Видное
зарплата от 200 000 руб.
Временный (на проект)

Бизнес-аналитик 1С
Санкт-Петербург
зарплата от 150 000 руб. до 200 000 руб.
Полный день