как реализовать отмены рудактирования строки

1. Drizer2000 14 17.11.11 21:11 Сейчас в теме
В табличной части документа хочу сделать проверку,что не было строк с одинаковым реквизитом, в моем случае, реквизит: партия.
Использую процедуру ПеремещаемыеПартииПриОкончанииРедактирования, но почему-то ОтменаРедактирования=Истина не отменяет редактирование строки.

Процедура ПеремещаемыеПартииПриОкончанииРедактирования(Элемент, НоваяСтрока, ОтменаРедактирования)
	// Вставить содержимое обработчика.
	Отбор=Новый Структура();
	ТекСтрока = ЭлементыФормы.ПеремещаемыеПартии.ТекущаяСтрока;
	Отбор.Вставить("Партия",ТекСтрока.Партия);
	СтрокиТЗ=Перемещаемыепартии.НайтиСтроки(Отбор);
	ОтменаРедактирования=СтрокиТЗ.Количество()>1;
	Если  ОтменаРедактирования Тогда
		Предупреждение("В таблице уже есть партия:"+ТекСтрока.Партия);
	КонецЕсли;	
КонецПроцедуры
Показать
Ответы
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
2. YNik 17.11.11 22:12 Сейчас в теме
Использовать процедуру ПередОкончаниемРедактирования(Элемент, НоваяСтрока, ОтменаРедактирования, Отказ)
и устанавливать Отказ для отмены, а ОтменаРедактирования - это входной параметр, который говорит, что пользователь отменил редактирование, так что в начале процедуры ставят:
Если ОтменаРедактирования Тогда
Возврат;
КонецЕсли;
MrFlanker; Dimkis; user802485; +3 Ответить
3. Drizer2000 14 17.11.11 22:33 Сейчас в теме
(2) YNik, спасибо большое ваш способ работает.
4. Miromaxv 18.11.11 10:22 Сейчас в теме
Ух и от меня спасибо
5. Eskimos 26 27.01.22 19:26 Сейчас в теме
Спасибо! В 2022 актуально.
user802485; dnikolaev; +2 Ответить
Оставьте свое сообщение

Для получения уведомлений об ответах подключите телеграм бот:
Инфостарт бот