Открыть и заполнить обработку

1. applesound 1 20.12.23 17:58 Сейчас в теме
Добрый день.
Конфигурация УПП 1.3
Как открыть и заполнить обработку?

// создал и заполнил обработку

ОбработкаОбъект = Обработки.МояОбработка.Создать();
	
	Для каждого Строка Из ДокументОбъект.Товары Цикл
		НоваяСтрокаПрод = ОбработкаОбъект.КонечнаяПродукция.Добавить();
		ЗаполнитьЗначенияСвойств(НоваяСтрокаПрод,Строка);
		НоваяСтрокаПрод.ЗаказПокупателя = ДокументОбъект;
	КонецЦикла; 


// Открыть не получается
По теме из базы знаний
Найденные решения
4. applesound 1 21.12.23 09:40 Сейчас в теме
Решение: https://infostart.ru/1c/articles/118784/

Немного адаптировал под свои нужны

Процедура Инициализировать(Объект,ИмяТабличнойЧасти=Неопределено,ТабличноеПолеОбъекта=Неопределено) Экспорт
	
	Форма = ПолучитьФорму("Обработка.МояОбработка.Форма.Форма");
	ДанныеФормы = Форма.Объект; // Получаем объект формы в переменную
	ЗаполнитьДокументНаСервере(ДанныеФормы,Объект); // Заполняем документ на сервере
	КопироватьДанныеФормы(ДанныеФормы, Форма.Объект); // копируем наш объект в объект формы и далее открываем ее
	Форма.Открыть();
	
КонецПроцедуры

Функция ЗаполнитьДокументНаСервере(ДанныеФормы, Объект);

	ОбработкаОбъект = Обработки.МояОбработка.Создать();

	Для каждого Строка Из Объект.Товары Цикл
		НоваяСтрокаПрод = ОбработкаОбъект.КонечнаяПродукция.Добавить();
		ЗаполнитьЗначенияСвойств(НоваяСтрокаПрод,Строка);
	КонецЦикла; 

ЗначениеВДанныеФормы(ОбработкаОбъект,ДанныеФормы);

КонецФункции
Показать
Остальные ответы
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
2. independ 1538 20.12.23 21:25 Сейчас в теме
(1)
Форма=Обработки.МояОбработка.ПолучитьФорму();
Форма.Открыть();
3. applesound 1 21.12.23 09:34 Сейчас в теме
(2) так мы открываем форму новой обработки.
Цель: заполнить и открыть или открыть и заполнить.
4. applesound 1 21.12.23 09:40 Сейчас в теме
Решение: https://infostart.ru/1c/articles/118784/

Немного адаптировал под свои нужны

Процедура Инициализировать(Объект,ИмяТабличнойЧасти=Неопределено,ТабличноеПолеОбъекта=Неопределено) Экспорт
	
	Форма = ПолучитьФорму("Обработка.МояОбработка.Форма.Форма");
	ДанныеФормы = Форма.Объект; // Получаем объект формы в переменную
	ЗаполнитьДокументНаСервере(ДанныеФормы,Объект); // Заполняем документ на сервере
	КопироватьДанныеФормы(ДанныеФормы, Форма.Объект); // копируем наш объект в объект формы и далее открываем ее
	Форма.Открыть();
	
КонецПроцедуры

Функция ЗаполнитьДокументНаСервере(ДанныеФормы, Объект);

	ОбработкаОбъект = Обработки.МояОбработка.Создать();

	Для каждого Строка Из Объект.Товары Цикл
		НоваяСтрокаПрод = ОбработкаОбъект.КонечнаяПродукция.Добавить();
		ЗаполнитьЗначенияСвойств(НоваяСтрокаПрод,Строка);
	КонецЦикла; 

ЗначениеВДанныеФормы(ОбработкаОбъект,ДанныеФормы);

КонецФункции
Показать
Оставьте свое сообщение

Для получения уведомлений об ответах подключите телеграм бот:
Инфостарт бот