При продаже пива Преобразование значения к типу Булево не может быть выполнено

1. zoeh 31 20.04.23 04:39 Сейчас в теме
Продажа Прокатывает если разрешить продажу бес сопоставления егаис и выбрать товар вручную, я думаю все таки дело в релизе, т.к. уже второй косяк всплыл, первый это двойные единицы измерения

"{ОбщийМодуль.РозничныеПродажиКлиентСервер.Модуль(75)}: Преобразование значения к типу Булево не может быть выполнено",
[
"ScriptRuntimeError",
"ScriptUseError"
],
"",
""
]
],
"stack": [
[
"Документ.ЧекККМ.Форма.ФормаОплатыНаличными.Форма",
299,
"\u0009Закрыть(РезультатОплаты);"
],
[
"Документ.ЧекККМ.Форма.ФормаДокументаРМК.Форма",
3998,
"\u0009ОбработатьДобавлениеОплаты(ДополнительныеПараметры);"
],
[
"Документ.ЧекККМ.Форма.ФормаДокументаРМК.Форма",
4193,
"\u0009\u0009\u0009\u0009ПробитьЧек();"
],
[
"Документ.ЧекККМ.Форма.ФормаДокументаРМК.Форма",
1792,
"\u0009\u0009НСтр(\"ru = \u0027Перед выполнением операции пробития чека не удалось записать документ.\u0027\"));"
],
[
"Документ.ЧекККМ.Форма.ФормаДокументаРМК.Форма",
4462,
"\u0009\u0009ВыполнитьОбработкуОповещения(ОповещениеПриЗавершении, Истина);"
],
[
"Документ.ЧекККМ.Форма.ФормаДокументаРМК.Форма",
1799,
"\u0009ПараметрыОперацииФискализацииЧека = ПараметрыОперацииФискализацииЧека();"
],
[
"Документ.ЧекККМ.Форма.ФормаДокументаРМК.Форма",
1769,
"\u0009Возврат ПараметрыОперацииФискализацииЧекаНаСервере();"
],
[
"Документ.ЧекККМ.Форма.ФормаДокументаРМК.Форма",
1762,
"\u0009Возврат ПараметрыОперацииФискализацииЧекаНаСервереЛокализация();"
],
[
"Документ.ЧекККМ.Форма.ФормаДокументаРМК.Форма",
5729,
"\u0009ФормированиеПараметровФискальногоЧекаСервер.ОбновитьПараметрыФискальногоЧекаПозицийЧекаККМ(ПараметрыОперацииФискализацииЧека, Объект.Ссылка);"
],
[
"ОбщийМодуль.ФормированиеПараметровФискальногоЧекаСервер.Модуль",
223,
"\u0009ФормированиеПараметровФискальногоЧекаСерверПереопреде­ляемый.ОбновитьПараметрыФискальногоЧекаПозицийЧекаККМ(ПараметрыФискальногоЧека, ДокументСсылка);"
],
[
"ОбщийМодуль.ФормированиеПараметровФискальногоЧекаСерверПереопределяемый.Модуль",
414,
"\u0009ПараметрыФискальныхСтрокЧека = ПараметрыФискальныхСтрокЧека(ПредметыРасчетов.Товары, ПредметыРасчетов.ДанныеДляИСМП, ПараметрыФискальногоЧека);"
],
[
"ОбщийМодуль.ФормированиеПараметровФискальногоЧекаСерверПереопределяемый.Модуль",
1069,
"\u0009\u0009\u0009СтрокаПозицииЧека.ПризнакПредметаРасчета = РозничныеПродажиКлиентСервер.ПризнакПредметаРасчетаФискальнойОперации("
],
[
"ОбщийМодуль.РозничныеПродажиКлиентСервер.Модуль",
75,
"\u0009\u0009\u0009\u0009\u0009И РозничныеПродажиВызовСервера.АлкогольнаяПродукцияЕГАИСМаркируемая(СтрокаПозицииЧека.НоменклатураЕГАИС) Тогда"
]
Показать
По теме из базы знаний
Ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
8. bladeson 14.05.23 06:25 Сейчас в теме
(1) Не нашли, в чем причина проблемы? Столкнулся с тем же самым...
9. zoeh 31 18.05.23 08:40 Сейчас в теме
(8)По моему надо убрать галочку подакцизный товар
10. bladeson 18.05.23 09:14 Сейчас в теме
(9)
(9) К сожалению некорректно будет. У нас та же проблема, но с крепким алкоголем
11. zoeh 31 18.05.23 09:17 Сейчас в теме
(10)Мое раширение не помогло, надо копать по этим модулям дальше, у меня решилось галочкой я бросил. могу скинуть, но оно кривое.
2. zoeh 31 20.04.23 04:42 Сейчас в теме
К.А. 2.5.11.96
ошибка выходит в момент печати чека
по моему проблема вот в этом значении
РозничныеПродажиКлиентСервер.ПризнакПредметаРасчетаФискальнойОперации(
как ему задать булево в базе? откуда вообще он берет этот признак.

товар прбовал сравниал с другими перезаписывал сопоставление ЕГАИС чистил
3. ImHunter 277 20.04.23 07:01 Сейчас в теме
(1) Насколько я понял по стеку, РозничныеПродажиВызовСервера.АлкогольнаяПродукцияЕГАИСМаркируемая(...) возвращает не Булево.
4. zoeh 31 21.04.23 07:30 Сейчас в теме
в функции нет вовзрата КАРЛ!!!!!

Функция АлкогольнаяПродукцияЕГАИСМаркируемая(НоменклатураЕГАИС) Экспорт
	
	РозничныеПродажиЛокализация.АлкогольнаяПродукцияЕГАИСМаркируемая(НоменклатураЕГАИС);
	
КонецФункции



Функция АлкогольнаяПродукцияЕГАИСМаркируемая(НоменклатураЕГАИС) Экспорт
	
	//++ Локализация
	
	Запрос = Новый Запрос;
	Запрос.Текст =
	"ВЫБРАТЬ
	|	КлассификаторАлкогольнойПродукцииЕГАИС.Ссылка КАК Ссылка,
	|	КлассификаторАлкогольнойПродукцииЕГАИС.ВидПродукции КАК ВидПродукции,
	|	КлассификаторАлкогольнойПродукцииЕГАИС.ВидПродукции.Маркируемый КАК ВидПродукцииМаркируемый
	|ИЗ
	|	Справочник.КлассификаторАлкогольнойПродукцииЕГАИС КАК КлассификаторАлкогольнойПродукцииЕГАИС
	|ГДЕ
	|	КлассификаторАлкогольнойПродукцииЕГАИС.Ссылка = &НоменклатураЕГАИС
	|	И КлассификаторАлкогольнойПродукцииЕГАИС.ВидПродукции.Маркируемый = ИСТИНА";
	Запрос.УстановитьПараметр("НоменклатураЕГАИС", НоменклатураЕГАИС);
	
	Выборка = Запрос.Выполнить().Выбрать();
	
	Если Выборка.Следующий() Тогда
		Возврат Истина;
	Иначе
		Возврат Ложь;
	КонецЕсли;
	
	//-- Локализация
	
	Возврат Ложь;
	
КонецФункции
Показать
5. ImHunter 277 21.04.23 09:19 Сейчас в теме
(4) Это кривовато:
Выборка = Запрос.Выполнить().Выбрать();

Если Выборка.Следующий() Тогда
Возврат Истина;
Иначе
Возврат Ложь;
КонецЕсли;
Показать

Лучше:
РезультатЗапроса = Запрос.Выполнить();
Возврат Не РезультатЗапроса.Пустой();
6. AlexandrSmith 68 21.04.23 10:40 Сейчас в теме
Мне понравилось название темы!!!
7. AlexandrSmith 68 21.04.23 10:42 Сейчас в теме
(2) Поставьте отладку по ошибке, не будет мнения, а будет четкое значение и увидите проблему.
12. bladeson 18.05.23 09:22 Сейчас в теме
(11) Не надо, спс! Пинаю саппорт, пытаюсь, если будет результат - отпишусь. В 1С саппорт великий, файл отчета об ошибке .json открыть не могут...
13. zoeh 31 18.05.23 09:37 Сейчас в теме
(12), лет через 10 напишешь че ответлили?
bladeson; +1 Ответить
14. bladeson 18.05.23 09:50 Сейчас в теме
15. bladeson 04.06.23 06:54 Сейчас в теме
(13) Обновил утром конфу до KA 2.2.12.64 и платформу до 8.3.23.1688, всё заработало. А саппорт до сих пор "работает" над заявкой)))
Оставьте свое сообщение
Вакансии
Аналитик
Москва
зарплата от 150 000 руб.
Полный день

Разработчик 1С
Москва
зарплата от 150 000 руб.
Полный день

Разработчик 1С:ERP WE
Москва
зарплата от 250 000 руб.
Полный день

Аналитик 1С:ЗУП
Москва
зарплата от 150 000 руб.
Полный день

Программист 1С
Москва
зарплата от 130 000 руб. до 170 000 руб.
Полный день