Отправка сообщений на email

1. Geophysic 06.02.23 08:40 Сейчас в теме
Здравствуйте, подскажите пожалуйста как настроить так, чтобы когда email указан одинаковый(email отбирается по ответственному)
договора этих ответственных попадали в одно письмо и отправлялось одно письмо, а не например два письма?
По теме из базы знаний
Найденные решения
2. user5300 1035 06.02.23 10:17 Сейчас в теме
Функция ВыполнитьРассылку(ДатаРассылки) Экспорт

	СписокПолучивших = "";

	Если ЭтотОбъект.Договоры.Количество() = 0 Тогда
		Возврат СписокПолучивших;
	КонецЕсли;

	
    Конст = Константа.ЗаголовокСистемы.Получить();
	ЗаголовокПрограммы = "Комплексная " + ?(ЗначениеЗаполнено(Конст),Конст,"Общая");
	
	
	
	НужныеСтроки = ЭтотОбъект.Договоры.НайтиСтроки(Новый Структура("ОК",Истина));
	
	МассивМенеджеров = ЭтотОбъект.Договоры.Выгрузить(НужныеСтроки,"Ответственный");
	МассивМенеджеров.Свернуть("Ответственный");

	
	Для каждого Менеджер Из МассивМенеджеров Цикл

		Если Менеджер.Пустая()  Тогда
			Продолжить;
		КонецЕсли;

		ТекстСписка = "";
		ТекстПисьма = "";
		Адрес = "";

		Счетчик = 1;
		МассДоговоры = ЭтотОбъект.Договоры.НайтиСтроки(Новый Структура("Менеджер, ОК",Ответственный,Истина));
		
		Для каждого СтрТЧ Из МассДоговоры Цикл
			ТекстСписка = ТекстСписка + Формат(Счетчик,"ЧГ=0") + СтрТЧ.СпрСсылка + Символы.ПС;			
			Адрес = СтрТЧ.Адрес;
			Счетчик = Счетчик + 1;
		КонецЦикла;

		Если не ЗначениеЗаполнено(Адрес) Тогда
			Продолжить;
		КонецЕсли;
		
		ТекстПисьма = ТекстПисьмаВФорматеHTML(Менеджер, ДатаРассылки, ТекстСписка, ЗаголовокПрограммы);

		Если СозданиеИОтправкаПисьма(Адрес, ТекстПисьма) Тогда
			СписокПолучивших = СписокПолучивших + Менеджер + Символы.ПС;
		КонецЕсли;

	КонецЦикла;

	Возврат СписокПолучивших;

КонецФункции 
Показать
Остальные ответы
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
2. user5300 1035 06.02.23 10:17 Сейчас в теме
Функция ВыполнитьРассылку(ДатаРассылки) Экспорт

	СписокПолучивших = "";

	Если ЭтотОбъект.Договоры.Количество() = 0 Тогда
		Возврат СписокПолучивших;
	КонецЕсли;

	
    Конст = Константа.ЗаголовокСистемы.Получить();
	ЗаголовокПрограммы = "Комплексная " + ?(ЗначениеЗаполнено(Конст),Конст,"Общая");
	
	
	
	НужныеСтроки = ЭтотОбъект.Договоры.НайтиСтроки(Новый Структура("ОК",Истина));
	
	МассивМенеджеров = ЭтотОбъект.Договоры.Выгрузить(НужныеСтроки,"Ответственный");
	МассивМенеджеров.Свернуть("Ответственный");

	
	Для каждого Менеджер Из МассивМенеджеров Цикл

		Если Менеджер.Пустая()  Тогда
			Продолжить;
		КонецЕсли;

		ТекстСписка = "";
		ТекстПисьма = "";
		Адрес = "";

		Счетчик = 1;
		МассДоговоры = ЭтотОбъект.Договоры.НайтиСтроки(Новый Структура("Менеджер, ОК",Ответственный,Истина));
		
		Для каждого СтрТЧ Из МассДоговоры Цикл
			ТекстСписка = ТекстСписка + Формат(Счетчик,"ЧГ=0") + СтрТЧ.СпрСсылка + Символы.ПС;			
			Адрес = СтрТЧ.Адрес;
			Счетчик = Счетчик + 1;
		КонецЦикла;

		Если не ЗначениеЗаполнено(Адрес) Тогда
			Продолжить;
		КонецЕсли;
		
		ТекстПисьма = ТекстПисьмаВФорматеHTML(Менеджер, ДатаРассылки, ТекстСписка, ЗаголовокПрограммы);

		Если СозданиеИОтправкаПисьма(Адрес, ТекстПисьма) Тогда
			СписокПолучивших = СписокПолучивших + Менеджер + Символы.ПС;
		КонецЕсли;

	КонецЦикла;

	Возврат СписокПолучивших;

КонецФункции 
Показать
Оставьте свое сообщение

Для получения уведомлений об ответах подключите телеграм бот:
Инфостарт бот