Com соединение и значение перечисления

1. 21.06.22 11:53 Сейчас в теме
Пытаюсь обменяться с базой через Com соединение, но не видит значение перечисления СтавкаНДС. Что можно предпринять?
П.С. Я понимаю, что ком соединение уже устарело, но пока что нужно сделать через него=))
Прикрепленные файлы:
Найденные решения
5. user673778_karavaykov 21.06.22 15:33 Сейчас в теме
Вот так решил. Спасибо за помощь

	
V8 = Новый COMобъект("V83.ComConnector");
	СтрокаСоединения = "File = '" +ВремПуть+"'; Usr = '" + ВремПольз+"'; Pwd = '"+ВремПароль+"'";
	
	Попытка
		БазаУТ = V8.Connect(СтрокаСоединения);
		БазаОткрыта = Истина
	Исключение
		Сообщение = Новый СообщениеПользователю;
		Сообщение.Текст = "Не удалось подключиться к базе" + ОписаниеОшибки();
		Сообщение.Сообщить();
	КонецПопытки;


// Товары
	Если ДокУТ.Товары.Количество() > 0 Тогда
		Для Каждого СтрокаУТ Из ДокУТ.Товары Цикл
		
			НовСтрока = ДокБП.Товары.Добавить();
			
			НовСтрока.Номенклатура = ВернутьНоменклатуру(СтрокаУТ.Номенклатура);
						
			НовСтрока.Количество = СтрокаУТ.Количество;
			НовСтрока.Цена 		 = СтрокаУТ.Цена;
			НовСтрока.Сумма 	 = СтрокаУТ.Сумма;
			
			ЭлементПеречисления = СтрокаУТ.СтавкаНДС;
			СтрокаЭлементПеречисления = ЭлементПеречисления.Метаданные().Имя;
			СтрокаЭлементПеречисления = БазаУТ.XMLСтрока(ЭлементПеречисления);
			НовСтрока.СтавкаНДС = Перечисления.СтавкиНДС[СтрокаЭлементПеречисления];
			НовСтрока.СуммаНДС   = СтрокаУТ.СуммаНДС;
			
					КонецЦикла;
	КонецЕсли;
Показать
Остальные ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
2. RustamZz 21.06.22 11:58 Сейчас в теме
(1) Сравнивать с перечислением полученным так же через COM. Зачем вам видеть?
3. Pavel Rodinchenko 21.06.22 12:18 Сейчас в теме
4. makaorel 54 21.06.22 13:02 Сейчас в теме
5. user673778_karavaykov 21.06.22 15:33 Сейчас в теме
Вот так решил. Спасибо за помощь

	
V8 = Новый COMобъект("V83.ComConnector");
	СтрокаСоединения = "File = '" +ВремПуть+"'; Usr = '" + ВремПольз+"'; Pwd = '"+ВремПароль+"'";
	
	Попытка
		БазаУТ = V8.Connect(СтрокаСоединения);
		БазаОткрыта = Истина
	Исключение
		Сообщение = Новый СообщениеПользователю;
		Сообщение.Текст = "Не удалось подключиться к базе" + ОписаниеОшибки();
		Сообщение.Сообщить();
	КонецПопытки;


// Товары
	Если ДокУТ.Товары.Количество() > 0 Тогда
		Для Каждого СтрокаУТ Из ДокУТ.Товары Цикл
		
			НовСтрока = ДокБП.Товары.Добавить();
			
			НовСтрока.Номенклатура = ВернутьНоменклатуру(СтрокаУТ.Номенклатура);
						
			НовСтрока.Количество = СтрокаУТ.Количество;
			НовСтрока.Цена 		 = СтрокаУТ.Цена;
			НовСтрока.Сумма 	 = СтрокаУТ.Сумма;
			
			ЭлементПеречисления = СтрокаУТ.СтавкаНДС;
			СтрокаЭлементПеречисления = ЭлементПеречисления.Метаданные().Имя;
			СтрокаЭлементПеречисления = БазаУТ.XMLСтрока(ЭлементПеречисления);
			НовСтрока.СтавкаНДС = Перечисления.СтавкиНДС[СтрокаЭлементПеречисления];
			НовСтрока.СуммаНДС   = СтрокаУТ.СуммаНДС;
			
					КонецЦикла;
	КонецЕсли;
Показать
6. ignorant 22.06.22 16:48 Сейчас в теме
(5) а так?
БазаПолучатель.Перечисления.ВидыОперацийСписаниеДенежныхСредств.ПеречислениеНалога
Оставьте свое сообщение
Вакансии
Консультант-аналитик 1С
Москва
зарплата от 120 000 руб. до 190 000 руб.
Полный день

Ведущий аналитик-разработчик 1С
Москва
зарплата от 230 000 руб. до 270 000 руб.
Полный день

1С:Эксперт по производительности
Москва
зарплата от 400 000 руб. до 950 000 руб.
Полный день

Ведущий аналитик 1С (ERP, ЗУП)
Краснодар
зарплата от 150 000 руб.
Полный день

Разработчик 1С
Тверь
зарплата от 150 000 руб. до 250 000 руб.
Полный день