Как вывести данные в табличную часть формы?

1. 13.01.22 20:46 Сейчас в теме
Есть отчет, в нем табличная часть. Как обратиться к реквизиту тч?

Нужно чтобы при открытии отчета он заполнялся данными с выборки
Форма


Код модуля формы:
&НаСервере
Процедура ПриОткрытииНаСервере()
  
  Запрос = Новый Запрос;
  Запрос.Текст = 
    "ВЫБРАТЬ
    |	ПодпискиПользователейСрезПоследних.Пользователь КАК Пользователь,
    |	ПодпискиПользователейСрезПоследних.Подписка КАК Подписка,
    |	ПодпискиПользователейСрезПоследних.ДатаОкончания КАК ДатаОкончания
    |ИЗ
    |	РегистрСведений.ПодпискиПользователей.СрезПоследних КАК ПодпискиПользователейСрезПоследних";
  
  РезультатЗапроса = Запрос.Выполнить();
  
  ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
  
  Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
    //Отчет.Подписки.ПодпискиПользователь = ВыборкаДетальныеЗаписи.Пользователь; 
    //Отчет.Подписки.ПодпискиПодписка= ВыборкаДетальныеЗаписи.Подписка; 
  КонецЦикла;
  
КонецПроцедуры

&НаКлиенте
Процедура ПриОткрытии(Отказ)
  ПриОткрытииНаСервере();
КонецПроцедуры
Показать
Найденные решения
5. Mag1strate 14.01.22 14:39 Сейчас в теме
Через Динамический Список все делается
Остальные ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
3. lefthander 14.01.22 09:07 Сейчас в теме
(1)
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
//Отчет.Подписки.ПодпискиПользователь = ВыборкаДетальныеЗаписи.Пользователь;
//Отчет.Подписки.ПодпискиПодписка= ВыборкаДетальныеЗаписи.Подписка;
КонецЦикла;


Подписки = Отчет.Подписки;
Пока .... цикл
НС= Подписки.Добавить();
НС.Пользователь = ВыборкаДетальныеЗаписи.Пользователь;
НС.Подписка = ВыборкаДетальныеЗаписи.Подписка;
КонецЦикла;


Как то так. ;)
4. Bukaska 138 14.01.22 10:41 Сейчас в теме
(1)Картинки прикрепите на форуме, не где-то)
2. Bosma 69 14.01.22 09:07 Сейчас в теме
Табличные части - это данные объекта, соответственно и обращение к ним возможно через объект.

НоваяСтрока = Объект.Подписки.Добавить();
НоваяСтрока.Подписка = 
.......
5. Mag1strate 14.01.22 14:39 Сейчас в теме
Через Динамический Список все делается
Оставьте свое сообщение
Вопросы с вознаграждением
Вакансии
Аналитик 1С
Санкт-Петербург
зарплата до 150 000 руб.
Полный день

Руководитель отдела разработки
Москва
зарплата от 200 000 руб. до 230 000 руб.
Полный день

Программист 1С
Москва
зарплата от 150 000 руб. до 150 000 руб.
Полный день

Консультант-аналитик 1С
Москва
зарплата от 100 000 руб. до 120 000 руб.
Полный день

Программист, аналитик, эксперт 1С
Санкт-Петербург
По совместительству