Присвоение номеров строк

1. 2 14.09.21 19:20 Сейчас в теме
Сделал для номера строки отдельную колонку в табличном поле. Как заполнить и вывести ее?
Ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
2. Begemot39 2 14.09.21 19:30 Сейчас в теме
(1)

можно подробности?)
НомерСтроки - стандартный реквизит табличной части, который эска создаёт в момент создания той самой табличной части...
3. sergqwert15 2 14.09.21 19:36 Сейчас в теме
Колонку № строки я скрыл, добавил на табличном поле НомерСтроки. Сделал это из-за того что была неправильная нумерация строк в обработке(перенумеровывались строки неправильно).
4. nomad_irk 57 14.09.21 19:56 Сейчас в теме
(3)Что значит "неправильная нумерация строк"? Что значит "перенумеровались строки неправильно"? Как вы определяете правильность номеров строк в ТЧ?
5. sergqwert15 2 14.09.21 19:58 Сейчас в теме
Событие ПриПолученииДанных не отрабатывает как надо:
сч = 0;
Для каждого ОформлениеСтроки Из ОформленияСтрок Цикл

Сч = Сч + 1;
ОформлениеСтроки.Ячейки.НомерСтроки.УстановитьТекст( "" + Сч);

КонецЦикла;
Эта конструкция заполняет номера строк неправильно, ставит 1 2 3 4 5 6 1 1 1 .
6. nomad_irk 57 14.09.21 19:59 Сейчас в теме
(5)зачем вы вообще ставите номера строк "вручную"?
DJ_Codebase; +1 Ответить
11. Vitaly1C8 15.09.21 15:27 Сейчас в теме
(5) а зачем свой счетчик используется ? Сч = Сч + 1
Вместо этого надо брать ОформлениеСтроки.Ячейки.НомерСтроки. <??? ПолучитьЗначение>
(точно не помню какое там свойство - посмотри в Отладчике чему равно ОформлениеСтроки.Ячейки.НомерСтроки)
7. sergqwert15 2 14.09.21 20:01 Сейчас в теме
1с обновляет строки по этому методу только те, которые рисуются на экране и выводит 111
9. slavyan_arena 15.09.21 05:28 Сейчас в теме
(7)
Здравствуйте.

Если вам уж очень нужна своя нумерация...

то добавьте реквизит в табличную часть документа и заполняйте номера не на клиенте, а на сервере

Для каждого ОформлениеСтроки Из ОформленияСтрок Цикл

Сч = Сч + 1;
ОформлениеСтроки.Ячейки.НомерСтроки.УстановитьТекст( "" + Сч);

КонецЦикла;


здесь вы оформляете строку, а не записываете данные табличной части
8. FatPanzer 14 14.09.21 20:05 Сейчас в теме
Слушай, я наконец-то понял ту поговорку про кота, который яйца лижет!
DJ_Codebase; +1 Ответить
10. SlavaKron 15.09.21 09:53 Сейчас в теме
Иногда, когда табличное поле связано с таблицей значений, требуется своего рода колонка с номером строки, как в табличной части.
Можно сделать так:
Процедура ТЗПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
	ИндексСтроки = ТЗ.Индекс(ДанныеСтроки);
	ОформлениеСтроки.Ячейки.НомерСтроки.Значение = ИндексСтроки + 1;
КонецПроцедуры
Оставьте свое сообщение
Вопросы с вознаграждением
Вакансии
Программист 1С
Новосибирск
зарплата от 90 000 руб.
Полный день

Программист 1С
Екатеринбург
зарплата от 100 000 руб. до 150 000 руб.
Полный день

Программист 1С
Москва
зарплата от 230 000 руб. до 230 000 руб.
Полный день

Программист 1С
Москва
зарплата от 100 000 руб. до 140 000 руб.
Полный день

Программист 1С
Хабаровск
зарплата от 130 000 руб. до 160 000 руб.
Полный день