отладка веб сервиса 8.3

1. 178 14.01.21 10:19 Сейчас в теме
Из дописанной торговли в почти типовую бухгалтерию выгружаю накладные через web сервис.
Документы создаются в бухгалтерии, но ответ в торговлю приходит не полный из-за чего возникает ошибка в торговле.
Не получается подключиться к web сервису из торговли.
База бухгалтерии опубликована на IIS. на srv3
ib="Srvr="srv3:1541";Ref="Acc_Test";">
<debug enable="true" protocol="tcp" url="tcp://localhost"/>
Запускаю на srv2 торговлю (сидит на srv3:1741) и конфигуратор бухгалтерию (сидит srv3:1541)и не попадаю в точку остановки в бухгалтерии в web сервисе операция "выполнить код"
В папке bin/conf на srv2
debugcfg.xml
<config xmlns="http://v8.1c.ru/v8/debugcfg">
<debugports range="1560:1791"/>
</config>
comcntrcfg.xml
<config xmlns="http://v8.1c.ru/v8/comcntrcfg">
<debugconfig debug="true" debuggerURL="tcp://localhost:1560" />
</config>
внешнимОтладка на сервере включена и работает, автоматическое подключение в отладке к клиентским подключениям/web сервисам поставлено и там и там.
Что упустил?
Найденные решения
16. tolyan_ekb 178 14.01.21 12:55 Сейчас в теме
Всем спасибо. Оказалось были закрыты порты для платформы бухгалтерии. Для платформы торговли они были открыты и отладка работала. Нашел, когда уже решил отладить веб сервис через обработку в базе бухгалтерии и оказалось что на сервер не захожу.
Остальные ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
3. koln 14.01.21 10:46 Сейчас в теме
(1)А предметы отладки (сервер, клиент и т.п.) подключаются?
4. tolyan_ekb 178 14.01.21 10:47 Сейчас в теме
(3)свои клиент и сервер вижу в торговле, ничего дополнительно ничего нет
6. koln 14.01.21 10:49 Сейчас в теме
(4)В конфигураторе Бухгалтерии есть подключенные предметы отладки? Вы ведь хотите отлаживать код на стороне Бухгалтерии, так?
7. tolyan_ekb 178 14.01.21 10:51 Сейчас в теме
(6) первый раз отладкой веб сервисов занимаюсь. Все делаю в торговле. У бухгалтерии только конфигуратор открыт, в который я так понимаю должен перейти автоматически.
8. koln 14.01.21 10:55 Сейчас в теме
(7)На стороне Бухгалтерии должна быть так же включена отладка и установите "галку" для автоматической подключения отладки веб-сервиса
Прикрепленные файлы:
10. tolyan_ekb 178 14.01.21 10:57 Сейчас в теме
11. koln 14.01.21 10:59 Сейчас в теме
(10)На стороне Бухгалтерии, в нижнем окне есть предметы отладки (сервер, веб-сервис)?
12. tolyan_ekb 178 14.01.21 11:00 Сейчас в теме
(11) нет чистое окно. Нужно смотреть в момент отправки из торговли? Или нужно как-то из бухгалтерии запускать?
13. koln 14.01.21 11:05 Сейчас в теме
(12)А в конфигураторе "галки" установлены?
Прикрепленные файлы:
14. tolyan_ekb 178 14.01.21 11:43 Сейчас в теме
2. mao_san 14.01.21 10:34 Сейчас в теме
Может банально отвалилась отладка на сервере? Такое случается, порой помогает только перезапуск 1С сервера.
2. andy_zhav 188 14.01.21 10:34 Сейчас в теме
(1) попробуйте вместо tcp://localhost указать конкретный ip адрес или доменное имя сервера
5. tolyan_ekb 178 14.01.21 10:49 Сейчас в теме
(2) в код на сервере заходит перед отправкой в веб сервис
9. tolyan_ekb 178 14.01.21 10:55 Сейчас в теме
(2) изменил на <debug enable="true" protocol="tcp" url="tcp://srv3"/> результат такой же, может неправильно отлаживаю?
15. tolyan_ekb 178 14.01.21 11:43 Сейчас в теме
Может это быть из-за того что платформы разные и кластера серверов разные?
16. tolyan_ekb 178 14.01.21 12:55 Сейчас в теме
Всем спасибо. Оказалось были закрыты порты для платформы бухгалтерии. Для платформы торговли они были открыты и отладка работала. Нашел, когда уже решил отладить веб сервис через обработку в базе бухгалтерии и оказалось что на сервер не захожу.
Оставьте свое сообщение
Вопросы с вознаграждением