Публикация 1с8 х64 на IIS

1. SantiouS 12.08.20 10:13 Сейчас в теме
Хочу опубликовать свой HTTP-сервис на веб сервере IIS.
Установил Win Server 2016 IIS, и опубликовал свой HTTP-сервис через конфигуратор 1с8, но при переходе на него получаю ошибку:
"Обработчик "1C Web-service Extension" содержит поврежденный модуль "IsapiModule" в списке модулей"
Почитал ряд статей в интернете о том что может быть проблема в том, что сервер 1с8 х64 и что для него нужно устанавливать другие настройки. Все их проверил - все хорошо, но не работает. Подскажите пожалуйста, в чём может быть проблема? Как решать?
Ниже прикрепляю скрины всех настроек.
Прикрепленные файлы:
Найденные решения
7. SantiouS 12.08.20 10:49 Сейчас в теме
(5) Спасибо большое. Помогло!
Нужно было доустановить эти компоненты (скрин).
Прикрепленные файлы:
visunwer; korppinen; Dimka74; Dobro210; fixin; MAleksey1712; tanat74; IvanSch; esqado; movled; AlbinaAAA; Unknown31; nnn123; EugeneMIPT; Socradt; fuser; ra9000; +17 Ответить
5. ignorant 12.08.20 10:37 Сейчас в теме
При публикации у вас какое-то странное имя каталога R _много пробелов_

ASP Вам не нужен. Достаточно ISAPI
https://infostart.ru/1c/articles/275820/
user673778_karavaykov; mitry; IvanSch; AlbinaAAA; SantiouS; +5 Ответить
Остальные ответы
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
2. SantiouS 12.08.20 10:14 Сейчас в теме
Ещё скрины
Прикрепленные файлы:
3. ignorant 12.08.20 10:25 Сейчас в теме
Компоненты так включены?
Прикрепленные файлы:
4. SantiouS 12.08.20 10:27 Сейчас в теме
(3) Вот здесь ASP установил (скрин аналогичный в шапке). Или это не оно? Подскажите тогда где смотреть)
Прикрепленные файлы:
5. ignorant 12.08.20 10:37 Сейчас в теме
При публикации у вас какое-то странное имя каталога R _много пробелов_

ASP Вам не нужен. Достаточно ISAPI
https://infostart.ru/1c/articles/275820/
user673778_karavaykov; mitry; IvanSch; AlbinaAAA; SantiouS; +5 Ответить
6. SantiouS 12.08.20 10:38 Сейчас в теме
(5) Я просто очистил название базы ластиком :)
7. SantiouS 12.08.20 10:49 Сейчас в теме
(5) Спасибо большое. Помогло!
Нужно было доустановить эти компоненты (скрин).
Прикрепленные файлы:
visunwer; korppinen; Dimka74; Dobro210; fixin; MAleksey1712; tanat74; IvanSch; esqado; movled; AlbinaAAA; Unknown31; nnn123; EugeneMIPT; Socradt; fuser; ra9000; +17 Ответить
8. esqado 30.08.22 13:44 Сейчас в теме
(7) для win10(11)
Прикрепленные файлы:
9. fixin 4259 24.02.23 21:22 Сейчас в теме
(7) Да, именно этого и не хватало серверу.
10. ks8585 3 01.10.23 07:39 Сейчас в теме
После установки этих компонентов стал выдавать 500 ошибку(
12. starik-2005 3051 01.10.23 16:52 Сейчас в теме
(10)
После установки этих компонентов стал выдавать 500 ошибку(
Ну так зайди в конфигуратор под администратором и переопубликуй.
11. I love pivo 01.10.23 14:47 Сейчас в теме
(10) попробуй пулы приложений - твой пул (по умолчанию DefaultAppPool). - режим управления - классический (вместо "встроенный")
смотри на картинке "пулы приложений" в вышеупомянутой статье. Там стоит встроенный. Попробуй поменять на классический. Естественно IIS после этого рестартануть
Оставьте свое сообщение

Для получения уведомлений об ответах подключите телеграм бот:
Инфостарт бот