1. 1Eset 30.06.20 13:46 Сейчас в теме

Как очистить поле формы ПриСозданииНаСервере?

Есть Реквизит, у которого есть сохранения заполненных данных, чтобы пользователь мог их заполнить потом, но беда в том, что когда создаешь новый Документ, то получается такая байда, что данные, которые вводились в предыдущий документ, отображаются и в этом. Я как только не мучил процедуру ПриСозданииНаСервере, но я так понимаю, что данные на форме это данные НаКлиенте, и желательно не делать кнопок, которые бы это делали, а прямо при создании документа очистить необходимые поля формы.

Подскажите пожалуйста.
Найденные решения
4. areavel 30.06.20 14:03 Сейчас в теме
проверку делайте если новый документ тогда очищать
5. areavel 30.06.20 14:05 Сейчас в теме
Если НЕ Параметры.Ключ.Пустая() Тогда
...
КонецЕсли;
9. 1Eset 30.06.20 17:42 Сейчас в теме
(5) Спасибо Ваш вариант лучший, сделал проверку, только без не.

И дополнительно ПриЗаписи прописал присвоение уникального идентификатора


&НаКлиенте
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)
Параметры.Ключ.УникальныйИдентификатор();
КонецПроцедуры


Всё работает!)
Остальные ответы
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
7. Sashares 18 30.06.20 15:07 Сейчас в теме
(1)
Есть Реквизит, у которого есть сохранения заполненных данных

Не использовать это для документов. По причине
что данные, которые вводились в предыдущий документ, отображаются и в этом.

Вы сделали полную хрень.
В одном документе пользователь вводит данные, открывает другой - в нем данные от сохраненных настроек предыдущего документа.
Это бред.

Эти настройки сохраняются в разрезе пользователей, а не в разрезе каждого документа/пользователя.
alex-l19041; +1 Ответить
2. mushdaj 30.06.20 13:51 Сейчас в теме
3. 1Eset 30.06.20 14:03 Сейчас в теме
(2) Тогда пользователь не сможет заполнить форму позже, при повторном открытии она очиститься...
6. alex-l19041 8 30.06.20 14:48 Сейчас в теме
(3)
Тогда пользователь не сможет заполнить форму позже
- зачем сохранять данные где-то, а не в самом документе?
8. 1Eset 30.06.20 17:23 Сейчас в теме
(6)
зачем сохранять данные где-то, а не в самом документе?


Это реквизит документа или Вы про что-то другое
4. areavel 30.06.20 14:03 Сейчас в теме
проверку делайте если новый документ тогда очищать
5. areavel 30.06.20 14:05 Сейчас в теме
Если НЕ Параметры.Ключ.Пустая() Тогда
...
КонецЕсли;
9. 1Eset 30.06.20 17:42 Сейчас в теме
(5) Спасибо Ваш вариант лучший, сделал проверку, только без не.

И дополнительно ПриЗаписи прописал присвоение уникального идентификатора


&НаКлиенте
Процедура ПередЗаписью(Отказ, ПараметрыЗаписи)
Параметры.Ключ.УникальныйИдентификатор();
КонецПроцедуры


Всё работает!)
10. SlavaKron 01.07.20 00:56 Сейчас в теме
(9) Просто мимо проходил. В вашей процедуре ПередЗаписью не происходит никакого присваивания.
Если свойство формы "АвтоматическоеСохранениеДанныхВНастройках" установлено Использовать, а у Реквизита стоит галочка "Сохранять данные в настройках", тогда ПриСозданииНаСервере вы ничего не сделаете, так как он заполнится чуть позже в событии ПриЗагрузкеДанныхИзНастроекНаСервере. Не говоря уже о том, что сохранять реквизит документа в настройках формы не имеет никакого смысла - реальное значение реквизита на форме будет затираться последним введённым, не важно - новый документ или нет.
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Автор новостных обзоров на тему 1С и бухучета
Санкт-Петербург
По совместительству

Программист 1С
Санкт-Петербург
зарплата до 150 000 руб.
Полный день

Программист 1С
Екатеринбург
зарплата от 80 000 руб. до 130 000 руб.
Полный день

Ведущий программист 1С
Москва
зарплата от 150 000 руб.
Полный день

Ведущий программист 1С (УТ 11)
Москва
зарплата до 200 000 руб.
Полный день