1. maxph5555 09.10.19 15:04 Сейчас в теме

Конструктор печати: Ожидается символ '('

Создал макет с помощью конструктора печати:

Процедура МШ8-1(ТабДок, Ссылка) Экспорт
	//{{_КОНСТРУКТОР_ПЕЧАТИ(МШ8-1)
	Макет = Документы.СписаниеМалоценныхАктивовИзЭксплуатации.ПолучитьМакет("МШ8-1");
	Запрос = Новый Запрос;
	Запрос.Текст =
	"ВЫБРАТЬ
	|	СписаниеМалоценныхАктивовИзЭксплуатации.Дата,
	|	СписаниеМалоценныхАктивовИзЭксплуатации.Номер,
	|	СписаниеМалоценныхАктивовИзЭксплуатации.МалоценныеАктивы.(
	|		Номенклатура,
	|		ФизЛицо
	|	)
	|ИЗ
	|	Документ.СписаниеМалоценныхАктивовИзЭксплуатации КАК СписаниеМалоценныхАктивовИзЭксплуатации
	|ГДЕ
	|	СписаниеМалоценныхАктивовИзЭксплуатации.Ссылка В (&Ссылка)";
	Запрос.Параметры.Вставить("Ссылка", Ссылка);
	Выборка = Запрос.Выполнить().Выбрать();

	ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
	Шапка = Макет.ПолучитьОбласть("Шапка");
	ОбластьМалоценныеАктивыШапка = Макет.ПолучитьОбласть("МалоценныеАктивыШапка");
	ОбластьМалоценныеАктивы = Макет.ПолучитьОбласть("МалоценныеАктивы");
	ТабДок.Очистить();

	ВставлятьРазделительСтраниц = Ложь;
	Пока Выборка.Следующий() Цикл
		Если ВставлятьРазделительСтраниц Тогда
			ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
		КонецЕсли;

		ТабДок.Вывести(ОбластьЗаголовок);

		Шапка.Параметры.Заполнить(Выборка);
		ТабДок.Вывести(Шапка, Выборка.Уровень());

		ТабДок.Вывести(ОбластьМалоценныеАктивыШапка);
		ВыборкаМалоценныеАктивы = Выборка.МалоценныеАктивы.Выбрать();
		Пока ВыборкаМалоценныеАктивы.Следующий() Цикл
			ОбластьМалоценныеАктивы.Параметры.Заполнить(ВыборкаМалоценныеАктивы);
			ТабДок.Вывести(ОбластьМалоценныеАктивы, ВыборкаМалоценныеАктивы.Уровень());
		КонецЦикла;

		ВставлятьРазделительСтраниц = Истина;
	КонецЦикла;
	//}}
КонецПроцедуры
Показать


Но при попытке использовать получаю ошибку.

Ошибка инициализации модуля: Документ.СписаниеМалоценныхАктивовИзЭксплуатации.МодульМенеджера:
{Документ.СписаниеМалоценныхАктивовИзЭксплуатации.МодульМенеджера(959,14)}: Ожидается символ '('
Процедура МШ8<<?>>-1(ТабДок, Ссылка) Экспорт
{Документ.СписаниеМалоценныхАктивовИзЭксплуатации.МодульМенеджера(976,29)}: Ошибка в выражении
	Выборка = Запрос.Выполнить(<<?>>).Выбрать();


Подскажите в чем может быть проблема?
Найденные решения
2. Sashares 18 09.10.19 15:05 Сейчас в теме
(1)В имени процедуры символ "-" использовать нельзя.
Bukaska; Pavel Rodinchenko; +2 Ответить
Остальные ответы
Избранное Подписка Сортировка: Древо
2. Sashares 18 09.10.19 15:05 Сейчас в теме
(1)В имени процедуры символ "-" использовать нельзя.
Bukaska; Pavel Rodinchenko; +2 Ответить
3. Pavel Rodinchenko 09.10.19 15:06 Сейчас в теме
(1)Вместо запрос.параметры.вставить("Ссылка", Ссылка) необходимо Запрос.УстановитьПараметр("Ссылка", Ссылка)
Bukaska; Sashares; +2 Ответить
5. maxph5555 09.10.19 15:15 Сейчас в теме
(3)Буду благодарен, если напишите почему нужно делать именно так? Кстати убрал минус из имени функции и все заработало даже с
Запрос.Параметры.Вставить("Ссылка", Ссылка);
8. Bukaska 130 09.10.19 15:29 Сейчас в теме
(5)При чем тут почему? Это я зык запросов. С ним надо именно так. В каждом языке свои погремушки, причем неважно почему, главное что так надо.
9. maxph5555 09.10.19 15:33 Сейчас в теме
(8)Вопрос почему из-за того, что
Запрос.Параметры.Вставить("Ссылка", Ссылка);
создал не я, а конструктор и он работает как надо!
10. Bukaska 130 09.10.19 15:41 Сейчас в теме
(9) Оба метода равнозначны. Просто метод УстановитьПараметр был с самого начала, а свойство Параметры появилось из-за пожеланий разработчиков прикладных решений иметь возможность анализировать уже установленные параметры запроса.
maxph5555; +1 Ответить
4. YannikAlx 28 09.10.19 15:07 Сейчас в теме
Вам пишется и номер строки и позиция в строке , где выявлена ошибка!
Вам какую еще помощь оказать?
6. maxph5555 09.10.19 15:17 Сейчас в теме
(4)В имени процедуры символ "-" использовать нельзя.
7. YannikAlx 28 09.10.19 15:23 Сейчас в теме
(6) Я с этим разве спорил? Вам была указана строчка и 14 символ как раз - !!
maxph5555; +1 Ответить
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Консультант-аналитик 1С
Набережные Челны
зарплата до 90 000 руб.
Полный день

Программист 1С
Набережные Челны
зарплата от 40 000 руб. до 110 000 руб.
Полный день

Программист 1С
Казань
зарплата от 40 000 руб. до 110 000 руб.
Полный день

Программист, аналитик, эксперт 1С
Санкт-Петербург
По совместительству

Бизнес-аналитик 1С
Санкт-Петербург
зарплата от 100 000 руб.
Полный день