1. Zhest 19 13.08.19 15:11 Сейчас в теме

Метод объекта не обнаружен (ПодготовитьКоллекциюПечатныхФорм)

Добрый день! После обновления на ЗУП 3.1.10 функция "ПодготовитьКоллекциюПечатныхФорм" перестала быть экспортной, поэтому
КоллекцияФорм = УправлениеПечатью.ПодготовитьКоллекциюПечатныхФорм(ПечатнаяФорма);
стало выдавать ошибку: "Метод объекта не обнаружен (ПодготовитьКоллекциюПечатныхФорм)".
В модуль формы ВПФ добавили функцию:
Функция ПодготовитьКоллекциюПечатныхФорм(Знач Идентификаторы)
	
	Результат = Новый ТаблицаЗначений;
	Для Каждого ИмяКолонки Из УправлениеПечатьюКлиентСервер.ИменаПолейКоллекцииПечатныхФорм() Цикл
		Результат.Колонки.Добавить(ИмяКолонки);
	КонецЦикла;
	
	Если ТипЗнч(Идентификаторы) = Тип("Строка") Тогда
		Идентификаторы = СтрРазделить(Идентификаторы, ",");
	КонецЕсли;
	
	Для Каждого Идентификатор Из Идентификаторы Цикл
		ПечатнаяФорма = Результат.Найти(Идентификатор, "ИмяМакета");
		Если ПечатнаяФорма = Неопределено Тогда
			ПечатнаяФорма = Результат.Добавить();
			ПечатнаяФорма.ИмяМакета = Идентификатор;
			ПечатнаяФорма.ИмяВРЕГ = ВРег(Идентификатор);
			ПечатнаяФорма.Экземпляров = 1;
		Иначе
			ПечатнаяФорма.Экземпляров = ПечатнаяФорма.Экземпляров + 1;
		КонецЕсли;
	КонецЦикла;
	
	Результат.Индексы.Добавить("ИмяВРЕГ");
	Возврат Результат;
	
КонецФункции
Показать

Заменили
КоллекцияФорм = УправлениеПечатью.ПодготовитьКоллекциюПечатныхФорм(ПечатнаяФорма);

на
КоллекцияФорм = ПодготовитьКоллекциюПечатныхФорм(ПечатнаяФорма);

Но выходит теперь сообщение об ошибке:
Значение не является значением объектного типа (Экземпляров)
ПечатнаяФорма.Экземпляров = ПечатнаяФорма.Экземпляров + 1;

Как это исправить?
Ответы
Избранное Подписка Сортировка: Древо
2. Olga__ 13.08.19 15:25 Сейчас в теме
Посмотрите, есть ли такая колонка "Экземпляров " в вашей ТЗ и что там лежит
3. Zhest 19 13.08.19 15:29 Сейчас в теме
4. alex-l19041 8 13.08.19 15:31 Сейчас в теме
(3) добавьте колонку
Результат.Колонки.Добавить("Экземпляров");
5. Olga__ 13.08.19 15:32 Сейчас в теме
Что у вас тут УправлениеПечатьюКлиентСервер.ИменаПолейКоллекцииПечатныхФорм()?
6. Zhest 19 13.08.19 15:38 Сейчас в теме
Вот
Прикрепленные файлы:
7. Olga__ 13.08.19 15:54 Сейчас в теме
8. Zhest 19 13.08.19 16:01 Сейчас в теме
(7)
Процедура ВыполнитьПечать()
	
	Если ТипЗнч(Объект.СсылкаНаОбъект) = Тип("СправочникСсылка.Сотрудники") Тогда
		
		Запрос = Новый Запрос;
		Запрос.Текст = "ВЫБРАТЬ ПЕРВЫЕ 1
			|	ПриемНаРаботу.Ссылка КАК Ссылка
			|ИЗ
			|	Документ.ПриемНаРаботу КАК ПриемНаРаботу
			|ГДЕ
			|	ПриемНаРаботу.Сотрудник = &Сотрудник
			|	И ПриемНаРаботу.Проведен
			|
			|УПОРЯДОЧИТЬ ПО
			|	ПриемНаРаботу.Дата УБЫВ";
		Запрос.Параметры.Вставить("Сотрудник",Объект.СсылкаНаОбъект); 	
		Результат = Запрос.Выполнить().Выбрать();
		
		Если Результат.Следующий() Тогда
			МассивОбъектовНазначения = Новый Массив;
			МассивОбъектовНазначения.Добавить(Результат.Ссылка);
		КонецЕсли;
			
	Иначе
		МассивОбъектовНазначения = Новый Массив;
		МассивОбъектовНазначения.Добавить(Объект.СсылкаНаОбъект);
	КонецЕсли;

	ПараметрыВывода = ПодготовитьСтруктуруПараметровВывода();
	
	ОбъектыПечати = Новый СписокЗначений;
	
	КоллекцияФорм = ПодготовитьКоллекциюПечатныхФорм(ПечатнаяФорма);
	
	ЭтотОбъект().Печать(МассивОбъектовНазначения, КоллекцияФорм, ОбъектыПечати, ПараметрыВывода);
	
	ТабличноеПоле.Очистить();
	
	Для каждого СтрокаТаблицы Из КоллекцияФорм Цикл
		Если СтрокаТаблицы.ТабличныйДокумент <> Неопределено Тогда
			ТабличноеПоле = СтрокаТаблицы.ТабличныйДокумент;
		КонецЕсли; 
	КонецЦикла;
	
КонецПроцедуры
Показать
9. user774630 15.08.19 18:19 Сейчас в теме
Эта процедура перестала быть экспортной. Скопируйте ее в вашу обработку и вызывайте локально.
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Москва
зарплата от 150 000 руб. до 150 000 руб.
Полный день

Консультант 1С
Нижний Новгород
зарплата до 100 000 руб.
Полный день

Программист стажер 1С
Нижний Новгород
зарплата от 30 000 руб.
Полный день

Программист 1С
Нижний Новгород
зарплата до 100 000 руб.
Полный день

Программисты 1С УТ / БУЗ/ЗУП / БИТ ФИНАНС
Москва
зарплата от 100 000 руб. до 180 000 руб.
Полный день