1. skala12345 12.07.19 14:48 Сейчас в теме

Вопрос при создании документа заказа.. в какой процедуре?

Для правильной нумерации пользователю требуется именно при первоначальном создании документа спросить какого типа он хочет создать документ и далее заполнить соответствующее поле в форме истина, либо ложь.
В какой процедуре это лучше всего сделать, чтоб работало только при первоначальном создании документа?
Ответы
Избранное Подписка Сортировка: Древо
2. VictorRGB2 10 12.07.19 14:56 Сейчас в теме
ладно с конфигурацией, бог с ней, но хоть режим работы укажите, обычный или управляемые формы

для обычного - ПриОткрытии()
для управляемых форм - ПриСозданииНаСервере()

в обоих случаях проверять Новый это документ или нет, если новый - задавать вопрос и обрабатывать результат
3. skala12345 12.07.19 15:06 Сейчас в теме
(2) Конфигурация 1С УНФ 1.6, управляемые формы, как проверить новый документ это или нет?
4. tusv 159 12.07.19 15:13 Сейчас в теме
(2)В ПриСозданииНаСервере пользователя не спросить ибо сервер:) Так что все в ПриОткрытии
(3)Код Для УФ
&НаКлиенте
Процедура ПриОткрытии(Отказ)
	Если Объект.Ссылка.Пустая() Тогда
		//Спрашиваем пользователя про Тип документа
	КонецЕсли;	
КонецПроцедуры
5. VictorRGB2 10 12.07.19 15:28 Сейчас в теме
(4) а никто и не говорил про спросить, сказано про проверить Новый или нет, а вот спрашивать уже, конечно в другом месте
но, согласен, как-то так действительно проще

Процедура ПриОткрытии()
  ЭтоНеНовый = ЗначениеЗаполнено(Объект.Ссылка); // обычно этот вызов в наличии как раз в ПриСозданииНаСервере()

  Если НЕ ЭтоНеНовый Тогда
		Оповещение = Новый ОписаниеОповещения("ОбраоткаОтветаПользоватляПроНомерДокумента", ЭтотОбъект);
		ПоказатьВопрос(Оповещение, НСтр("ru = Будем менять префикс номера?'"), РежимДиалогаВопрос.ДаНет);
  КонецЕсли;

КонецПроцедуры
Показать
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Бизнес-аналитик 1С
Санкт-Петербург
зарплата от 120 000 руб.
Полный день

Программист 1С
Москва
Полный день

Консультант-аналитик 1С
Москва
Полный день

Консультант ERP-систем
Москва
Временный (на проект)

Бизнес-аналитик 1С
Москва
зарплата от 90 000 руб. до 150 000 руб.
Полный день