Как подсветить активную строку в табличном документе

1. 18.06.19 08:41 Сейчас в теме
Доброго дня.
Каким образом можно можно подсветить др.цветом всю строку в табличном документе, а не только ту ячейку на которой стоишь?
Сам табличный документ располагается на форме внешней обработки(форма обычна, т.е. не управляемая). Есть возможность установить цвет фона самой активной ячейки, а вот чтобы всю строку - такого не нашла.
Кто-то может сталкивался, какие есть варианты?
Заранее благодарю.
Найденные решения
3. SlavaKron 18.06.19 09:21 Сейчас в теме
Перем ПредыдущийНомерСтроки;

Процедура ТабДокПриАктивизацииОбласти(Элемент)
	НомерСтроки = ЭлементыФормы.ТабДок.ТекущаяОбласть.Верх;
	Если ПредыдущийНомерСтроки <> Неопределено И НомерСтроки <> ПредыдущийНомерСтроки Тогда
		ЭлементыФормы.ТабДок.Область(ПредыдущийНомерСтроки,,ПредыдущийНомерСтроки).ЦветФона = Новый Цвет;		
	КонецЕсли;
	ЭлементыФормы.ТабДок.Область(НомерСтроки,,НомерСтроки).ЦветФона = WebЦвета.АкварельноСиний;
	ПредыдущийНомерСтроки = НомерСтроки;
КонецПроцедуры
Показать
Остальные ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
2. НовенькийЯ 18.06.19 08:52 Сейчас в теме
Свойства табличного поля - Режим выделения строки - Строка
4. Gal_B 18.06.19 10:30 Сейчас в теме
(2)
строки

нет такого в свойствах поля табличного документа (у нас 1С 8.3)
3. SlavaKron 18.06.19 09:21 Сейчас в теме
Перем ПредыдущийНомерСтроки;

Процедура ТабДокПриАктивизацииОбласти(Элемент)
	НомерСтроки = ЭлементыФормы.ТабДок.ТекущаяОбласть.Верх;
	Если ПредыдущийНомерСтроки <> Неопределено И НомерСтроки <> ПредыдущийНомерСтроки Тогда
		ЭлементыФормы.ТабДок.Область(ПредыдущийНомерСтроки,,ПредыдущийНомерСтроки).ЦветФона = Новый Цвет;		
	КонецЕсли;
	ЭлементыФормы.ТабДок.Область(НомерСтроки,,НомерСтроки).ЦветФона = WebЦвета.АкварельноСиний;
	ПредыдущийНомерСтроки = НомерСтроки;
КонецПроцедуры
Показать
5. Gal_B 18.06.19 10:44 Сейчас в теме
(3) дело в том, что табличное поле не является реквизитом обработки, а значит и обратиться к нему через ЭлементыФормы не получится
6. antz 18.06.19 10:55 Сейчас в теме
(5)
>Сам табличный документ располагается на форме внешней обработки
>табличное поле не является реквизитом обработки

Так табличный документ или табличное поле? Является или не является?
7. Gal_B 18.06.19 11:06 Сейчас в теме
8. SlavaKron 18.06.19 12:06 Сейчас в теме
(5) Из справки к полю табличного документа:
Поле табличного документа можно использовать для ввода данных пользователем и представления информации, хранимой в системе или полученной в результате расчетов.
Объект является визуальным представлением объекта ТабличныйДокумент и имеет все присущие ему свойства и методы.
9. Gal_B 18.06.19 15:16 Сейчас в теме
Разобралась. Да, действительно через ЭлементыФормы всё отлично работает.
Спасибо огромное!
Оставьте свое сообщение
Вопросы с вознаграждением