1. Sakh1CPRO 11.06.19 17:46 Сейчас в теме

Использование модальных окон в данном режиме запрещено!

Привет коллеги!
Что может быть, при выполнении кода, выходит ошибка "Использование модальных окон в данном режиме запрещено!"
Код:
   // Здесь тоже процедура на Клиенте
   ДиалогОткрытияФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
   ОписаниеОповещения = Новый ОписаниеОповещения("ОбработатьВыборФайла", ЭтаФорма);
   НачатьПомещениеФайлов(ОписаниеОповещения, , ДиалогОткрытияФайла, Истина, УникальныйИдентификатор);


&НаКлиенте
Процедура ОбработатьВыборФайла(ПомещенныеФайлы, ДополнительныеПараметры) Экспорт

    Если ПомещенныеФайлы = Неопределено Тогда
        Возврат;
    КонецЕсли;

    Для каждого ПереданныйФайл Из ПомещенныеФайлы Цикл
	    ПутьКФайлу = ПереданныйФайл.Имя;     
	    Адрес = ПереданныйФайл.Хранение;
	    Объект.ФайлНаЛокальномПК=ПереданныйФайл.Имя;
	    ДвоичныеДанные = Новый ДвоичныеДанные(ПутьКФайлу);
	  ИмяФайла =  ПоместитьВоВременноеХранилище(ДвоичныеДанные );
    КонецЦикла;

    СоздатьСсылкуНаСервере(ИмяФайла);
КонецПроцедуры 



Показать



P.S. В свойствах конфигурации проставлено "Режим использования модальности" - Разрешить
Ответы
Избранное Подписка Сортировка: Древо
3. Xershi 646 11.06.19 19:50 Сейчас в теме
(1) нажми кнопку реафкторинга покажет где косяк. В данном коде нет модальности. Ставь точку останова и следи когда вылетит окно, может так быстрее найдешь.
4. tusv 159 11.06.19 20:04 Сейчас в теме
(1)У меня без ДиалогОткрытияФайла работает и на модальность не ругается
ОписаниеОповещения = Новый ОписаниеОповещения("ОбработатьВыборФайла", ЭтаФорма);
  НачатьПомещениеФайлов(ОписаниеОповещения, , , Истина, УникальныйИдентификатор);
6. Sakh1CPRO 12.06.19 05:26 Сейчас в теме
9. Xershi 646 12.06.19 20:40 Сейчас в теме
(1) справку бы открыли.
НачатьПомещениеФайлов(<ОписаниеОповещенияОЗавершении>, <ПомещаемыеФайлы>, <Интерактивно>, <УникальныйИдентификаторФормы>, <ОписаниеОповещенияПередНачаломПомещенияФайлов>)
В веб-клиенте, если расширение работы с файлами не установлено, то параметр <ПомещаемыеФайлы> должен иметь тип ДиалогВыбораФайла или массив объектов типа СсылкаНаФайл.

Неужели только копипастить умеете?
2. ellavs 461 11.06.19 18:39 Сейчас в теме
Только в режиме отладки? Если запустить не из конфигуратора, а отдельно, тоже самое?
5. Sakh1CPRO 12.06.19 04:39 Сейчас в теме
(2) запускаю в WEB клиенте выходит такая ошибка, если конечно же просто в тонком клиенте то все нормально
7. Xershi 646 12.06.19 08:28 Сейчас в теме
А да для веба это ты синхронно делаешь смотри мою публикацию работы с файлами.
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Нижневартовск
зарплата от 60 000 руб.
Полный день

Руководитель проекта, аналитик, консультант
Санкт-Петербург
По совместительству

Автор новостных обзоров на тему 1С и бухучета
Санкт-Петербург
По совместительству

Бизнес-аналитик 1С
Санкт-Петербург
зарплата от 120 000 руб.
Полный день

Программист 1С
Москва
Полный день