1. santa56 6 11.06.19 08:40 Сейчас в теме

ИНН покупателя в чек ККТ

Добрый день не кто не занимался печать ИНН в чеке? накидал программно но он печатает чек без ошибок но не печатает данные о покупателе прикладываю формирование XML ККТ для печати чека какая должна быть версия драйвера и прошивки ККТ?

<?xml version="1.0" encoding="UTF-8"?>
<CheckPackage>
<Parameters PaymentType="2" TaxVariant="0" CashierName="Бакулкина Е.А. (Инспектор по досмотру)" SenderEmail="info@1c.ru" CustomerEmail="" CustomerPhone="" CustomerInfo="Общество с ограниченной ответственностью "Гепард"" CustomerINN="11111111">
<AgentData/>
<Positions>
<FiscalString Name="Парковка ТС на территории ГТ ( Легковой автотранспорт, микроавтобусы ) сторонними организациями и физическими лицами при предъявлении документа ГТ* на" Quantity="1" PriceWithDiscount="100" SumWithDiscount="100" DiscountSum="0" Department="1" Tax="20" SignMethodCalculation="4" SignCalculationObject="4" TaxSum="16.67">
<AgentData/>
<PurveyorData/>
</FiscalString>
</Positions>
<Payments Cash="100" ElectronicPayment="0" Credit="0" AdvancePayment="0" CashProvision="0"/>
</CheckPackage>
Ответы
Избранное Подписка Сортировка: Древо
85. AlexeyPapanov 327 10.07.19 12:27 Сейчас в теме
Коллеги, у кого Штрих-М 01ф и иже с ними, подскажите какая актуальная версия прошивки.
А то у меня такое:
Версия ПО : C.1
Сборка ПО : 5190
Дата ПО : 29.04.2019

сомневаюсь, может обновить надо. клиент говорит, что им последнюю накатили.


И еще: если в 1С заходим по RemoteApp, то выходит, что дрова и компоненту надо на серверном компе ставить или только на клиентском?

У клиента либо дрова старые, либо компонента старая (2.4). А как поставить корректно новую я не знаю в случае с RemoteApp. Подскажете? Я бы отблагодарил.
87. user644066 10.07.19 19:00 Сейчас в теме
(85) по прошивке см. мой ответ (86)
89. user644066 10.07.19 19:09 Сейчас в теме
(85) По RemoteApp - насколько я понимаю, это, по сути, тоже самое, что и RDS -- значит дрова должны быть на стороне сервера.
90. Дмитрий2254 4 11.07.19 05:26 Сейчас в теме
(85)У нас касса штрих и УПП 1.3.123.2 , но модуль МенеджерОборудованияКлиентСервер и документы ПриходныйКассовыйОрдер и
ОплатаОтПокупателяПлатежнойКартой из версии УПП 1.3.123.1, т.к. в версии УПП 1.3.123.2 начали использовать обработку ПредпросмотрЧека и с ней так и не сладили. В модуле формы документа при пробития чека добавил заполнение ИНН и наименование покупателя:

Процедура ОсновныеДействияФормыЧек(Кнопка)
	
	Перем ФУ;
	
	Если НомерЧекаККМ <> 0 Тогда
		Предупреждение("Чек уже пробит на фискальном устройстве!", 60);
		Возврат;
	КонецЕсли;
	
	Если Не РаботаСТорговымОборудованием.ПолучитьПроверитьПараметрыДляПробитияЧека(ФУ, Истина, Организация) Тогда
		Возврат;
	КонецЕсли;
	
	Если (НЕ Оплачено) ИЛИ (НЕ Проведен) ИЛИ Модифицированность Тогда
		Ответ = Вопрос("Провести документ?", РежимДиалогаВопрос.ДаНет, , КодВозвратаДиалога.Да);
		Если Ответ <> КодВозвратаДиалога.Да Тогда
			Предупреждение("Операция не выполнена!");
			Возврат;
		КонецЕсли;
	КонецЕсли;
	
	Попытка
		
		НачатьТранзакцию();
		
		БылоОплачено = Оплачено;
		Оплачено = Истина;
		ИспользоватьРежимПроведения = ИспользованиеРежимаПроведения.Авто;
		ЗаписатьВФорме(РежимЗаписиДокумента.Проведение);
		
		ВидФУ = ПолучитьСерверТО().ПолучитьВид(ФУ);
		Если ВидФУ = Перечисления.ВидыТорговогоОборудования.ФискальныйРегистратор Тогда
			Позиция         = Неопределено;
			НомерСмены      = Неопределено;
			ТаблицаПлатежей = Новый ТаблицаЗначений();
			ТаблицаПлатежей.Колонки.Добавить("Заголовок");
			ТаблицаПлатежей.Колонки.Добавить("Сумма");
			ТаблицаПлатежей.Колонки.Добавить("НДС");
			
			Для Каждого Позиция Из РасшифровкаПлатежа Цикл
				СтрокаТаблицы           = ТаблицаПлатежей.Добавить();
				СтрокаТаблицы.Заголовок = "Принято от " + ПринятоОт
				+ "
				|Основание: " + Основание;
				СтрокаТаблицы.Сумма     = Позиция.СуммаПлатежа;
				СтрокаТаблицы.НДС       = УчетНДС.ПолучитьСтавкуНДС(Позиция.СтавкаНДС);
			КонецЦикла;
			
			Результат = ПолучитьСерверТО().ПечатьЧекаПКО(ФУ,
			"",
			НомерЧекаККМ,
			НомерСмены,
			ТаблицаПлатежей,
			СуммаДокумента,
			0);
			Если ЗначениеЗаполнено(Результат) Тогда
				ОтменитьТранзакцию();
				ТекстОшибки = ПолучитьСерверТО().ПолучитьТекстОшибкиФРТО(Результат);
				Предупреждение(ТекстОшибки);
				Возврат;
			КонецЕсли;
			
		Иначе
			ОписаниеПКС = КассовыеСменыВызовСервера.ОписаниеПоследнейКассовойСмены(ФУ);
			Если ОписаниеПКС = Неопределено ИЛИ ОписаниеПКС.Статус = Перечисления.СтатусыКассовойСмены.Закрыта Тогда
				ОбщегоНазначения.СообщитьОбОшибке("Кассовая смена не открыта");
				Возврат;
			КонецЕсли;
			
			ОбъектДрайвера = Неопределено;
			ОбработкаОбслуживания = Неопределено;
			ПолучитьСерверТО().ПолучитьОбъектДрайвера(ФУ, ОбработкаОбслуживания, ОбъектДрайвера);
			
			ОбработкаОбслуживания.ПолучитьПараметрыККТ(ОбъектДрайвера);
			ВерсияФормата = МенеджерОборудованияКлиентСервер.ВерсияФФД(ОбъектДрайвера.ВыходныеПараметры);
			
			ПараметрыЧека = МенеджерОборудованияКлиентСервер.ПараметрыОперацииФискализацииЧека();
			ПараметрыЧека.Вставить("ОписаниеПКС", ОписаниеПКС);
			
			//+ Дополнение 09.07.2019
			Если ЗначениеЗаполнено(Ссылка.Контрагент) Тогда 
					ПараметрыЧека.Получатель = Ссылка.Контрагент.НаименованиеПолное;
					ПараметрыЧека.ПолучательИНН = Ссылка.Контрагент.ИНН;
			КонецЕсли;
		// - Дополнение
		
		МенеджерОборудованияВызовСервера.ПодготовитьДанныеДляФискализацииЧека(Ссылка, ПараметрыЧека, ВерсияФормата, 
		ПолучитьСерверТО().ПолучитьМодель(ФУ), ПринятоОт, Основание);
		
		Результат = ОбработкаОбслуживания.ФискализироватьЧек(ОбъектДрайвера, ПараметрыЧека);
		Если Не ЗначениеЗаполнено(Результат) Тогда
			ЭтотОбъект.НомерЧекаККМ = ОбъектДрайвера.ВыходныеПараметры[1];
			ЭтотОбъект.ККМ = ОписаниеПКС.КассаККМ;
			ЭтотОбъект.ТекстЭлектронногоЧека = ПараметрыЧека.ТекстЭлектронногоЧека;
		Иначе
			Оплачено = БылоОплачено;
			ОбщегоНазначения.СообщитьОбОшибке(ОбъектДрайвера.ОписаниеОшибки);
		КонецЕсли;
		
	КонецЕсли;
	
	ПриЗаписиПерепроводить = Ложь;
	ЗаписатьВФорме(РежимЗаписиДокумента.Запись);
	ПриЗаписиПерепроводить = Истина;
	ЗафиксироватьТранзакцию();
	
Исключение
	
	ОтменитьТранзакцию();
	Предупреждение("Операция не выполнена!");
	
КонецПопытки;

КонецПроцедуры
Показать


Драйвер ККТ должен быть не ниже 4.14.0.772. Также в драйвере установить 1 в свойство "Авто печать тегов" в таблицу настройки фискальника. А вот УТ 11 не получается пока...
88. dakork 14 10.07.19 19:01 Сейчас в теме
Если расчет между двумя юрлицами безналом (кроме банковской карты), то ККТ не нужна и чек не формируется и не направляется контрагенту.
96. MikeAdm 11.07.19 22:59 Сейчас в теме
Вернее, ГТД выводятся в кассу, но на чеке их нет, вижу уже в ОФД.
103. user644066 15.07.19 16:38 Сейчас в теме
(96) Если у вас Штрих, то, возможно, это поможет:

В таблицах ККТ (настраиваются через Тест драйвера ФР от Штриха), а именно в таблице 17 (Regional settings), поле 25 (Rus автопечать тегов) установить в значение 1.
97. riks05 12.07.19 08:12 Сейчас в теме
установил компоненту 10.5 при записи ккт компонента определяется как 10.5. смена открывается, при пробитии чека выходит ошибка что смена не открыта.
user1130155; +1 Ответить
108. vavilon85 16.07.19 15:12 Сейчас в теме
Добрый день, а кто нибудь сталкивался с пирит 2ф с этой проблемой. Все драйвера и 1с УТ 11.4 обновили до последних версий, в файле xml покупатель и инн есть, но вот на печать ничего не выводится
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Бизнес-аналитик 1С
Санкт-Петербург
зарплата от 120 000 руб.
Полный день

Программист 1С
Москва
Полный день

Консультант-аналитик 1С
Москва
Полный день

Консультант ERP-систем
Москва
Временный (на проект)

Бизнес-аналитик 1С
Москва
зарплата от 90 000 руб. до 150 000 руб.
Полный день