1. tusv 147 14.05.19 18:01 Сейчас в теме

Значица так. По Глебу Жеглову

Я чесна пытался. спросить.вопрос, что это обсуждение. Увы дорогой друг . Это решение. Верните это в Истина https://infostart.ru/public/1058110/
Ответы
Избранное Подписка Сортировка: Древо
2. user856012 8 14.05.19 18:26 Сейчас в теме
Публикация неактивна или находится на модерации.
М-да. Судя по стилистике автора, представляю, что там: "Варбамбия. Киргуду!"
3. TODD22 17 14.05.19 18:34 Сейчас в теме
(2)+100 похоже русский язык для автора не родной.
4. tusv 147 14.05.19 18:58 Сейчас в теме
(3)Аз емь. Поверишь, что я еврей? Это риторический вопрос)))
5. tusv 147 14.05.19 21:49 Сейчас в теме
(2)"
Варбамбия. Киргуду!"

Судя по стилистике комментатора. Классику не смотрел. "Барбамия" пишется, через большую Букву "Б"
А Киркиду. Чтож извольте. на Ваш вкус. Мне не стыдно
Еще один не стандартный способ расшифровки отчета или Лень + СКД = Очень много свободного времени
Статью написать сподвиг вопрос Слишком сложно для меня по уже стандартно нестандартной расшифровке. В свое время тоже требовалось онное и естественно набрел на Это. Все здорово. Но! Статья то о СКД + Лень. Последняя пылала пожаром и отказывалась нажимать последовательность cntr+C, alt+Tab, cntr+V многократно.

Я её уговаривал, грамотно же статья написана. Нет, отвечает Лень. Там нужна форма, а в БСП это Общая форма и она может измениться со следующим релизом, будет тебе лишняя головная боль при обновлении. В обще Лень странная девочка. Когда творческий поиск, сложный запрос - ядерным взрывом не разбудишь, а тут бунт и в условиях цейтнота.

Пришлось идти на поводу у Матери всея прогресса. Спросил у Яндекса, тот мне честно: “Ты б еще у Гугела идиот спросил”. Пришлось включать творческий процесс и метод “Научного тыка”. Чем научный от ненаучного знаете, чем отличается? Ставишь точку останова и смотришь в табло. Не нужное само отметается, а нужное обязательно найдется. А где ее ставить как не в ПриКомпоновкеРезультата. В уже стандартных строчках:

Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
СтандартнаяОбработка = Ложь;

Настройки = КомпоновщикНастроек.ПолучитьНастройки();

КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, Настройки, ДанныеРасшифровки);

ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;
ПроцессорКомпоновки.Инициализировать(МакетКомпоновки,, ДанныеРасшифровки);

ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
ПроцессорВывода.УстановитьДокумент(ДокументРезультат);
ПроцессорВывода.Вывести(ПроцессорКомпоновки);
КонецПроцедуры
И вот ОНО. Нужное! После строчки:

МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, Настройки, ДанныеРасшифровки);
Под пытками, ЕЁ Величества Точки останова, ДанныеРасшифровки сознаются в своих параметрах, отборах и остальных "грехах". Остается только проверить, а расшифровка ли это

ЭтоРасшифровка = Не ДанныеРасшифровки.Настройки.Отбор.Элементы.Количество()= 0;
Накидываем седло с уздечкой на коня и вуаля. Шорты превращаются в брюки:

Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
СтандартнаяОбработка = Ложь;
Настройки = КомпоновщикНастроек.ПолучитьНастройки();
КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных, Настройки, ДанныеРасшифровки);

ЭтоРасшифровка = Не ДанныеРасшифровки.Настройки.Отбор.Элементы.Количество()= 0;

Если ЭтоРасшифровка Тогда
Отчет = Отчеты.<Любой отчет>.Создать();
Настройки = Отчет.КомпоновщикНастроек.Настройки;
//То что мы пытали непосильным трудом из данных расшифровки
//Праметры, отборы
//Подставляем Здесь
МакетКомпоновки = КомпоновщикМакета.Выполнить(Отчет.СхемаКомпоновкиДанных, Настройки, ДанныеРасшифровки);
КонецЕсли;

ПроцессорКомпоновки = Новый ПроцессорКомпоновкиДанных;
ПроцессорКомпоновки.Инициализировать(МакетКомпоновки,, ДанныеРасшифровки);

ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
ПроцессорВывода.УстановитьДокумент(ДокументРезультат);
ПроцессорВывода.Вывести(ПроцессорКомпоновки);
КонецПроцедуры
Вроде бы просто. Но не тут то было. Моя Лень требует большего. Шорты не превращаются в брюки, пока СКД задает много ненужных вопросов. Как заставить формировать Расшифровку без глупых диалогов с вопросами я не знаю. Отставить! Временно не знаю.

Статья же о Матушке Лени. Найдем решение утихомирить совместными усилиями эту раздухарившуюся Особу
6. user856012 8 14.05.19 22:03 Сейчас в теме
(5)
Судя по стилистике комментатора. Классику не смотрел
Вот тут точку надо заменить на запятую, а "классику" написать с маленькой буквы.

По существу: классику смотрел, но не читал. А кто читал? Никулин? Гайдай? Наверное, но я в то время не мог читать.

А на слух различается плохо.
"Барбамия" пишется, через большую Букву "Б"
А Киркиду. Чтож извольте. на Ваш вкус.
Судя по Вики, ваш вкус вас подводит не меньше: https://ru.wiktionary.org/wiki/бамбарбия_киргуду
7. tusv 147 14.05.19 22:11 Сейчас в теме
(6) не ну а лучше спрашиваю Яндекс "кавказская пленница смотреть":) Покажет то что нужно. Вики -ацтой. ВыОбращайтесь к ниму. Тама без абшибкаф пишеца. И точно не будет задавать не нужных вопросов, как здесь
8. tusv 147 14.05.19 22:21 Сейчас в теме
(6)И да. Стесняюсь спросить. Вы точно разработчик или википедию тут рекламируете? С Вашим то безупречным Русским
9. user856012 8 14.05.19 22:42 Сейчас в теме
(8)
Вы точно разработчик
Ну, куда мне до вас? Вы даже цитату в (5) оформили как код!
С Вашим то безупречным Русским
"У каждого свои недостатки" (с)
11. tusv 147 14.05.19 22:56 Сейчас в теме
(9)Кстати это сказал мужчина мужчине. Смортите классику, а не википедию:)
10. tusv 147 14.05.19 22:51 Сейчас в теме
Вы даже цитату в (5) оформили как код!

Ужо привычка,На мой взгляд лучше, чем говорить об безупречном Русском. Не находите?
У каждого свои недостатки

Эт правильно, но Вы мне же указали, что я пишу не эдак. Мой код работает. Строчек мизер. Квалифицированного ответа нет. Только носом тыкнули в Русский язык. А здесь так то 1Совский в почете
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Руководитель отдела внедрения 1С
Новосибирск
зарплата от 60 000 руб. до 160 000 руб.
Полный день

Ведущий программист 1С
Москва
зарплата от 120 000 руб. до 150 000 руб.
Полный день

Программист 1С
Самара
зарплата от 50 000 руб. до 100 000 руб.
По совместительству


Ведущий программист 1С
Сочи
зарплата от 82 500 руб. до 99 000 руб.
Полный день