Групповое формирование актов сверки взаиморасчетов и рассылка по электронной почте (БП 3.0)

0. 440 12.04.19 14:25 Сейчас в теме
Внешняя обработка, которая позволяет формировать акты сверки расчетов с контрагентами, делать рассылку файлов актов с печатью и подписью, контролировать возврат оригиналов документов.

Перейти к публикации

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
2. VolodinaOlga 8 24.07.19 10:31 Сейчас в теме
Обработка работает не корректно. Акты сверок формируются пустые, без оборотов и остатков. Автор, исправьте или напишите, что данную обработку нужно дорабатывать.
3. andy23 440 24.07.19 12:08 Сейчас в теме
(2) Здравствуйте!
У меня на предприятии обработка работает корректно.
Вероятно настройки конфигурации у Вас отличаются от моих.
Далее приведу текст который появляется перед скачивание обработки с infostart.ru
"Предупреждение! Файлы за стартмани не являются готовым решением. Это примеры, шаблоны, алгоритмы, "стройматериалы" для вашей учетной системы. Нет гарантии работоспособности. Вы скачиваете и используете на свой страх и риск."
4. VolodinaOlga 8 24.07.19 12:54 Сейчас в теме
Пробовала на разных базах, не работает.. Под какой платформой вы работаете? Может в этом проблема..
5. andy23 440 24.07.19 17:24 Сейчас в теме
(4) Заполнение актов идет из процедур самого документов, т.е. типовым способом:

Форма = ПолучитьФорму("Документ.АктСверкиВзаиморасчетов.ФормаОбъекта");
Форма.ЗаполнитьПоДаннымБухгалтерскогоУчета(Истина);

Если создать акт и интерактивно нажать кнопку заполнить, что-то заполняется?
7. SV-63 03.12.19 09:31 Сейчас в теме
(5)
Форма.ЗаполнитьПоДаннымБухгалтерскогоУчета(Истина);

Если создать акт и интерактивно нажать кнопку заполнить, что-то заполняется?


Конечно заполняется. А вот из обработки нет ! Наверное п.ч. процедура не экспортная.
Хорошая идея с автоматизаций создания и контролем подписания , но похоже что автор поторопился с исполнением ... ))
8. SV-63 06.12.19 16:57 Сейчас в теме
(7) Вот так заполняет табличную часть :

Результат=Форма.ЗаполнитьПоДаннымБухгалтерскогоУчета(Истина);    //051219
		Если Результат.Статус = "Выполнено" Тогда
			Форма.ЗагрузитьПодготовленныеДанные(Результат);
			Форма.Записать();
			АктСсылка = Форма.Объект.Ссылка;
			СформироватьАктыСверкиНаСервере(АктСсылка);
			Строка.АктСверки = АктСсылка;
		Иначе
			Сообщить("КраткоеПредставлениеОшибки = "+Результат.КраткоеПредставлениеОшибки);
		КонецЕсли;          //051219
Показать
6. VolodinaOlga 8 24.07.19 18:55 Сейчас в теме
То есть, сначала создать акт без обработки? При выборе всех контрагентов, если мною уже был создан документ, то он просто подгружается в обработку, если документа не было, то после того как нажимаю Сформировать акты сверки, документы создаются, но если зайти внутрь - они пустые без оборотов (но при заполнении внутри акта все заполняется в обычном порядке)
9. sobico 12.12.19 12:50 Сейчас в теме
Добрый день! Есть возможность отбора по счетам (60,62,76)?
10. kubiky 131 28.04.20 23:58 Сейчас в теме
Вот так заработало (3.0.76.77):

&НаКлиенте
Процедура СформироватьАктыСверки(Команда)
// YYK-------->	
	Перем ДополнительныеПараметры;
	
	ДополнительныеПараметры=Неопределено;
// YYK--------<	
	Если НЕ ЗначениеЗаполнено(Организация) Тогда
		Сообщить("Не заполнена организация!");	
		Возврат;
	КонецЕсли;	
	
	Если НЕ ЗначениеЗаполнено(ДатаНачала) или НЕ ЗначениеЗаполнено(ДатаОкончания) или НЕ ЗначениеЗаполнено(ДатаАкта) Тогда
		Сообщить("Не выбраны даты формирования актов сверки!");	
		Возврат;
	КонецЕсли;
	
	НетОтмеченных = Истина;
	
	Представитель =  ПолучитьПредставителя(Организация, ДатаАкта);
	
	Для Каждого Строка Из тзКонтрагенты Цикл
		Если НЕ Строка.Отметка Тогда
			Продолжить;
		КонецЕсли; 
		НетОтмеченных = Ложь;
		Если ЗначениеЗаполнено(Строка.АктСверки) Тогда
			Сообщить(""+Строка.Контрагент + " акт уже был сформирован!", СтатусСообщения.Важное);
			Продолжить;
		КонецЕсли; 
		
		Форма = ПолучитьФорму("Документ.АктСверкиВзаиморасчетов.ФормаОбъекта");
		Форма.Объект.Дата = ДатаАкта;
		Форма.Объект.Организация = Организация;
		Форма.Объект.ДатаНачала = ДатаНачала;
		Форма.Объект.ДатаОкончания = ДатаОкончания;
		Форма.Объект.Контрагент = Строка.Контрагент;
		Форма.Объект.ПредставительОрганизации = Представитель;
// YYK-------->	
		//Форма.ПриИзмененииКонтрагентаСервер();
		Форма.ВопросПриИзмененииКонтрагентаЗавершение(КодВозвратаДиалога.Да,ДополнительныеПараметры);
// YYK--------<	
		Форма.Объект.ДоговорКонтрагента = "";
// YYK-------->			
		//Форма.ЗаполнитьПоДаннымБухгалтерскогоУчета(Истина);
		ДополнительныеПараметры=Новый Структура;
		ДополнительныеПараметры.Вставить("ЗаполнятьДанныеКонтрагента",Истина);
		Форма.ВопросЗаполнитьПоДаннымУчетаЗавершение(КодВозвратаДиалога.Да, ДополнительныеПараметры);
// YYK--------<	
		Форма.Записать();
		АктСсылка = Форма.Объект.Ссылка;
		
		СформироватьАктыСверкиНаСервере(АктСсылка);
		
		Строка.АктСверки = АктСсылка;
	КонецЦикла;

	 Если НетОтмеченных Тогда
	 
	 	Сообщить("Нет отмеченных контрагентов!", СтатусСообщения.Важное);	
	Иначе
		Сообщить("Формирование актов завершено!", СтатусСообщения.Информация);
	 КонецЕсли; 
	
КонецПроцедуры
Показать
14. kubiky 131 29.04.20 00:20 Сейчас в теме
(10)

Здесь лучше так:

ДополнительныеПараметры.Вставить("ЗаполнятьДанныеКонтрагента",Ложь);
11. kubiky 131 29.04.20 00:05 Сейчас в теме
+

В запрос
//Заполним существующими актами

добавить проверку на пометку удаления неудачных актов:

Запрос = Новый Запрос;
	Запрос.Текст = "ВЫБРАТЬ РАЗЛИЧНЫЕ
...................
// YYK-------->
	               |	И АктСверкиВзаиморасчетов.ПометкаУдаления = ЛОЖЬ";
// YYK--------<
12. kubiky 131 29.04.20 00:11 Сейчас в теме
+

там же:

Запрос.УстановитьПараметр("ДатаОкончания", НачалоДня(ДатаОкончания));

Может надо:

Запрос.УстановитьПараметр("ДатаОкончания", КонецДняДня(ДатаОкончания));
13. kubiky 131 29.04.20 00:12 Сейчас в теме
сорри:


Запрос.УстановитьПараметр("ДатаОкончания", КонецДня(ДатаОкончания));
15. kubiky 131 29.04.20 00:27 Сейчас в теме
16. kubiky 131 29.04.20 00:36 Сейчас в теме
+

В идеале еще добавить типовой отбор по контрагентам с сохранением настроек отбора, а не просто принадлежность группе.

Щас займусь...
17. alesya_gai 26.01.21 12:59 Сейчас в теме
(16)здравствуйте! Скажите пожалуйста , исправляла по вашим комментариям , работает. Но заметила что заполняет только документами по движению дс, остальные не попадают....к сожалению...
Не подскажите как можно это исправить?
18. kubiky 131 26.01.21 18:59 Сейчас в теме
"...Но заметила что заполняет только документами по движению дс, остальные не попадают"

А что такое "остальные"????

Возможно в акте сверки у вас отключены требуемые счета учета.

1. проверьте в ваших актах сверки на закладке ТЧ "Счета учета расчетов" - что включено
Нажите на кнопку "Заполнить" (по умолчанию).


2. В этой обработке найдите строку:

ТаблицаСчетовВзаиморасчетов = УчетВзаиморасчетов.ПолучитьТаблицуСчетовУчетаВзаиморасчетов(Истина, Ложь);

Посмотрите что в таблице и

В эту таблицу ТаблицаСчетовВзаиморасчетов добавьте ваши "хотелки" счетов взаиморасчетов
Оставьте свое сообщение
Вопросы с вознаграждением
Вакансии
Архитектор 1С
Пермь
зарплата до 200 000 руб.
Полный день

Бизнес-аналитик 1С
Санкт-Петербург
зарплата от 120 000 руб. до 150 000 руб.
Полный день

Бизнес-аналитик 1С
Пермь
зарплата до 100 000 руб.
Полный день

Старший программист 1С
Самара
зарплата от 70 000 руб.
Полный день

Программист, аналитик, эксперт 1С
Санкт-Петербург
По совместительству