1. pavel06 08.02.19 23:30 Сейчас в теме

Есть ли в ЗУП 3.1 групповая обработка справочников и документов?

Мне нужно в ЗУП 3.1 удалить локументы до позапрошлого года. Есть ли в ЗУП 3.1 такой инструмент, как "Групповая обработка справочников и документов", чтоб пометить на удаление и удалить?
Ответы
Избранное Подписка Сортировка: Древо
2. TODD22 17 08.02.19 23:56 Сейчас в теме
(1)Администрирование - Обслуживание - Корректировка данных - Групповое изменение реквизитов
3. pavel06 09.02.19 00:40 Сейчас в теме
(2) Это групповое изменение реквизитов я видел во всех функциях - обработках
Но там все очень неудобно. 1)Как установить период для обрабатываемых документов?
2)Как выбрать все документы разом?(там только галочки на огромном количестве квадратиков надо расставлять)
В 8.2 ведь такая удобная обработка была про группововое изменение, может кто ее переписал под 8.3 один в один?
В и-нете есть код:
Для Каждого ТекМД из Метаданные.Документы Цикл
		
	Выборка = Документы[ТекМД.Имя].Выбрать();
		
	Пока Выборка.Следующий() Цикл
			
		ТекОб = Выборка.ПолучитьОбъект();
			
		Если ТекОб.ПометкаУдаления Тогда 
			Продолжить;
		КонецЕсли;
			
		Попытка
			ТекОб.УстановитьПометкуУдаления(Истина);
		Исключение
			Сообщить("Документ " + ТекОб + " не удалось пометить на удаление, по причине " + ОписаниеОшибки());			
		КонецПопытки;
			
	КонецЦикла;
		
		
КонецЦикла;
Показать

Может в него как-то период можно вставить?
7. alxarz 29 09.02.19 17:10 Сейчас в теме
(3)
Может в него как-то период можно вставить?
можно, например
Если ТекОб.ПометкаУдаления Тогда 
            Продолжить;
        КонецЕсли;
Если ТекОб.Дата > НужнойДаты Тогда 
            Продолжить;
        КонецЕсли;
8. pavel06 09.02.19 21:32 Сейчас в теме
(7)
можно, например


Тут, наверно, как-то надо учесть, что некоторые объекты реквизита Дата не имеют.

Если в той же обработке "Групповое изменение реквизитов" выбрать для обработки много объектов(много галочек поставить, т.к. нет галки "Выбрать все"), то обработка говорит, что нет общих реквизитов( в том числе реквизита Дата)
Только после нажатия на кнопку "Дополнительно" появляется реквизит "Пометка удаления"
Поэтому отбор по реквизиту Дата не сделать.
Почему-то в групповой обработке из 8.2 таких проблем не было.
9. alxarz 29 09.02.19 21:56 Сейчас в теме
(8)
Тут, наверно, как-то надо учесть, что некоторые объекты реквизита Дата не имеют.
например, заключить условие в
попытка
...
исключение
продолжить;
конецпопытки
5. DNN13 09.02.19 09:47 Сейчас в теме
(1) В групповом изменении реквизитов можно и отбор настроить и удалить.
4. TODD22 17 09.02.19 01:19 Сейчас в теме
1)Как установить период для обрабатываемых документов?

Там есть отбор.
2)Как выбрать все документы разом?(там только галочки на огромном количестве квадратиков надо расставлять)

Да надо проставить галочки.
6. leosoft 134 09.02.19 10:13 Сейчас в теме
делаем отбор по реквизиту дата
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии


Специалист техподдержки 1С
Иркутск
зарплата от 28 000 руб. до 34 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 48 000 руб. до 96 000 руб.
По совместительству

Программист 1С
Ставрополь
зарплата от 40 000 руб. до 60 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 120 000 руб. до 150 000 руб.
Полный день