1. user1024476 05.12.18 13:18 Сейчас в теме

Не работает ИнтеграцияС1СДокументооборот в регламентном задании

В обработчике (серверный общий модуль, вызов есть )регламентного задания используется ИнтеграцияС1СДокументооборот для программного формирования и отправки в ДО задания
Ломается сразу же при получении прокси
 Прокси         = ИнтеграцияС1СДокументооборотПовтИсп.ПолучитьПрокси();

Возвращает неопределено
в чем может быть проблема ?
с кнопки код отрабатывает на ура
Найденные решения
7. user1024476 10.12.18 10:54 Сейчас в теме
Проблема решилась "ручной" передачей параметров из констант с именем и паролем пользователя в функцию ПолучитьПрокси (доступна в модуле ИнтеграцияС1СДокументооборот)
Остальные ответы
Избранное Подписка Сортировка: Древо
2. user705522_constantin_h 12 05.12.18 14:09 Сейчас в теме
(1)Код посмотрите.
У меня такой:
	Если Не ЗначениеЗаполнено(ИмяПользователя)
		И Не ИспользуетсяАутентификацияОС Тогда
		Возврат Неопределено;
	КонецЕсли;
	
	Если Пароль = Неопределено Тогда
		Если Не ПараметрыСеанса.ИнтеграцияС1СДокументооборотПарольИзвестен
			И Не ИспользуетсяАутентификацияОС Тогда
			Возврат Неопределено;
		КонецЕсли;
		Пароль = ПараметрыСеанса.ИнтеграцияС1СДокументооборотПароль;
	КонецЕсли;
Показать

Если не введено ИмяПользователя или Пароль интерграции, то Возврат = Неопределено.
3. user1024476 05.12.18 19:59 Сейчас в теме
(2) я так понимаю, что пользователь , под которым выполняется регламентное задание не зашел в ДО ?
а как передать регламенту эти параметры ? )
4. user705522_constantin_h 12 05.12.18 22:44 Сейчас в теме
(3)В настройках по гиперссылке Интеграция с 1С:Документооборотом, далее по гиперссылке Ввести имя пользователя и пароль.
5. user1024476 06.12.18 05:32 Сейчас в теме
(4)Т.е авторизация в в режиме предприятия ?
так я там авторизовался
иначе код не исполнялся бы и с кнопки
6. user705522_constantin_h 12 06.12.18 09:42 Сейчас в теме
(5)У пользователя, под которым авторизовались, должны быть права администратора.
user1024476; +1 Ответить
7. user1024476 10.12.18 10:54 Сейчас в теме
Проблема решилась "ручной" передачей параметров из констант с именем и паролем пользователя в функцию ПолучитьПрокси (доступна в модуле ИнтеграцияС1СДокументооборот)
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Волгоград
зарплата от 45 000 руб. до 90 000 руб.
Полный день

Автор новостных обзоров на тему 1С и бухучета
Санкт-Петербург
По совместительству

Консультант-аналитик 1С
Москва
зарплата от 70 000 руб. до 100 000 руб.
Полный день

Программист 1С
Москва
зарплата от 80 000 руб. до 120 000 руб.
Временный (на проект)

Ведущий программист 1С
Сочи
зарплата от 80 000 руб. до 100 000 руб.
Полный день