INFOSTART EVENT 2018 EDUCATION

Второй тур голосования за доклады.
Окончание 5 сентября.

Лимонтова Марина | Руководитель отдела автоматизации | Торговая сеть РЕМИ

«Как внедрить 1С:Документооборот в условиях хаоса»

В своём докладе хочу поделиться опытом внедрения 1С: Документооборот в крупной бурно развивающейся компании при условиях отсутствия описанных процессов и структуры предприятия. В ходе доклада слушатели на примере истории реального внедрения узнают: • Какие подводные камни ожидают внедренцев программы 1С:Документооборот. • Плюсы и минусы использования встроенного почтового клиента 1С:Документооборота, как важного фактора успешного внедрения. • Что важно понимать при распределении прав доступа. • Какие небольшие, но очень полезные доработки функционала можно сделать. • Какие организационные вопросы нужно решить для успешной эксплуатации внутреннего электронного документооборота. • Как заинтересовать руководителей подразделений выступать с инициативой по автоматизации своих процессов. • Ключевые моменты использования 1С:Документооборот совместно с другими программами.

1. lenna_1985 61 10.08.18 18:00 Сейчас в теме

Как установить параметры отбора для отчета при открытии

1с 8.3 - самописная конфигурация - есть отчет - вызываю его открытие из документа реализация (задаю параметр "Контрагент") - как при открытии отчета установить пользовательский отбор ?

фиксированный отбор установить получилось, но его пользователь изменить не может..

Вот текст ФИКСИРОВАННОГО ОТБОРА:
=================================================
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)


	Контрагент = "";
	Если Параметры.Свойство("Контрагент", Контрагент) Тогда  
		ЭлементОтбораНачПер                = Отчет.КомпоновщикНастроек.ФиксированныеНастройки.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
		ПолеКомпановки                     = Новый ПолеКомпоновкиДанных("Контрагент");
		ЭлементОтбораНачПер.ЛевоеЗначение  = ПолеКомпановки;
		ЭлементОтбораНачПер.ВидСравнения   = ВидСравненияКомпоновкиДанных.Равно;
		ЭлементОтбораНачПер.ПравоеЗначение = Контрагент;
		ЭлементОтбораНачПер.Использование  = Истина;
	КонецЕсли; 

КонецПроцедуры
===========================================
Показать


может кто знает - помогите очень нужно..
Найденные решения
6. lenna_1985 61 12.08.18 19:24 Сейчас в теме
ответ нашла сама может кому пригодиться

&НаКлиенте
Процедура Команда_Взаиморасчеты(Команда)
    //структура отбора
    Отбор = Новый Структура("Контрагент", Контрагент.Ссылка);
    ПараметрыФормы = Новый Структура("СформироватьПриОткрытии, Отбор", Истина, Отбор);
    ФормаОтчета = ПолучитьФорму("Отчет.ВзаиморасчетыСКонтрагентами.ФормаОбъекта", ПараметрыФормы);
	
	//затираем пользовательские настройки
    НовыеПользовательскиеНастройки = Новый ПользовательскиеНастройкиКомпоновкиДанных;
    ФормаОтчета.Отчет.КомпоновщикНастроек.ЗагрузитьПользовательскиеНастройки(НовыеПользовательскиеНастройки);
    ОткрытьФорму(ФормаОтчета);	
КонецПроцедуры
Показать
Остальные ответы
Сортировка: Древо
2. user652236_dima_-_- 10.08.18 18:11 Сейчас в теме
ну, есть же ещё настройки по умолчанию и пользовательские настройки.
а фиксированные для "хитрых" пользователей
3. tata_1211 57 10.08.18 19:32 Сейчас в теме
Если это управляемые формы, посмотрите реализацию, к примеру, отчетов по продажам, который в карточке номенклатуры. Там есть, например, отчет по продажам, который как раз открывает отчет по продажам с фильтром по номенклатуре.
4. lenna_1985 61 10.08.18 21:18 Сейчас в теме
Татьяна - какой отчет по продажам в какой конфигурации ?
5. tata_1211 57 11.08.18 11:34 Сейчас в теме
(4) Например, УТ11, в справочнике Номенклатура. Там куча отчетов формируется как раз с отбором. Посмотрите реализацию этих отчетов.
6. lenna_1985 61 12.08.18 19:24 Сейчас в теме
ответ нашла сама может кому пригодиться

&НаКлиенте
Процедура Команда_Взаиморасчеты(Команда)
    //структура отбора
    Отбор = Новый Структура("Контрагент", Контрагент.Ссылка);
    ПараметрыФормы = Новый Структура("СформироватьПриОткрытии, Отбор", Истина, Отбор);
    ФормаОтчета = ПолучитьФорму("Отчет.ВзаиморасчетыСКонтрагентами.ФормаОбъекта", ПараметрыФормы);
	
	//затираем пользовательские настройки
    НовыеПользовательскиеНастройки = Новый ПользовательскиеНастройкиКомпоновкиДанных;
    ФормаОтчета.Отчет.КомпоновщикНастроек.ЗагрузитьПользовательскиеНастройки(НовыеПользовательскиеНастройки);
    ОткрытьФорму(ФормаОтчета);	
КонецПроцедуры
Показать
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Удаленный ИТ-журналист
Санкт-Петербург
По совместительству

Удаленный бизнес-аналитик 1С
Санкт-Петербург
Временный (на проект)

Программист 1С
Москва
Полный день

Консультант-аналитик 1С
Санкт-Петербург
зарплата от 80 000 руб.
Полный день

Аналитик 1С
Москва
зарплата от 80 000 руб. до 120 000 руб.
Полный день