INFOSTART EVENT 2018 EDUCATION

Второй тур голосования за доклады.
Окончание 5 сентября.

Зябликов Дмитрий | Senior ios developer | ЦРПТ

«Разработка на 1С VS нативная разработка под iOS»

- а такое возможно?:) - плюсы и есть ли минусы - нюансы разработки - путь от начала до публикации приложения

1. MarryJane 21 12.06.18 18:55 Сейчас в теме

Добавление в расширение действия к элементу, который добавляется в коде

Добрый день коллеги, хочу поделится с Вами с такой проблемой:
Платформа 8.3.10.2168 база УНФ локализация для Беларуси. Фирма, которая локализовывала базу добавляла элементы на форму документа через общий модуль.

в форме документа добавили процедуру
&НаКлиенте
Процедура РеквизитыПечатиНакладных(Элемент)
....
КонецПроцедуры

В процедуре формы
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
....
//вызов процедуры, которая добавляет необходимые команды и реквизиты на форму
УправлениеФормамиУНФСервер_Локализация.ПриСозданииНаСервере(ЭтаФорма)
КонецПроцедуры

процедура в общем модуле

Процедура ПриСозданииФормыДокументаПеремещениеЗапасов(Форма)  
....

        РеквизитыПечатиНакладных = Команды.Добавить("РеквизитыПечатиНакладных");
	РеквизитыПечатиНакладных.Действие = "РеквизитыПечатиНакладных"; //Команды.РеквизитыПечати.Действие;
	
	РеквизитыПечатиНакладныхКнопка = Элементы.Добавить("РеквизитыПечатиНакладных", Тип("КнопкаФормы"), 
       Элементы.СтраницаДополнительно.ПодчиненныеЭлементы.ГруппаПечать);
	РеквизитыПечатиНакладныхКнопка.Заголовок = "Реквизиты печати накладных";
	РеквизитыПечатиНакладныхКнопка.ИмяКоманды = "РеквизитыПечатиНакладных";
	РеквизитыПечатиНакладныхКнопка.Вид = ВидКнопкиФормы.Гиперссылка;
КонецПроцедуры
Показать


так вот если хочешь сделать расширение в форме документа на процедуру РеквизитыПечатиНакладных() (метод вместо) то ничего не получается (расширение добавляется) механизм как бы не видит расширения. Может кто поделится своими мыслями по этому поводу
Ответы
Сортировка: Древо
4. user705522_constantin_h 7 13.06.18 17:06 Сейчас в теме
(1)Проверьте: запускается ли расширение.
2. VmvLer 13.06.18 09:22 Сейчас в теме
3. MarryJane 21 13.06.18 16:46 Сейчас в теме
Так в том дело что не работает. в расширении. Указываю в расширении эту процедуру как заместить выполнить вместо или сначала, и в расширении не перехватывает эту процедуру
5. MarryJane 21 13.06.18 17:08 Сейчас в теме
Расширение запускается. и работает, но вот просто заметил что в такой ситуации он не хочет перехватывать
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Бизнес-аналитик 1С
Санкт-Петербург
Полный день

Программист 1С
Москва
зарплата от 120 000 руб. до 150 000 руб.
Полный день

Ведущий программист
Москва
зарплата от 130 000 руб. до 200 000 руб.
Полный день

Программист 1С
Одесса (Украина)
зарплата от 40 000 руб.
Полный день

Менеджер по продажам проектов 1С
Санкт-Петербург
Полный день