INFOSTART EVENT 2018 EDUCATION

Второй тур голосования за доклады.
Окончание 5 сентября.

Захаренков Николай | Главный эксперт отдела перспективных разработок | Банк России

«Совершенствование бизнес-процессов предприятия за счет внедрения передовых технологий»

Торговые и производственные информационные технологии в своем развитии прошли несколько стадий: от простейших систем, которые упростили ручной труд до систем ERP, позволяющих планировать и контролировать деятельность всего предприятия. С другой стороны, мы живем в век нейронных сетей, big data, блокчейн, интернета вещей, причем данные технологии вплотную подобрались к производственной деятельности. Учитывая то, что компания 1С является лидером на рынке использования программ автоматизации предприятий, означает, что мимо 1С конфигураций указанные технологии не пройдут. А это значит, что в ближайшее время учетные системы потребуют нового уровня автоматизации и что бы соответствовать этим требованиям в 1С платформе непременно добавятся объекты для создания и управления современными технологиями, а для программистов 1С они станут новыми инструментами. Именно поэтому тему влияния технологий 4 промышленной революции надо обсуждать, делать выводы, строить прогнозы. Своим докладом хотел бы внести маленькую лепту в большое дело и продемонстрировать свое видение работы систем планирования производства 21 века, в едином симбиозе передовых технологий. Тезисы доклада: - Вспомним историю промышленных революций, стандартов производства (от MPS до ERP-2) и их влияние на работу предприятий и эволюцию конфигураций 1С; - Рассмотрим текущие технологии взглядом обывателя, их совместимость, возможность реализации в платформе 1С; - Выявим временные издержки текущей деятельности предприятий при В2В (бизнес для бизнеса) и B2C (бизнес для потребителей) транзакциях; - Попробуем оптимизировать участки производства за счет использования современных технологий и посмотрим к чему это в итоге приведет.

1. user933577 13.03.18 16:13 Сейчас в теме

Загрузка xml в 1с

Есть несколько видов выгрузки данных в xml формат.
Например,

<table name="regcontr">
            <column name="ID">1</column>
            <column name="USNAME">Дом</column>
            <column name="INN">7826652560</column>
        </table>


а есть еще такой вид:

<?xml version="1.0" encoding="windows-1251"?>
<!--Pay--><Root>
	<RegContr>
		<Contr ID="123" SNAME="Дом;" USNAME="Дом;" INN="" KPP="" JADRESS="" FAX="" PHONE="" ACCOUNT="" PADRESS="" OKPO="" OKONH="" BANK="" BIK="" CORACCOUNT="" EMAIL=""/>
	</RegContr>
</Root>


Вид кода, который я нашел, не подходит


&НаСервере
Процедура ПрочитатьXMLФайлНаСервере(Файлик)

	ПутьКФайлу = Файлик[0];
	
	//XML 
	
	ЧтениеXML = Новый ЧтениеXML;
	ЧтениеXML.ОткрытьФайл(ПутьКФайлу);
	
	
	СЗ = Новый СписокЗначений;
	
	Пока ЧтениеXML.Прочитать() Цикл
		
		
		Если ЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда
			 ЧтениеXML.ПрочитатьАтрибут();
			 Атрибут = ЧтениеXML.Значение;
			КонецЕсли;
		
			
		Если ЧтениеXML.ТипУзла = ТипУзлаXML.Текст Тогда
			Если Атрибут = "USNAME" Тогда
				СЗ.Добавить(ЧтениеXML.Значение);		
			КонецЕсли;
			Если Атрибут = "INN" Тогда
				СЗ.Добавить(ЧтениеXML.Значение);		
			КонецЕсли;
				
		КонецЕсли;
		
		Если ЧтениеXML.ТипУзла = ТипУзлаXML.КонецЭлемента and Атрибут="INN" Then 
			СоздатьЭлементСправочника(СЗ);
			
			СЗ.Очистить();
		КонецЕсли;
		
		
		
		
			
		КонецЦикла;
	
КонецПроцедуры

Процедура СоздатьЭлементСправочника(СЗ)
	Если СЗ.Количество() >0 Тогда 
		НовыйЭлемент = Справочники.Поставщики.СоздатьЭлемент();
		НовыйЭлемент.Наименование = СЗ[0].Значение;
		НовыйЭлемент.ИНН =СЗ[1].Значение;
		НовыйЭлемент.Записать();
	КонецЕсли
КонецПроцедуры


&НаКлиенте
Процедура ПрочитатьИзФайлаXML(Команда)
	Режим = режимДиалогаВыбораФайла.Открытие;
ДиалогОткрытияфайла = Новый ДиалогВыборафайла(Режим);
Фильтр = "xml|*.xml";
ДиалогОткрытияфайла.фильтр = фильтр;
Если ДиалогОткрытияфайла.Выбрать() Тогда 
	файлик = ДиалогОткрытияфайла.Выбранныефайлы;
	ПрочитатьXMLФайлНаСервере (Файлик);
	КонецЕсли;

ОбновитьИнтерфейс();
КонецПроцедуры
Показать


Вопрос, что нужно изменить?
Ответы
Сортировка: Древо
2. gradi 13.03.18 16:29 Сейчас в теме
Сериализатором пробовали прочитать?
3. FesenkoA 24 13.03.18 16:52 Сейчас в теме
4. palsergeich 13.03.18 21:35 Сейчас в теме
Построчное чтение XML - ахронизм, и оправдано ИМХО если предполагается что файлы могут быть гигантского размера и все остальные методы отказываются с ними работать.
Объектная техника позволяет описать простые, небольшие и легкие для понимания и изменения алгоритмы.
Если файлы будут небольшие по размеру - то проще всего для понимания через DOM.
Технологичнее и быстрее по скорости чтения - через XDTO но там есть ньюансы.
Выше постом хорошая ссылка по теме, рекомендую ознакомиться.
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии


Преподаватель 1С
Санкт-Петербург
Полный день

Удаленный ИТ-журналист
Санкт-Петербург
По совместительству

Удаленный бизнес-аналитик 1С
Санкт-Петербург
Временный (на проект)

Консультант-аналитик 1С
Санкт-Петербург
зарплата от 80 000 руб.
Полный день