1. user618695_ka 1 12.01.17 11:25 Сейчас в теме

Добавление записи в табличную часть.

Маленькая обработочка, проходится по контрагентам и создает контактные лица (элемент справочника) и заполняет там поле "телефон".

&НаСервере
Процедура СтартНаСервере()
	
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ
		|	Контрагенты.Ссылка КАК Ссылка,
		|	Контрагенты.Представление КАК Наименование,
		|	Контрагенты.Комментарий КАК НомерТелефона,
		|	Контрагенты.КонтактноеЛицо.Ссылка КАК СсылкаНаКонтактноеЛицо
		|ИЗ
		|	Справочник.Контрагенты КАК Контрагенты";
	
	РезультатЗапроса = Запрос.Выполнить();
	
	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
	
	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		
		Элемент = Справочники.КонтактныеЛица.СоздатьЭлемент();  
		Элемент.Наименование = ВыборкаДетальныеЗаписи.Наименование;
		Элемент.Владелец = ВыборкаДетальныеЗаписи.Ссылка;
		
		НоваяСтрока = Элемент.КонтактнаяИнформация.Добавить();
		НоваяСтрока.НомерТелефона = ВыборкаДетальныеЗаписи.НомерТелефона;
		
		Элемент.Записать();
		
	КонецЦикла;
			
КонецПроцедуры

&НаКлиенте
Процедура Старт(Команда)
	СтартНаСервере();
КонецПроцедуры
Показать


Обработка запустилась, создала КонтактныеЛица, но не добавился номер телефона в табличную часть..

Вот так пытаюсь сделать это в коде:
		Элемент = Справочники.КонтактныеЛица.СоздатьЭлемент();  
		Элемент.Наименование = ВыборкаДетальныеЗаписи.Наименование;
		Элемент.Владелец = ВыборкаДетальныеЗаписи.Ссылка;
		
		НоваяСтрока = Элемент.КонтактнаяИнформация.Добавить();
		НоваяСтрока.НомерТелефона = ВыборкаДетальныеЗаписи.НомерТелефона;


Подскажите, как правильно добавить эту запись в табличную часть?
Прикрепленные файлы:
Найденные решения
2. TODD22 17 12.01.17 11:29 Сейчас в теме
У номер нужно указать ещё тип и вид контактной информации.
user618695_ka; yaroslav.artem; kasper076; +3 Ответить
3. antz 12.01.17 11:29 Сейчас в теме
Какие еще реквизиты есть в табличной части? Наверняка там есть что-то вроде "Вид контактной информации", которое тоже нужно заполнять.
user618695_ka; +1 Ответить
Остальные ответы
Избранное Подписка Сортировка: Древо
2. TODD22 17 12.01.17 11:29 Сейчас в теме
У номер нужно указать ещё тип и вид контактной информации.
user618695_ka; yaroslav.artem; kasper076; +3 Ответить
6. user618695_ka 1 12.01.17 12:19 Сейчас в теме
(2) (3) не заполняется всё равно
		НоваяСтрока = Элемент.КонтактнаяИнформация.Добавить();
		НоваяСтрока.Тип = Перечисления.ТипыКонтактнойИнформации.Телефон;
		НоваяСтрока.Вид = Справочники.ВидыКонтактнойИнформации.ТелефонКонтактногоЛица;
		НоваяСтрока.НомерТелефона = ВыборкаДетальныеЗаписи.НомерТелефона;
3. antz 12.01.17 11:29 Сейчас в теме
Какие еще реквизиты есть в табличной части? Наверняка там есть что-то вроде "Вид контактной информации", которое тоже нужно заполнять.
user618695_ka; +1 Ответить
4. user618695_ka 1 12.01.17 12:02 Сейчас в теме
(3) на первом скриншоте видно. Тип, вид, представление, значениеПолей и.т.д.

Тип это перечисление, а вот вид - это справочник.
С типом понятно, а что делать с видом?

		НоваяСтрока = Элемент.КонтактнаяИнформация.Добавить();
		НоваяСтрока.Тип = Перечисления.ТипыКонтактнойИнформации.Телефон;
		НоваяСтрока.Вид = 
		НоваяСтрока.НомерТелефона = ВыборкаДетальныеЗаписи.НомерТелефона;
5. user618695_ka 1 12.01.17 12:11 Сейчас в теме
тоже вроде разобрался..
НоваяСтрока.Вид = Справочники.ВидыКонтактнойИнформации.ТелефонКонтактногоЛица;
7. user618695_ka 1 12.01.17 12:33 Сейчас в теме
Да. Оказалось что сам номер нужно писать в Представление..
		НоваяСтрока = Элемент.КонтактнаяИнформация.Добавить();
		НоваяСтрока.Тип = Перечисления.ТипыКонтактнойИнформации.Телефон;
		НоваяСтрока.Вид = Справочники.ВидыКонтактнойИнформации.ТелефонКонтактногоЛица;
		НоваяСтрока.НомерТелефона = ВыборкаДетальныеЗаписи.НомерТелефона;
		НоваяСтрока.Представление = ВыборкаДетальныеЗаписи.НомерТелефона;
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Санкт-Петербург
зарплата от 110 000 руб. до 120 000 руб.
Полный день

Аналитик 1С
Санкт-Петербург
зарплата от 80 000 руб.
Полный день

Программист 1С
Самара
зарплата от 50 000 руб.
Полный день

Программист 1С
Нижний Новгород
зарплата до 120 000 руб.
Полный день

Программист 1С
Волгоград
зарплата от 45 000 руб. до 90 000 руб.
Полный день