Лисенков Владимир | Руководитель отдела разработки | АО МФК "Городская Сберкасса"

«Имитационное моделирование в среде 1С:Предприятие»

- суть имитационного моделирования, как способа определения наиболее оптимального решения - алгоритмы получения случайных значений по заданному закону распределения - построение имитационной модели и проведение имитационных испытаний в среде 1С:Предприятие В основу доклада будет положена выпускная работа по теме "Имитационное моделирование". Теория и практическая часть на платформе 1С. В качестве примера - расчет оценки кредитного риска по методу VAR в финансовых организациях. Платформа 1С будет рассмотрена в качестве аналога такому пакету как Oracle Cristal Ball.

Заполнение шапки табличного документа

1. danjer74 29.12.16 11:15 Сейчас в теме
Вот еще какой вопрос - у меня есть документ Товарный Чек. Как бы мне сделать так, чтобы проставить ТабличныйДокумент.КоличествоЭкземпляров = 2, но на одном в шапке написать "Экземпляр покупателя", а на другом "Экземпляр продавца"?
Ответы
Сортировка: Древо
2. olgerd666 49 29.12.16 11:19 Сейчас в теме
(1)
Вот еще какой вопрос - у меня есть документ Товарный Чек. Как бы мне сделать так, чтобы проставить ТабличныйДокумент.КоличествоЭкземпляров = 2, но на одном в шапке написать "Экземпляр покупателя", а на другом "Экземпляр продавца"?

Сделать вторую печатную форму с надписью "Экземпляр продавца". Потом при печати выводить две ПФ подряд - по указанию какого либо условия(можно выводить сообщение - "Печатать второй экз.?" и по нему печатать уже вторую форму).
3. danjer74 29.12.16 11:20 Сейчас в теме
(2)Ну это я первым делом предположил :) По другому никак? :)
4. vovan_victory 58 29.12.16 11:27 Сейчас в теме
В шапку добавляешь параметр "ЧейЭкзампляр"

Коде при заполнении

//Перед заполнением шапки из таб док получим количество экземпляров 
Кол = ТабличныйДокумент.КоличествоЭкземпляров;

//Кол-во установим равное 1
ТабличныйДокумент.КоличествоЭкземпляров = 1;

//Заполняем шапку
Для Н = 0 По Кол Цикл

//Функция ЧетноеЧисло проверяет какое число Н четное или нет. Если четное, это экземпляр продавца, нет - наш
//четность проверяется на случай, если количество экземпляров больше 2.
Если ЧетноеЧисло(пЧисло)  Тогда 
    ЧейЭкзампляр = "Экземпляр продавца";
Иначе
    ЧейЭкзампляр = "Наш экземпляр";
КонецЕсли;

Шапка.ЧейЭкзампляр = ЧейЭкзампляр;


//Заполняем таб.. док
Для каждого ... Из Источник Цикл

............................

..................................


КонецЦикла;


КонецЦикла;


Функция ЧетноеЧисло(пЧисло)    
    Четное = пЧисло%2=0;
    Возврат Четное;    
КонецФункции
Показать
5. danjer74 29.12.16 11:36 Сейчас в теме
(4)Это куда вставлять? Не совсем понял, что такое источник
7. vovan_victory 58 29.12.16 11:52 Сейчас в теме
(5)А Вы предполагаете, что я телепат? и могу видеть Ваш код чтобы сказать конкретно куда нужно вставить
8. danjer74 29.12.16 13:22 Сейчас в теме
9. vovan_victory 58 29.12.16 13:27 Сейчас в теме
(8)Это выборка из которой вы заполняете табличный документ. Эта переменная у Вас может называться как угодно.
Я Вам всего лишь пример того, как можно реализовать поставленную задачу, а Вы по этому принципу можете переделать свой код

Или прикрепите саму печатную форму или покажите код, тогда будет легче разговаривать
6. danjer74 29.12.16 11:41 Сейчас в теме
(4)Все равно не понятно Для каждого из источник
10. vovan_victory 58 29.12.16 13:30 Сейчас в теме
Источник = Запрос.Выполнить().Выгрузить();

//в цикле идет заполнение таблицы
Для каждого Стр Из Источник Цикл
...........................................
КонецЦикла;


ИЛИ

//в цикле идет заполнение таблицы
Источник =  Запрос.Выполнить().Выбрать();

Пока  Источник.Следующий() Цикл
......................
конецЦикла;
11. danjer74 29.12.16 16:19 Сейчас в теме
(10)Тогда понятно. Выборки там у меня нету. Документ берется один.
12. vovan_victory 58 29.12.16 16:21 Сейчас в теме
А разница то какая?
Источник = Ссылка;


И убрать цикл...
13. vovan_victory 58 29.12.16 16:23 Сейчас в теме
//Перед заполнением шапки из таб док получим количество экземпляров 
Кол = ТабличныйДокумент.КоличествоЭкземпляров;

//Кол-во установим равное 1
ТабличныйДокумент.КоличествоЭкземпляров = 1;

//Заполняем шапку
Для Н = 0 По Кол Цикл

//Функция ЧетноеЧисло проверяет какое число Н четное или нет. Если четное, это экземпляр продавца, нет - наш
//четность проверяется на случай, если количество экземпляров больше 2.
Если ЧетноеЧисло(пЧисло)  Тогда 
    ЧейЭкзампляр = "Экземпляр продавца";
Иначе
    ЧейЭкзампляр = "Наш экземпляр";
КонецЕсли;

Шапка.ЧейЭкзампляр = ЧейЭкзампляр;


//Заполняем таб.. док
...........................

..................................



КонецЦикла;


Функция ЧетноеЧисло(пЧисло)    
    Четное = пЧисло%2=0;
    Возврат Четное;    
КонецФункции
Показать
Оставьте свое сообщение

Вакансии

Бизнес-аналитик 1С
Санкт-Петербург
зарплата от 70 000 руб. до 90 000 руб.
Полный день

Консультант-аналитик 1С
Санкт-Петербург
зарплата от 50 000 руб. до 65 000 руб.
Полный день

Консультант по внедрению 1С
Новосибирск
Полный день

Программист 1С
Новокузнецк
зарплата от 55 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 70 000 руб. до 110 000 руб.
Полный день