1. PoZiTiFFF 596 06.05.14 12:08 Сейчас в теме

Вывод колонок отчета СКД друг под другом

Здравствуйте. Подскажите, пожалуйста, вывожу отчет СКД- используя настройку, указанную в первом приложенном файле (добавлена таблица, у которой в Колонках две группировки, одна под другой). В результате получается шапка, где сначала в строке идет первая группировка, затем в этой же строки разваливается вторая группировка и т.д., а хотелось бы добиться чтобы эти группировки шли под друг под другом. Подскажите, пожалуйста, как этого можно добиться.
Прикрепленные файлы:
Ответы
Избранное Подписка Сортировка: Древо
2. fierylions 204 06.05.14 12:56 Сейчас в теме
В реконфигурация в настройках скд на вкладке "Другие настройки" там есть:
1. Расположение полей группировок
2. Расположение группировок
Попробуйте поэкспериментировать с ними.
4. PoZiTiFFF 596 06.05.14 14:32 Сейчас в теме
(2) fierylions, Всевозможные манипуляции с указанными настройками не привели к нужному результату
(3) spezc, вывод в рамках одной группировки приведет к тому что в каждой колонке будет и поле первой группировки и ниже поле второй, это не то что мне нужно.
Вопрос открыт.
3. spezc 545 06.05.14 14:05 Сейчас в теме
ВидТары и Номенклатуры нужно выводить в рамках одной группировки
5. spezc 545 06.05.14 14:56 Сейчас в теме
похоже понял, что хочется автору. средствами СКД такое не сделать.
вижу решение так: использовать способ из (3) и при выводе макета - вручную пробегать по ячейкам шапки, и объединять нужные ячейки верхнего уровня (в данном случае ячейки, содержащие "мешки" и "МКР")
agdam_m; adva; PoZiTiFFF; +3 Ответить
6. PoZiTiFFF 596 06.05.14 15:09 Сейчас в теме
(5) spezc, то есть использовать свой макет в СКД и программную обработку вывода? Спасибо за предложение, а есть еще варианты?
11. adva 39 07.05.14 06:38 Сейчас в теме
я бы тоже как в (5) сделал
7. PoZiTiFFF 596 06.05.14 17:26 Сейчас в теме
Куда-то слетел прикрепленный файл "как хочу", добавляю его, заодно поднимаю тему наверх. Надеюсь на Вашу помощь и дельные советы.
Прикрепленные файлы:
8. PoZiTiFFF 596 07.05.14 06:29 Сейчас в теме
9. adva 39 07.05.14 06:32 Сейчас в теме
А разве нельзя группу в группу?
10. adva 39 07.05.14 06:33 Сейчас в теме
хотя нет, тут не поможет
12. PoZiTiFFF 596 07.05.14 21:02 Сейчас в теме
Воспользовался идеей предложенной spezc. Получлась следующая постобработка табличного документа в коде:

Процедура ОбъединитьОбластиПоЗаданномуТексту (Текст)
	
	ОбрабатываемаяОбласть = ЭлементыФормы.Результат.НайтиТекст(Текст);   
	
	Если ОбрабатываемаяОбласть<>Неопределено Тогда
		
		НачалоОбъединяемойОбласти = ОбрабатываемаяОбласть.Имя;
		
		Пока ОбрабатываемаяОбласть <> Неопределено  Цикл
			КонецОбъединяемойОбласти = ОбрабатываемаяОбласть.Имя;
			ОбрабатываемаяОбласть = ЭлементыФормы.Результат.НайтиТекст(Текст, ОбрабатываемаяОбласть,,,Истина);   			
		КонецЦикла;
		
		ОбъединяемаяОбласть = ЭлементыФормы.Результат.Область (НачалоОбъединяемойОбласти+":"+КонецОбъединяемойОбласти);
		ОбъединяемаяОбласть.Объединить();
		ОбъединяемаяОбласть.ГоризонтальноеПоложение=ГоризонтальноеПоложение.Центр;
		ОбъединяемаяОбласть.Текст=Текст;
	КонецЕсли;

КонецПроцедуры


Процедура ДействияФормыСформировать(Кнопка)
	
	ОбновитьОтчет();
	
	СписокСтрокДляПоиска = Новый СписокЗначений();
	СписокСтрокДляПоиска.Добавить("мешки");
	СписокСтрокДляПоиска.Добавить("МКР");
	СписокСтрокДляПоиска.Добавить("навал");
	
	Для Каждого СтрокаСписка из СписокСтрокДляПоиска Цикл
		ОбъединитьОбластиПоЗаданномуТексту(СтрокаСписка.Значение);
	КонецЦикла;
	
КонецПроцедуры
Показать


Единственное, что это решение для заранее определенных значений первой группировки, если же значения не известны, то данный метод не подходит, то есть универсальным его назвать, к сожалению, никак нельзя.
13. spezc 545 08.05.14 09:11 Сейчас в теме
СКД не всесильна, иногда приходится достигать цели на костылях, так что универсальность да, хромать будет
14. adva 39 08.05.14 09:38 Сейчас в теме
Думаю проще обработать такой вариант настроек (почти в том виде как требуются, остается просто объединить одинаковые заголовки, проверяя, что внизу либо количество, либо количество итого, ну и объединить с полями Количество)
Прикрепленные файлы:
Настройки.xml
PoZiTiFFF; +1 Ответить
15. adva 39 08.05.14 09:38 Сейчас в теме
Причем обрабатывать можно универсально, не зная, заранее, чего в ячейках
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Специалист техподдержки 1С
Иркутск
зарплата от 28 000 руб. до 34 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 48 000 руб. до 96 000 руб.
По совместительству

Программист 1С
Ставрополь
зарплата от 40 000 руб. до 60 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 120 000 руб. до 150 000 руб.
Полный день

Программист 1С
Благовещенск (Амурская область)
зарплата от 40 000 руб. до 70 000 руб.
Полный день