0. ptkrzy 69 15.10.12 18:31 Сейчас в теме

УНФ РИБ

В типовой УНФ нет РИБа. Исправляем этот недостаток, используя УТ 11 и ИТС. Статья подойдет для настойки распределенки в любой конфе на базе БСП.

Перейти к публикации

Комментарии
Избранное Подписка Сортировка: Древо
1. Воронкин 16.10.12 19:52 Сейчас в теме
Думаю, скоро появится и штатно. В первых релизах УТ 11 - вообще ничего не было, потом функционал из 10.3 стали добавлять.
2. KliMich 16.10.12 22:12 Сейчас в теме
Наверное скоро будет... Но пока это актуально!
3. ptkrzy 69 16.10.12 22:32 Сейчас в теме
Это актуально для любой конфы на базе БСП, в том числе и для любой самописной.
4. Воронкин 17.10.12 15:11 Сейчас в теме
(3) За это и респект автору.
5. alexware 23.10.12 04:46 Сейчас в теме
Автору плюс. Как раз имею самописную конфигурацию на базе БСП и хотел бы внедрить РИБ. Выглядит вроде не очень страшно.
7. dimk@a 24.10.12 00:23 Сейчас в теме
Уж не знаю, как скоро появится в штатной, но у меня уже 3 месяца работает. Причем тупо создал план обмена, и галочки снимал чисто на глаз. Автору спасибо за публикацию - подправлю теперь свое творчество, и теперь я понял почему у меня всегда пишет выгружено 0 объектов. Ошибку с созданием образа подчиненной побеждал так - сохранял образ не в локальный каталог, а использовал сетевой путь, который начинается с \\
8. Tangram 150 30.01.13 23:40 Сейчас в теме
Для 1.4.4.11 в модуль менеджера плана обмена Полный нужно еще добавить:

Функция ПланОбменаИспользуетсяВМоделиСервиса() Экспорт
	Возврат ложь;
КонецФункции // ПланОбменаИспользуетсяВМоделиСервиса()

Функция ПодробнаяИнформацияПоОбмену() Экспорт

	Возврат "Обмен УНФ <-> УНФ";

КонецФункции // ПодробнаяИнформацияПоОбмену()
 
Функция КраткаяИнформацияПоОбмену() Экспорт
	Возврат "Обмен УНФ <-> УНФ";	
КонецФункции // КраткаяИнформацияПоОбмену()
Показать


Иначе УНФ вообще не запускается.
9. Tangram 150 01.02.13 00:44 Сейчас в теме
В продолжение темы:
Модуль менеджера плана обмена Полный:
Исправляем процедуру

    Функция НастройкаОтборовНаУзле() Экспорт
        Возврат Новый Структура; // мг
    КонецФункции


При запуске ПИБ вываливается на исключении в обработчике ПередЗаписью справочника ИдентификаторыОбъектовМетаданных:

	Если ПланыОбмена.ГлавныйУзел() <> Неопределено Тогда // Это не главный узел ИБ в РИБ-обмене.
		ВызватьИсключениеПоОшибке(
			НСтр("ru = 'Изменение идентификаторов объектов метаданных может быть выполнено
			           |только в главном узле распределенной информационной базы.'"));
	КонецЕсли;


Включение справочника в обмен пока не помогло.
Пока остановился на этом, разберусь, отпишу.
10. ptkrzy 69 01.02.13 11:56 Сейчас в теме
Просто закоментируй вызов исключения. В 1.4.4.10 много чего поменялось - нужно добавить несколько заглушек в модуль менеджера.
	Функция ПояснениеДляНастройкиПараметровУчета() Экспорт
		Возврат "";
	КонецФункции
	Функция ЗначенияПоУмолчаниюНаУзле() Экспорт

        Возврат Неопределено;
    КонецФункции

    Функция ЗначенияПоУмолчаниюНаУзлеБазыКорреспондента() Экспорт
        Возврат Неопределено;
    КонецФункции

    Функция ИмяФайлаНастроекДляПриемника() Экспорт
        Возврат НСтр("ru = 'Настройки обмена УНФ-УНФ'");
    КонецФункции

    Функция ИспользуемыеТранспортыСообщенийОбмена() Экспорт
        Результат = Новый Массив;
        Результат.Добавить(Перечисления.ВидыТранспортаСообщенийОбмена.FILE);
		Результат.Добавить(Перечисления.ВидыТранспортаСообщенийОбмена.FTP);
        Возврат Результат;
    КонецФункции

    Функция ИмяФормыСозданияНачальногоОбраза() Экспорт
		Возврат "ОбщаяФорма.СозданиеНачальногоОбразаСФайлами";
                //Решает проблему с созданием начального образа

    КонецФункции

    Функция ЗаголовокКомандыДляСозданияНовогоОбменаДанными() Экспорт
         Возврат НСтр("ru = 'Создать обмен УНФ-УНФ'");
    КонецФункции

    Функция ИспользоватьПомощникСозданияОбменаДанными() Экспорт
        Возврат Истина;
    КонецФункции

    Функция НастройкаОтборовНаУзле() Экспорт
        Возврат Новый Структура;
    КонецФункции

    Функция НастройкаОтборовНаУзлеБазыКорреспондента() Экспорт
        Возврат Неопределено;
    КонецФункции

    Функция ОписаниеЗначенийПоУмолчанию(ЗначенияПоУмолчаниюНаУзле) Экспорт
        Возврат "";
    КонецФункции

    Функция ОписаниеЗначенийПоУмолчаниюБазыКорреспондента(ЗначенияПоУмолчаниюНаУзле) Экспорт
          Возврат "";
     КонецФункции

    Функция ОписаниеОграниченийПередачиДанных(НастройкаОтборовНаУзле) Экспорт
     Возврат "";    
    КонецФункции

    Функция ОписаниеОграниченийПередачиДанныхБазыКорреспондента(НастройкаОтборовНаУзле) Экспорт    
        Возврат "";    
	КонецФункции
	
	Функция КраткаяИнформацияПоОбмену() Экспорт
		Возврат "КраткаяИнформацияПоОбмену";    
	КонецФункции
	Функция ПодробнаяИнформацияПоОбмену() Экспорт
		Возврат "";    
	КонецФункции
	Функция ПланОбменаИспользуетсяВМоделиСервиса() Экспорт
		Возврат Ложь;
	КонецФункции
	


Показать
11. aser86 13.03.13 13:26 Сейчас в теме
Добрый день! Не могли бы Вы выслать на почту ksaz@bk.ru .cf файл УНФ с настроенным планом обмена? а то у меня какие то ошибки выходят и не хочет создаваться распределенная база, буду очень очень благодарен !!!
12. LexSeIch 202 15.06.13 19:23 Сейчас в теме
Мир этому дому!
Автору плюс. Полезная информация по использованию БСП.
13. Tangram 150 17.06.13 10:03 Сейчас в теме
При обновлении на 1.4.6.19 в модуль менеджера плана обмена надо добавить функцию:

//Возвращает режим запуска, в случае интерактивного инициирования синхронизации
//Возвращаемые значения АвтоматическаяСинхронизация Или ИнтерактивнаяСинхронизация
//На основании этих значений запускается либо помощник интерактивного обмена, либо автообмен
Функция РежимЗапускаСинхронизацииДанных(УзелИнформационнойБазы) Экспорт

Возврат "АвтоматическаяСинхронизация";

КонецФункции
14. 13kawaii13 16.08.13 15:06 Сейчас в теме
При включении базы подчинённого узла выходит ошибка.



{Справочник.ИдентификаторыОбъектовМетаданных.МодульМенеджера(373)}: Ошибка при вызове метода контекста (Записать)
ТаблицаОбъект.Записать();
по причине:
Ошибка при выполнении обработчика - 'ПередЗаписью'
по причине:
{Справочник.ИдентификаторыОбъектовМетаданных.МодульОбъекта(96)}: Ошибка при работе со справочником "Идентификаторы объектов метаданных".

Добавление новых элементов может быть выполнено
только в главном узле распределенной информационной базы.
ТаблицаОбъект.Записать();


Вышлите мне пожалуйста .cf файл УНФ с настроенным планом обмена.
kawaii@live.ru
Не могу обойти возникающие ошибки. Релиз (1.4.6.19)
17. sudo90 09.02.14 11:57 Сейчас в теме
(14) 13kawaii13, Здравствуйте, тоже возникла ошибка такая же как у Вас, Вы справились с ней?
19. 13kawaii13 09.02.14 12:25 Сейчас в теме
(17) sudo90, Просто не стали обновляться на последний релиз.
15. 13kawaii13 20.08.13 10:51 Сейчас в теме
Вышлите мне пожалуйста .cf файл УНФ с настроенным планом обмена. (На любом релизе)
16. ptkrzy 69 23.08.13 16:10 Сейчас в теме
У меня есть сильно переписаная под нужды заказчика конфигурация. Это будет некорректно по отношению к заказчику и нарушать права самой 1с. Предложите метод, который позволит выгрузить лишь отличия между типовой кинфигурацией и УНФ+РИБ. Почитайте статью на ИТС http://its.1c.ru/db/bspdoc?db=bspdoc#content:34:1 .Либо обратитесь к франчайзи своего региона. Я думаю они смогут вам помочь.
20. sudo90 09.02.14 15:08 Сейчас в теме
Жаль, а у нас версия как раз 1.4.6.19((
21. ptkrzy 69 10.02.14 10:51 Сейчас в теме
Для 1.4.7.37 подробно описано по ссылке http://infostart.ru/public/249881/
22. Prometeus2011 88 22.07.16 09:47 Сейчас в теме
Если в модуле "ОбменДаннымиПовтИсп", процедура "ИспользуемыеТранспортыСообщенийОбмена" закомментировать строки:
Если Не ЭтоУзелАвтономногоРабочегоМеста(УзелИнформационнойБазы) Тогда
          ОбщегоНазначенияКлиентСервер.УдалитьЗначениеИзМассива(Результат, Перечисления.ВидыТранспортаСообщенийОбмена.WS);
КонецЕсли;

, то это позволяет производить синхронизацию в режиме сервиса, по http протоколу.
(Версия УНФ 1.6.4.19)
23. al_zzz 123 23.10.16 15:36 Сейчас в теме
Прошло 4 года с момента публикации. Видимо штатный РИБ в УНФ уже вряд ли появится...
24. Shaldryn 08.11.16 15:19 Сейчас в теме
кто настраивал в 1.6? вроде бы создает РИБ, но при запуске ее отображает не все разделы, только Работа, Зарплата, Производство. В чем может быть косяк?
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Ведущий программист 1С
Санкт-Петербург
зарплата от 130 000 руб.
Полный день

Программист 1С
Москва
зарплата от 130 000 руб. до 200 000 руб.
Полный день

Бизнес-архитектор 1С, ведущий консультант
Санкт-Петербург
Полный день

Руководитель проектов 1С
Санкт-Петербург
Полный день

Программист 1C
Москва
зарплата от 100 000 руб. до 150 000 руб.
Полный день