Ошибка при сохранении ценников в файл "Не определен список получаемых файлов.

1. 02.12.22 21:30 Сейчас в теме
Добрый вечер. Подскажите что может быть. У одного из пользователей базы, с правами админа, выскакивает ошибка при сохранении ценников в файл PDF формата "Не определен список получаемых файлов", если же файл не сохранят а попробовать отправить по почте то вложения с ценниками нет. Проверял на 1 машине, заходил под 1 администратором, все сохраняет и отправляет, тут же если зайти под другим администратором то постоянно выскакивает эта ошибка.
Найденные решения
5. CYCTAHOH 06.12.22 11:13 Сейчас в теме
Помогла такая штука что удалил все настройки пользователя и эта тема пропала. Удаление настройки табличного документа эффекта не дали. Только полное удаление настроек.
Остальные ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
2. user1881061 05.12.22 16:11 Сейчас в теме
привет. такая же проблема....нашли как то решение?
4. CYCTAHOH 06.12.22 10:48 Сейчас в теме
(2) Долго мучился. Решил таким образом (не самым рациональным, но рабочим). Создал такого же пользователя, пометил старого на удаление, обработкой поменял ссылки в документах со старого пользователя на нового, после удалил старого.
6. lexushka 12.01.23 16:51 Сейчас в теме
(1)
&НаСервере
&Перед("ЗагрузитьНастройкиКоличестваКопий")
Процедура Olp_ЗагрузитьНастройкиКоличестваКопий()
	
	СохраненныеНастройкиПечатныхФорм = Новый Массив;
	
	ИспользоватьСохраненныеНастройки = Истина;
	Если ТипЗнч(Параметры.ПараметрыПечати) = Тип("Структура") И Параметры.ПараметрыПечати.Свойство("ПереопределитьПользовательскиеНастройкиКоличества") Тогда
		ИспользоватьСохраненныеНастройки = Не Параметры.ПараметрыПечати.ПереопределитьПользовательскиеНастройкиКоличества;
	КонецЕсли;
	
	Если ИспользоватьСохраненныеНастройки Тогда
		Если ЗначениеЗаполнено(Параметры.ИсточникДанных) Тогда
			КлючНастроек = Строка(Параметры.ИсточникДанных.УникальныйИдентификатор()) + "-" + Параметры.ПараметрыИсточника.ИдентификаторКоманды;
		Иначе
			ИменаМакетов = Параметры.ИменаМакетов;
			Если ТипЗнч(ИменаМакетов) = Тип("Массив") Тогда
				ИменаМакетов = СтрСоединить(ИменаМакетов, ",");
			КонецЕсли;
			
			КлючНастроек = Параметры.ИмяМенеджераПечати + "-" + ИменаМакетов;
		КонецЕсли;
		СохраненныеНастройкиПечатныхФорм = ОбщегоНазначения.ХранилищеОбщихНастроекЗагрузить("НастройкиПечатныхФорм", КлючНастроек, Новый Массив);
		
		Olp_СброкитьНастройкиЕслиЕстьНулевоеКоличествоКопий(СохраненныеНастройкиПечатныхФорм, КлючНастроек); //!!

	КонецЕсли;
	
КонецПроцедуры

&НаСервере
Процедура Olp_СброкитьНастройкиЕслиЕстьНулевоеКоличествоКопий(СохраненныеНастройкиПечатныхФорм, КлючНастроек)    
	
	НадоСбрасыватьНастройки = Ложь;   
	
	Для каждого Эл из СохраненныеНастройкиПечатныхФорм Цикл
		
		Если Не ЗначениеЗаполнено(Эл.Количество) Тогда
			НадоСбрасыватьНастройки = Истина;
			Прервать;
		КонецЕсли;
		
	КонецЦикла;
	
	Если НадоСбрасыватьНастройки = Истина Тогда
		ОбщегоНазначения.ХранилищеОбщихНастроекУдалить("НастройкиПечатныхФорм", КлючНастроек, Пользователи.ТекущийПользователь());
	КонецЕсли;
	
КонецПроцедуры
Показать
3. mrisha 06.12.22 08:18 Сейчас в теме
Здравствуйте. Посмотрите, что в настройках пользователя по работе с табличной формой документа, возможно там запрет на редактирование стоит. Ну или в конфигураторе можно посмотреть, я думаю.
5. CYCTAHOH 06.12.22 11:13 Сейчас в теме
Помогла такая штука что удалил все настройки пользователя и эта тема пропала. Удаление настройки табличного документа эффекта не дали. Только полное удаление настроек.
Оставьте свое сообщение
Вакансии
Инженер 1С
Ессентуки
зарплата от 120 000 руб. до 144 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 100 000 руб. до 250 000 руб.
Полный день

Программист 1С
Краснознаменск (Московская обл.)
зарплата от 150 000 руб. до 250 000 руб.
Полный день

Специалист техподдержки
Краснознаменск (Московская обл.)
зарплата от 50 000 руб. до 100 000 руб.
Полный день

Программист, аналитик, эксперт 1С
Санкт-Петербург
По совместительству