Адресный классификатор в УПП 166.2

1. cherva 30.09.21 16:48 Сейчас в теме
Поставили новый релиз УПП 166.2. В описании написано "Новая адресная информация заполняется по формату ФИАС (пункт 1 части 2 статьи 5 Федерального закона от 28.12.2013 № 443-ФЗ). Загрузить адресный классификатор ФИАС можно с портала 1С:ИТС, а также из файлов, распространяемых ФНС РФ." Загрузили с ИТС классификатор ФИАС, но он не загружается в УПП, УПП ищет файлы по старому формату. Что не так сделали?
Ответы
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
2. TokarevV 01.10.21 08:16 Сейчас в теме
Как именно не загружается? Что пишет? Что делаете конкретно, как загружаете?
3. cherva 96 01.10.21 09:33 Сейчас в теме
Там пытается загрузить адресный классификатор КЛАДР ( формат файлов dbf) , а у ФИАС другой формат файлов!
4. cherva 96 01.10.21 09:35 Сейчас в теме
Пытаемся загрузить адресный классификатор из одноименного Регистра сведений.
5. cherva 96 01.10.21 09:54 Сейчас в теме
Из формы редактирования адреса Классификатор загружается ( правда непонятно какой!!! загружали с ИТС в папке почему то не видит). После этого при заполнении адреса на номере дома система наглухо виснет!
assol2000; +1 Ответить
7. homer_ 76 04.10.21 10:46 Сейчас в теме
(5)
Функция НомерДомаЧислом(ИсходнаяСтрока)
	
	НаборСимволов = СтрРазделить(ИсходнаяСтрока, "0123456789", Ложь);
	СимволыДляУдаления = СтрСоединить(НаборСимволов);
	//Добавить
	//Временное решение
	Если ИсходнаяСтрока = "" Тогда
		Возврат 0
	КонецЕсли;
	//
	НаборЦифр = СтрРазделить(ИсходнаяСтрока, СимволыДляУдаления, Ложь);
	ИтоговоеЧисло = СтрСоединить(НаборЦифр);
	
	Возврат ?(ПустаяСтрока(ИтоговоеЧисло), 0, Число(ИтоговоеЧисло));
КонецФункции
Показать
user1270445; +1 Ответить
6. Andrekaa 03.10.21 21:12 Сейчас в теме
Совсем разработчики плюнули на тестирование УПП перед выпуском релиза(
Сломали работу с адресным классификатором
8. user1270445 05.10.21 10:00 Сейчас в теме
V8 ответил
Добрый день.



Зарегистрирована ошибка 00-00404444.


Локальное исправление:
1. Заменить обработку РедактированиеКонтактнойИнформации (во вложении)

2. Внести изменения в общие модули
Общий модуль АдресныйКлассификаторСлужебный
Функция НомерДомаЧислом
Строку:
НаборЦифр = СтрРазделить(ИсходнаяСтрока, СимволыДляУдаления, Ложь);

заменить на строку:
НаборЦифр = ?(ПустаяСтрока(ИсходнаяСтрока) И ПустаяСтрока(СимволыДляУдаления), Новый Массив, СтрРазделить(ИсходнаяСтрока, СимволыДляУдаления, Ложь));



Процедура ДобавитьИнформациюОДоме
Строку:
НайденныйФрагментСтроения = Новый ФорматированнаяСтрока(ТекстПроСтроения, Разделитель + НазваниеСтроения + " " + СокрЛП(ОписаниеДома.Строние));

заменить на строку:
НайденныйФрагментСтроения = Новый ФорматированнаяСтрока(ТекстПроСтроения, Разделитель + НазваниеСтроения + " " + СокрЛП(ОписаниеДома.Строение));



Общий модуль РаботаСАдресами
Заменить объявление функции:
Функция СтруктураАдресаВСтруктуруJSON(Знач КонтактнаяИнформация)


на следующее:
Функция СтруктураАдресаВСтруктуруJSON(Знач КонтактнаяИнформация) Экспорт
Прикрепленные файлы:
РедактированиеКонтактнойИнформации.epf
makar-ananev; AgroPZU; Misanets; AnddnA; +4 Ответить
9. denklu 05.10.21 10:47 Сейчас в теме
Совсем разработчики плюнули на тестирование УПП перед выпуском релиза...
Зарегистрирована ошибка 00-00404444.
Жесть, тоже сегодня столкнулся с этим. Только устроился на новую работу, а тут такие "официальные" подставы. 2 обновления - 2 косяка. Первый это на предыдущем обновлении, когда реализации перестали проводиться из-за отслеживаемости.
10. elisabet 98 05.10.21 12:32 Сейчас в теме
(8) День добрый. у меня такой же косяк у людей.
Спасибо огромное, все заработало!
11. Andrekaa 05.10.21 12:59 Сейчас в теме
12. user1270445 05.10.21 13:03 Сейчас в теме
(10),(11) C выбором из классификатора осталась проблема.
14. elisabet 98 05.10.21 18:22 Сейчас в теме
(12) Очисти полностью классификатор и залей его заново. Проблема исчезнет.
29. гаврюша 2 17.10.21 20:09 Сейчас в теме
(14) Если полностью очистить классификатор, а потом залить его заново, ранее заведенная в справочниках информация по адресам не очистится (не измениться)?
30. elisabet 98 18.10.21 07:09 Сейчас в теме
13. sergio199 17 05.10.21 13:12 Сейчас в теме
При попытке добавить новый адрес в справочнике "Физические лица" вываливается ошибка
{Обработка.РедактированиеКонтактнойИнформации.МодульОбъекта(126)}: Поле объекта не обнаружено (Значение)
Если ПустаяСтрока(СтруктураЗаписи.Значение) Тогда

Это уже на замененной обработке.
А при добавлении в регистре сведений "Контактная информация" такой ошибки нет.
20. Misanets 339 06.10.21 18:54 Сейчас в теме
(13) я решил проблему изменением в пару строк. Ошибка в том, что в функцию могут передаваться выборки из разных запросов, "как раньше" и "в новом формате". Если передается выборка "как раньше", то она не содержит в себе поля "Значение", по этому и возникает ошибка.

В Функции ПолучитьПредставлениеАдреса()
Строку:
Если ЗначениеЗаполнено(Запись.Значение) Тогда

заменить на:
СтруктураПроверки = Новый Структура("Значение", "");
ЗаполнитьЗначенияСвойств(Структурапроверки, Запись);
Если ЗначениеЗаполнено(СтруктураПроверки.Значение) Тогда
26. sergio199 17 11.10.21 09:18 Сейчас в теме
(20) А в обновлении УПП решения подобной ошибки так и не вышло.
15. cherva 96 06.10.21 10:42 Сейчас в теме
При обновлении столкнулись еще с одной ошибкой, касающейся контактной информации:
после обновления на релиз 166.2
в справочнике Клиенты на закладке контакты
идет неправильная сортировка,
раньше все заполненные элементы были вверху,
а сейчас вверху находятся пустые строки, а заполненные строи идут в середине и в конце
19. xard2003 06.10.21 13:37 Сейчас в теме
(15)
Внести изменение в общем модуле УправлениеКонтактнойИнформацией
Процедура ПрочитатьКонтактнуюИнформацию
Добавить строчку кода в конце процедуры:
ТабЗн.Сортировать("Представление Убыв");

Код:
ТабЗн = Запрос.Выполнить().Выгрузить();
ТабЗн.Сортировать("Представление Убыв"); // Временное решение
Для Каждого стр Из ТабЗн Цикл
	стр.Представление = СокрП(стр.Представление);
	стр.Комментарий   = СокрП(стр.Комментарий);
КонецЦикла;
16. user1675860 06.10.21 12:39 Сейчас в теме
Все сделал что указано у user1270445

Теперь вылезает ошибка такого рода

{ОбщийМодуль.УправлениеКонтактнойИнформациейСлужебный.Модуль(225)}: Ошибка при вызове метода контекста (ЗаписатьJSON)
ЗаписатьJSON(ЗаписьJSON, Значение,, "АдаптацияПолейКонтактнойИнформации", УправлениеКонтактнойИнформациейСлужебный);
по причине:
Передано значение недопустимого типа
17. makar-ananev 06.10.21 13:04 Сейчас в теме
18. user1675860 06.10.21 13:22 Сейчас в теме
(17) причем регион, город сохраняется без проблем, а если водить номер дома и улицы, то эта ошибка вылезает, и даже если сохраняется, при попытке редактировать снова все данные слетают
21. Andrekaa 07.10.21 08:26 Сейчас в теме
Вышел релиз 1.3.167.1, но проблема набора адреса осталась (именно набора)
22. user1270445 07.10.21 16:30 Сейчас в теме
(21) надо сделать, как (14) написал
23. Asaqura 07.10.21 16:36 Сейчас в теме
(22) Сотрудники организации (выбираем сотрудника) - Более подробно о физическом лице-Адреса и телефоны- Добавить = {Обработка.РедактированиеКонтактнойИнформации.МодульОбъекта(126)}: Поле объекта не обнаружено (Значение)
Если ПустаяСтрока(СтруктураЗаписи.Значение) Тогда
24. user1270445 07.10.21 16:53 Сейчас в теме
(23) все добавилось без ошибок (на серверной базе). Роль Добавление и изменение адресной информации у пользователя включена.
25. krenchik 08.10.21 12:32 Сейчас в теме
Установила релиз 1.3.167.1 + загрузила новый классификатор + добавила некоторым пользователям роль "Добавление и изменение адресной информации" - пользователи довольны)))
27. 5591igor 12.10.21 12:39 Сейчас в теме
1С УПП 1.3.166.2 Теже самые проблемы + не могу попасть под админскими правами через физические лица к форме где есть загрузка адресного класификатора ( роль редактирования адресных данных себе добавил толку ноль Вход к класификатору только от роли кадровика Чуш ккакая то ) Основная Форма загрузки адресного класификатора в старом формате не исправлена
Если подвести итоги
Обновиться до 1.3.167.1
Полностью Очистить адресный классификатор КЛАДР
Загрузить ФИАС
Будет работать на SQL? или ждать следующего обновления?
28. user682053_kuplu_dom 13.10.21 12:23 Сейчас в теме
https://bugboard.v8.1c.ru/version/upp1/000026611

Описание:
В документе Начисление по больничному листу при повторном открытии уже введенного адреса очищаются введенные значения

Описание:
При проведении документа Реестр сведений ФСС о пособиях о нетрудоспособности возникает ошибка:
Не удалось разобрать адрес регистрации, возможно указан адрес а пределами РФ!

Описание:
В справочнике Медицинские организации после заполнения адреса не заполняется код КЛАДР

Способ исправления:
Общий модуль УправлениеКонтактнойИнформацией
Функция ПолучитьПолныйАдрес(Запись) Экспорт


Строку:
Если ОпределитьДляОбъектаРоссийскийАдрес(Запись) И ПустаяСтрока(Запись.Значение) Тогда

заменить на строки:
Если (ОпределитьДляОбъектаРоссийскийАдрес(Запись) И ПустаяСтрока(Запись.Значение)
Или (ОпределитьДляОбъектаРоссийскийАдрес(Запись) И Запись.Объект = Неопределено)) Тогда

Обработка РедактированиеКонтактнойИнформации
Форма ФормаЗаписиАдреса

Процедура ПередОткрытием


Перед строкой:
НачальноеЗначениеВыбора.Свойство("Район", Поле3);

добавить строку:
НачальноеЗначениеВыбора.Свойство("Индекс", Поле1);


После строки:
КонтактнаяИнформация.Вставить("Регион", Поле2);

добавить строки:
КонтактнаяИнформация.Вставить("Город", Поле4);
КонтактнаяИнформация.Вставить("Индекс", Поле1);
КонтактнаяИнформация.Вставить("Дом", Поле7);
Оставьте свое сообщение
Вопросы с вознаграждением
Вакансии
Аналитик 1С ERP
Санкт-Петербург
зарплата до 200 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 150 000 руб.
Полный день

Бизнес-аналитик 1С
Москва
зарплата от 100 000 руб.
Полный день

Программист, аналитик, эксперт 1С
Санкт-Петербург
По совместительству

Программист 1С
Москва
зарплата от 150 000 руб. до 200 000 руб.
Полный день