Проблема перехода на Postgre 11

1. Vlad_M_75 31.01.19 12:13 Сейчас в теме
Есть рабочая система 1С Сервер x64 8,3,13,1690 на Windows 2008 + PostgreSQL на CentOS 7.
После обновления Postgre на 11.1 с PostgrePro возник непонятный глюк: из одного из периодических регистров в запросе из виртуальной таблицы СрезПоследних выбирается не последнее значение. На локальной базе все хорошо. Причем ошибка проявляется только при определенных параметрах выборки. Так вот вопрос: куда копать? Тестирование и исправление базы полное делали. Что еще можно попробовать?
По теме из базы знаний
Найденные решения
6. Vlad_M_75 26.02.19 08:56 Сейчас в теме
Проблема решилась оптимизацией запроса. Вместо левых соединений с виртуальными таблицами "СрезПоследних", из них сделали временные таблицы, а уже потом применили левые соединения. (Особенности работы с Postgree). Все стало работать хорошо. Хотя где-то была информация, что начиная с какого-то релиза движка эта фича была поправлена. А вот снова вылезла.
Остальные ответы
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
2. herfis 508 31.01.19 12:22 Сейчас в теме
А разве 1С официально поддерживает 11-ю версию?
3. herfis 508 31.01.19 12:25 Сейчас в теме
Хотя все равно глюк странный. Для этого регистра, случаем, итоги не включены?
4. Vlad_M_75 31.01.19 14:03 Сейчас в теме
5. alxarz 32 02.02.19 08:07 Сейчас в теме
а если, например, удалить то значение которое выбирается сейчас, и повторить запрос?
6. Vlad_M_75 26.02.19 08:56 Сейчас в теме
Проблема решилась оптимизацией запроса. Вместо левых соединений с виртуальными таблицами "СрезПоследних", из них сделали временные таблицы, а уже потом применили левые соединения. (Особенности работы с Postgree). Все стало работать хорошо. Хотя где-то была информация, что начиная с какого-то релиза движка эта фича была поправлена. А вот снова вылезла.
Оставьте свое сообщение

Для получения уведомлений об ответах подключите телеграм бот:
Инфостарт бот