1. eruil 14.12.16 18:14 Сейчас в теме

Предупреждение безопасности при запуске .epf

После обновления платформы на 8.3.9.2016 при запуске любого .epf файла получем предупреждение-вопрос:
Предупреждение безопасности
Открывается "" из файла ... .epf
...
Разрешить открывать данный файл?

И только кнопка Ок, нажимая которую, диалог пропадает и ничего не происходит.

Как отключить "нововведенную заботу" и запускать .epf как и раньше без танцев?
Прикрепленные файлы:
Найденные решения
5. eruil 19.12.16 21:45 Сейчас в теме
Ответ от разработчика (решение):
То, что в вопросе нет кнопок "Да" и "Нет" признали ошибкой платформы, но непонятно когда исправят.
Самый простой способ обойти проблему - в конфигураторе в свойствах пользователя ИБ убрать флажок "Защита от опасных действий".
denis-sqluev; unreg11; Taktic; cheburashka; serge-ce1; egorcheg1; xenica.kmb; kyts; rpgshnik; almerus; KotorVB; kholkin; Tolpinski; zveruganet; Titov222; Knopodav; NN2P; cargobird; MsDjuice; zerg17; Xershi; the1; tenaxxx; A7758735; kukla11; Alexei_fox; ResetAtreides; Sиlьver; mailrum2004; markovki; Greysvandir; Chuves; nick_man; DreamcastMD; Novinsky; HenrySLAV; EmpireSer; Shersman; Unk92; Wildpig; Ryukenden; Shida; anime21; 1v7; Sanya1984; kernelio; mftrash@ya.ru; корум; Kesak; AlexDaewoo; AlexDaewoo; AlexDaewoo; AlexDaewoo; AlexDaewoo; vital1c; mindcannon; +56 Ответить
Остальные ответы
Избранное Подписка Сортировка: Древо
2. Fox-trot 107 14.12.16 21:39 Сейчас в теме
(1)
и ничего не происходит.
видимо обработка "кривая" - нет подходящей формы для открытия, если она вообще там есть
3. olegmedvedev 15.12.16 13:58 Сейчас в теме
(1)судя по скрину вы пытаетесь запустить портабельные "Инструменты разработчика", там есть обработка "...\Модули\ирКэш.epf", но они не запускаются отдельными обработками, а стартуют с главной "ирПортативный.epf".
Остальные обработки (Не из "Инструменты разработчика") у вас нормально запускаются?
4. eruil 19.12.16 21:15 Сейчас в теме
(3) Да, речь идет о "Инструменты разработчика". Запускаю как обычно ирПортативный.epf, и на последних релизах 1С получаем предупреждение безопасности.
Что-то наверное 1С наворотила с безопасностью запуска .epf файлов. Искал в настройках, гуглил - ничего. Не откатываться же на старые релизы 1С из-за этого. Попробуйте кто у себя.
5. eruil 19.12.16 21:45 Сейчас в теме
Ответ от разработчика (решение):
То, что в вопросе нет кнопок "Да" и "Нет" признали ошибкой платформы, но непонятно когда исправят.
Самый простой способ обойти проблему - в конфигураторе в свойствах пользователя ИБ убрать флажок "Защита от опасных действий".
denis-sqluev; unreg11; Taktic; cheburashka; serge-ce1; egorcheg1; xenica.kmb; kyts; rpgshnik; almerus; KotorVB; kholkin; Tolpinski; zveruganet; Titov222; Knopodav; NN2P; cargobird; MsDjuice; zerg17; Xershi; the1; tenaxxx; A7758735; kukla11; Alexei_fox; ResetAtreides; Sиlьver; mailrum2004; markovki; Greysvandir; Chuves; nick_man; DreamcastMD; Novinsky; HenrySLAV; EmpireSer; Shersman; Unk92; Wildpig; Ryukenden; Shida; anime21; 1v7; Sanya1984; kernelio; mftrash@ya.ru; корум; Kesak; AlexDaewoo; AlexDaewoo; AlexDaewoo; AlexDaewoo; AlexDaewoo; vital1c; mindcannon; +56 Ответить
6. vital1c 95 22.12.16 10:44 Сейчас в теме
Внешние печатные формы тоже выдают такое сообщение
7. AlexDaewoo 1 22.12.16 15:06 Сейчас в теме
такое же происходит при запуске базы на последней платформе, жесть какая то
8. tormozit 5621 26.12.16 09:45 Сейчас в теме
Решение проблемы описано здесь
pavlo; Titov222; MsDjuice; Enyel; the1; METAL; Жолтокнижниг; Misanets; +8 Ответить
9. smilohov 5 12.01.17 18:18 Сейчас в теме
Благодарю, оперативно нашел!!!
10. CratosX 106 08.02.17 14:52 Сейчас в теме
11. deutsch2008 141 10.02.17 11:11 Сейчас в теме
Самый простой способ обойти проблему - в конфигураторе в свойствах пользователя ИБ убрать флажок "Защита от опасных действий".
Вот ссылка ка это можно сделать https://infostart.ru/public/577219/
Denis Nsk; pavlo; Dmitry_001; AntonH851; +4 Ответить
12. AlexxSys 182 14.02.17 16:22 Сейчас в теме
(11)
в свойствах пользователя ИБ

А что делать если нет пользователя ? Т.е. для регламентных заданий, они создаются без пользователя, но из за этой проверки не выполняются, и подтвердить никак нельзя, оно ж фоновое, и без пользователя выполняется.
13. AlexxSys 182 14.02.17 16:46 Сейчас в теме
(12)
Нашел:
4. Воспользоваться параметром DisableUnsafeActionProtection файла conf.cfg (более подробно см. здесь). В этом случае механизм защиты от опасных действий будет отключаться для всех пользователей информационных баз, строки соединения которых удовлетворяют указанным маскам.
DisableUnsafeActionProtection=test_.*;stage_.*;
14. pap 15.02.17 09:00 Сейчас в теме
Спасибо. (11) .
Помогло. Замучило это предупреждение.
15. Nathalie.E 01.03.17 10:16 Сейчас в теме
Можно еще галочку снять в конфигураторе
Прикрепленные файлы:
Denis Nsk; MsDjuice; COMPER; Alexei_fox; +4 Ответить
16. tank68 17 11.04.17 17:12 Сейчас в теме
Для массового изменения


Процедура КнопкаВыполнитьНажатие(Кнопка)

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| Пользователи.Ссылка,
| Пользователи.ИдентификаторПользователяИБ
|ИЗ
| Справочник.Пользователи КАК Пользователи";

РезультатЗапроса = Запрос.Выполнить();

Выборка = РезультатЗапроса.Выбрать();

#Если Клиент Тогда
Процессор = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВКоллекциюЗначений;
Процессор.ОтображатьПроцентВывода = Истина;
Процессор.НачатьВывод();
Элемент = Новый ЭлементРезультатаКомпоновкиДанных;
#КонецЕсли

Колво = Выборка.Количество();
НомерПП = 0;


Пока Выборка.Следующий() Цикл

НомерПП = НомерПП+1;
#Если Клиент Тогда
Состояние(""+ТекущаяДата()+" Обрабатывается "+ НомерПП+" из "+Колво);
Элемент.ПроцентВывода = НомерПП/Колво*100;
Процессор.ВывестиЭлемент(Элемент);
#КонецЕсли

Попытка

Пользователь1с = ПользователиИнформационнойБазы.НайтиПоУникальномуИдентификатору(Выборка.ИдентификаторПользователяИБ);
Пользователь1с.ЗащитаОтОпасныхДействий.ПредупреждатьОбОпасныхДействиях = Ложь;
Пользователь1с.Записать();

Исключение

Сообщить(""+ТекущаяДата()+" "+ОписаниеОшибки());

КонецПопытки;

КонецЦикла;

#Если Клиент Тогда
Процессор.ЗакончитьВывод();
#КонецЕсли

КонецПроцедуры
17. cargobird 289 02.06.17 15:04 Сейчас в теме
(16) Чего-то запрос не нашел поле ИдентификаторПользователяИБ.
Сделал так.
НомерПП = 0;
	Попытка
		ВсеПользователиИнформационнойБазы = ПользователиИнформационнойБазы.ПолучитьПользователей();
		Для каждого Пользователь1с Из ВсеПользователиИнформационнойБазы Цикл
			НомерПП = НомерПП+1;
			Пользователь1с.ЗащитаОтОпасныхДействий.ПредупреждатьОбОпасныхДействиях = Ложь;
			Пользователь1с.Записать();
		КонецЦикла;
	Исключение
		Сообщить(""+ТекущаяДата()+" "+ОписаниеОшибки());
	КонецПопытки;			
	Сообщить("Изменено пользователей " + НомерПП);
Показать
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Ведущий программист 1С
Омск
зарплата от 70 000 руб. до 110 000 руб.
Полный день

Программист 1С
Екатеринбург
зарплата до 120 000 руб.
Полный день

Консультант-аналитик 1С
Рязань
зарплата до 80 000 руб.
Полный день

Программист 1С
Калининград
зарплата от 60 000 руб. до 80 000 руб.
Полный день

Программист 1С
Рязань
зарплата от 90 000 руб.
Полный день