Счет-фактура с 01.07.2021 для "Торговля + склад" редакции 9.2

0. 61 11.06.21 17:49 Сейчас в теме
Внешние печатные формы счета-фактуры и УПД по Постановлению Правительства РФ от 02.04.2021 № 534 для конфигурации "Торговля + склад" редакция 9.2

Перейти к публикации

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Serve-it 16.06.21 08:39 Сейчас в теме
Добрый день. В УПД нет никаких изменений. Будут ли?
А вот в счет-фактуре всё работает, спасибо.
2. aleksandr_leiman 61 16.06.21 09:03 Сейчас в теме
УПД по новой форме печатается только из документа "Счет-фактура выданный", "Реализация" с датой более 01.07.2021.
3. Serve-it 16.06.21 12:21 Сейчас в теме
4. alexstav 5 17.06.21 10:45 Сейчас в теме
А колонки 12, 12а, и 13 не должны быть на форме, пусть даже пустые?
5. aleksandr_leiman 61 17.06.21 12:02 Сейчас в теме
(4)Для непрослеживаемого товара не выводятся на печать колонки 12-13
https://buh.ru/forum/forum18376/topic95469/
6. jackyz 23.06.21 16:46 Сейчас в теме
не работает
ошибка
БратьСуммыИзУчета = глБратьСуммыИзУчета<<?>>(Докум.ДатаДок);
{D:\1CBASES\ТОРГОВЛЯБУХЭНИКС\EXTFORMS\PRNFORMS\GSF1137.ERT(395)}: Функция не обнаружена (глБратьСуммыИзУчета)
8. cargobird 303 25.06.21 10:28 Сейчас в теме
(6) То же. Старая конфигурация.
Пришлось немного подпилить, - убрать несуществующие функции и обращения к несуществующим реквизитам.
7. aleksandr_leiman 61 23.06.21 17:38 Сейчас в теме
Какая версия вашей конфигурации? Я проверял на релизах 7.70.1000 - 7.70.1003
9. user1448301 28.06.21 13:09 Сейчас в теме
(7) Добрый день!
Подключили УПД Счет-фактуре и в Реализации, форма не изменилась. Версия 7.70.999.
Скриншот прилагаю.
Печатная форма счет-фактуры работает.
Прикрепленные файлы:
10. aleksandr_leiman 61 28.06.21 19:39 Сейчас в теме
УПД новой формы печатается для документов с датой 01.07.2021 и позднее
user1448301; +1 Ответить
11. kazann 22 30.06.21 10:36 Сейчас в теме
Работает. Визуально поправьте в УПД рамки измененных колонок и вывод в "Код товара" - артикула
12. aleksandr_leiman 61 30.06.21 12:34 Сейчас в теме
В типовой обработке УПД из поставки ТиС 7.7 Код товара не заполняется, я так и оставил.
При желании откройте в конфигураторе файл внешней формы и в модуле заменить
	ТоварКод = ""; 

на
	ТоварКод =  СокрЛП(МнЧ.Номенклатура.Артикул);; 


Рамки в таблице поправлю.
ivdvorkovoy; +1 Ответить
13. hard666 30.06.21 17:44 Сейчас в теме
1с 7.7 Торговля + Склад редакция 9.2 7.70.923

Внешняя форма

БратьСуммыИзУчета = глБратьСуммыИзУчета<<?>>(Докум.ДатаДок, Докум.ДокОснование.КодОперации);
{\\192.168.0.123\BASE\BASE\NEW_SKLAD_KM_DB\EXTFORMS\PRNFORMS\GSF1137.ERT(393)}: Функция не обнаружена (глБратьСуммыИзУчета)
БратьСуммыИзУчета = глБратьСуммыИзУчета<<?>>(Докум.ДатаДок);
{\\192.168.0.123\BASE\BASE\NEW_SKLAD_KM_DB\EXTFORMS\PRNFORMS\GSF1137.ERT(395)}: Функция не обнаружена (глБратьСуммыИзУчета)

Поправил:
Всё на что ругалось, вынес за слэши (//)
Вышла ещё ошибка, так же поправил.
ВОт инструкция
https://infostart.ru/public/106058/
ivdvorkovoy; aleksandr_leiman; +2 Ответить
14. aleksandr_leiman 61 30.06.21 19:38 Сейчас в теме
(13)Спасибо за ссылку, действительно проверял только на последних релизах, поскольку за основу брал внешнюю обработку из комплекта поставки 7.70.1000
15. a.schelkonogova@yandex.ru 01.07.21 14:29 Сейчас в теме
Добрый день , скажите на релизе 7.70.993 будет работать эта форма ?
16. aleksandr_leiman 61 01.07.21 16:41 Сейчас в теме
(15)Да, будет проверил начиная с 7.70.971
17. user1076592 02.07.21 04:08 Сейчас в теме
Добрый день, проверил, обнаружилось, что форма УПД не разбивает на отдельные строки товары проходящие (списываемые по партиям) по разным ГТД. А так не должно быть... Если, к примеру списание товарной позиции проходит по трем ГТД, должна быть основная строка, а затем три подстроки, где в каждой указывается кол-во и номер конкретной ГТД.
18. aleksandr_leiman 61 02.07.21 07:05 Сейчас в теме
(17)Механизм формирования печатных форм полностью взят из типовой конфигурации ТиС 9.2, я только добавил таблицу нового формата и дописал заполнение графы 5а. Специально учет по ГТД не проверял, нет таких данных. Вышла типовая конфигурация 7.70.1004, в ней есть новая внешняя форма УПД. Проверьте правильность формирования в ней.
19. user1076592 02.07.21 17:07 Сейчас в теме
Добрый день, спасибо за ответ. Я уточнил у коллеги, реализованный вариант вывода по ГТД устраивает. Форма при наличии позиций проходящим по разным ГТД просто их выводит разными строками, без подстрок, как у нас реализовано в другой базе, так что с этим ок.

Другой момент - в графе 5а должна быть ссылка на номер Реализации (накладной), а у Вас сейчас она ссылается на номер Счета-Фактуры. Можно исправить?
20. user1076592 02.07.21 17:10 Сейчас в теме
Вот как в разъяснениях написано насчет "5а"
" ...

https://www.klerk.ru/blogs/moedelo/515845/


добавили строку 5а для номера и даты документа об отгрузке товаров (выполнении работ, оказании услуг) — товарной накладной, акта приёма-передачи и др. Их вписывают под тем же порядковым номером, что и в строках счёта-фактуры. Например, в счёте-фактуре указано три позиции товаров. Их отгрузили по накладной № 105 от 05.07.2021. В строке 5а нужно написать: «Документ об отгрузке № п/п 1-3 № 105 от 05.07.2021». Если документов несколько, реквизиты разделяют точкой с запятой. Если счёт-фактуру заменяет УПД со статусом 1, в строке 5а нужно повторить реквизиты этого УПД.

.."
21. user1076592 02.07.21 17:10 Сейчас в теме
Вот как в разъяснениях написано:


"...добавили строку 5а для номера и даты документа об отгрузке товаров (выполнении работ, оказании услуг) — товарной накладной, акта приёма-передачи и др. Их вписывают под тем же порядковым номером, что и в строках счёта-фактуры. Например, в счёте-фактуре указано три позиции товаров. Их отгрузили по накладной № 105 от 05.07.2021. В строке 5а нужно написать: «Документ об отгрузке № п/п 1-3 № 105 от 05.07.2021». Если документов несколько, реквизиты разделяют точкой с запятой. Если счёт-фактуру заменяет УПД со статусом 1, в строке 5а нужно повторить реквизиты этого УПД."
22. user1076592 03.07.21 01:15 Сейчас в теме
Бухгалтер потратил целый день, пришли к тому откуда начинали ), все-таки в 5а должен быть номер накладной.
23. user1076592 03.07.21 01:34 Сейчас в теме
Так что в целом ок, единственное что странно, на некоторых документах, в отдельных строках по графе 8 (сумма налога) округления не ограничиваются 2 знаками после запятой, а идут в периоде (фрагмент скрина прилагаю).
24. user1076592 03.07.21 01:36 Сейчас в теме
Что бы это могло быть, ведь другие строки выводятся в нормальном формате (с 2 знаками)?
Прикрепленные файлы:
25. aleksandr_leiman 61 03.07.21 07:11 Сейчас в теме
(24)Графа 5а так и есть для счета-фактуры указывается номер документа отгрузки, для УПД - дублируется номер УПД. Пока нет от ФНС других указаний, оставляю так. Дробные суммы НДС у меня не воспроизводятся, предполагаю, что такое может произойти при распределении сумм между ГТД. В приведенном фрагменте графа 11 не видна.
26. mehkkt 13.07.21 11:52 Сейчас в теме
на ТиС 7.70.944 будет работать?
27. aleksandr_leiman 61 13.07.21 13:30 Сейчас в теме
(26)Требует доработки, как написано в сообщении (13)
28. Cobalt River 02.08.21 18:17 Сейчас в теме
Если товар надо разбить по ГТД ошибки.

Например.

1-й товар 4 шт по одной ГТД №1
2-й товар 5 шт по двум ГТД (2 шт по одной ГТД №2 и 3 штуки по другой ГТД №3)

Печатает

1 строка: первый товар 4 шт и правилное ГТД №1
2 строка: второй товар 2 шт и правильная ГТД №2
3 строка: первый(!) товар 4(!) штуки и правильная ГТД №3

Если первый товар удалить, распределяет правильно.

Заменил в функции ПодготовитьМнчОсн

//РаспредГТД.ВыбратьСтроки();
				//Пока РаспредГТД.ПолучитьСтроку() = 1 Цикл
				//	
				//	ТекСумма	  = МнЧ.Сумма;
				//	ТекСуммаНДС	  = МнЧ.СуммаНДС;
				//	ТекВсегоСНДС  = МнЧ.ВсегоСНДС;
				//	ТекКоличество = МнЧ.Количество;
				//	Если ТекКоличество > 0 Тогда 
				//		ТекКоэф = РаспредГТД.Колво/ТекКоличество;
				//	Иначе
				//		ТекКоэф = 1;
				//	КонецЕсли;
				//	
				//	Если НЕ(РаспредГТД.НомерСтроки = 1) Тогда
				//
				//		МнЧ.НоваяСтрока();
				//		МнЧ.Номенклатура = МнЧ.ПолучитьЗначение(1,"Номенклатура");
				//		МнЧ.Цена		 = МнЧ.ПолучитьЗначение(1,"Цена");
				//		МнЧ.СтавкаНДС	 = МнЧ.ПолучитьЗначение(1,"СтавкаНДС");
				//		МнЧ.Единица      = МнЧ.ПолучитьЗначение(1,"Единица");
				//		МнЧ.ЕдиницаКод   = МнЧ.ПолучитьЗначение(1,"ЕдиницаКод");
				//		МнЧ.АкцизЦена	 = МнЧ.ПолучитьЗначение(1,"АкцизЦена");			        			
				//	КонецЕсли;  
				//	
				//	МнЧ.Сумма		 = ТекСумма * ТекКоэф;
				//	МнЧ.СуммаНДС	 = ТекСуммаНДС * ТекКоэф;
				//	МнЧ.СуммаНП		 = КороткийПрочерк;
				//	МнЧ.ВсегоСНДС	 = ТекВсегоСНДС * ТекКоэф;
				//	МнЧ.Количество  = РаспредГТД.Колво;
				//
				//    МнЧ.НомерГТД    = РаспредГТД.Номер;
				//	МнЧ.СтранаН     = РаспредГТД.Страна;
				//	
				//	Если ТипЗначенияСтр(РаспредГТД.Страна) = "Справочник" Тогда
				//		МнЧ.СтранаК     = РаспредГТД.Страна.Код;
				//	Иначе
				//		МнЧ.СтранаК = "";	
				//	КонецЕсли;
				//						
				//	Если (МнЧ.Количество - Цел(МнЧ.Количество)) > 0 Тогда
				//	    ФорматКоличества = "Ч14.3";
				//	КонецЕсли;
				//	
				//КонецЦикла;
Показать


на:
РаспредГТД.ВыбратьСтроки();
				Пока РаспредГТД.ПолучитьСтроку() = 1 Цикл
					
					МнЧ.НоваяСтрока();
					МнЧ.Номенклатура = "     в т.ч.";
					МнЧ.Цена		 = 0;
					МнЧ.Сумма		 = 0;
					МнЧ.СтавкаНДС	 = КороткийПрочерк;
					МнЧ.СуммаНДС	 = КороткийПрочерк;
					МнЧ.СуммаНП		 = КороткийПрочерк;
					МнЧ.ВсегоСНДС	 = 0;
					
					МнЧ.Единица     = ТекЕдиница;
					МнЧ.ЕдиницаКод  = ТекЕдиницаКод;
					МнЧ.Количество  = РаспредГТД.Колво;
					МнЧ.НомерГТД    = РаспредГТД.Номер;
					МнЧ.СтранаН     = РаспредГТД.Страна;
					МнЧ.СтранаК     = ?(ТипЗначенияСтр(РаспредГТД.Страна)="Справочник",РаспредГТД.Страна.Код,""); 
					
					Если (МнЧ.Количество - Цел(МнЧ.Количество)) > 0 Тогда
					    ФорматКоличества = "Ч10.3";
					КонецЕсли;
					
				КонецЦикла;
Показать
29. aleksandr_leiman 61 02.08.21 18:53 Сейчас в теме
Спасибо за проверку. В моих базах ГТД не применяется, проверить не смог.
30. Automatik 756 25.08.21 07:51 Сейчас в теме
Укажите в описании, для какого документа
31. aleksandr_leiman 61 25.08.21 08:38 Сейчас в теме
(30)Спасибо, добавил в описании применяется для документа счет-фактура выданный.
Оставьте свое сообщение
Вопросы с вознаграждением
Вакансии
Программист 1С
Москва
зарплата от 150 000 руб.
Полный день

Программист 1С
Новосибирск
зарплата от 100 000 руб.
Полный день

Программист 1С: ЗУП
Чита
зарплата от 110 000 руб. до 150 000 руб.
Полный день

Разработчик 1C: ERP (Блоки: Снабжение, закупки, склад; Финансы и казначейство)
Чита
зарплата от 110 000 руб. до 150 000 руб.
Полный день

Консультант 1С
Нижний Новгород
зарплата от 55 000 руб. до 100 000 руб.
Полный день