1. Antimyslitel 2 11.09.16 17:05 Сейчас в теме

Настройка списка документов

Добрый день,
Есть проблема, Конфигурация УТ10.3
С форме списка документа Приходный кассовый ордер и в форме списка документа Расходный кассовый ордер добавил колонку для удобства статья движения денежных средств. Но ни в том ни в другом документах точнее формах документов не отображается сама статья, тоесть в самом документе я выбираю статью он нормально сохраняет но в форме списка документа не отображает статью! Прошу помочь!

И еще одна проблема:
В документе заказ покупателя добавил реквизит оплата дизайнеру хочу что бы в форме списка документа по статусу если оплачено закрашивалось синим цветом если статус не оплачено то красным!

Заранее благодарен за помощь!
Ответы
Избранное Подписка Сортировка: Древо
3. x_under 12 12.09.16 11:45 Сейчас в теме
(1) Antimyslitel, статья движения - реквизит табличной части. Поэтому и не выводится. Только программно если будете заполнять
4. olgerd666 42 12.09.16 12:16 Сейчас в теме
(1) Antimyslitel, А добавляли как - через колонки-добавить, или через размещение колонок на поле формы.
(3) x_under, СтатьяДвиженияДенежныхСредств такой реквизит есть и не только в ТЧ
2. spe1c 11.09.16 17:42 Сейчас в теме
Добрый день, раскрашивать строки можно через событие ПриВыводеСтроки
Процедура СправочникСписокПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
    Красный = Новый Цвет( 255, 0, 0 );
    Если ДанныеСтроки.Код > 1 Тогда
        ОформлениеСтроки.ЦветФона = Красный;
    КонецЕсли; 
КонецПроцедуры

Показать

Что касается невывода значения в колонке - скорее всего не связали колонку с данными объекта.
5. AnnaKalacheva 6 12.09.16 12:50 Сейчас в теме
Я закрашивала в событии ПриПолученииДанных()

Процедура ДоговораПриПолученииДанных(Элемент, ОформленияСтрок)
	ЦветКрасный = Новый Цвет(225, 166, 173);
	 Для каждого Строка Из ОформленияСтрок Цикл
	   ДанныеСтроки = Строка.Данныестроки;
			Если (НачалоДня((ТекущаяДата()+60*60*60*24))>ДанныеСтроки.ДатаРасторжения) Тогда
		    	Строка.ЦветФона = ЦветКрасный; 	
			КонецЕсли;
			Если (НачалоДня(ТекущаяДата())>ДанныеСтроки.ДатаРасторжения) Тогда
		    	Строка.ЦветФона = WebЦвета.Серый; 	
			КонецЕсли;

	КонецЦикла;
КонецПроцедуры
Показать
6. olgerd666 42 12.09.16 12:54 Сейчас в теме
ПриПолученииДанных() и ПриВыводеСтроки() - выбор зависит от целей автора.
При выводе строки будет перекрашивать весь список при любом изменении (трудоемко, если больше 1000ххх позиций)
При получении данных только на кнопку обновить (неудобно для отслеживания в реальном времени)

Осталось с колонкой разобраться)
8. AnnaKalacheva 6 12.09.16 12:59 Сейчас в теме
10. AnnaKalacheva 6 12.09.16 13:03 Сейчас в теме
(6) olgerd666, хотя надо подумать... У меня при нету никакой кнопки, все красит...
11. olgerd666 42 12.09.16 13:05 Сейчас в теме
(10) AnnaKalacheva, Закрашивает ПриОткрытииСписка, а если изменить текущую запись - не закрывая список, то закраска отработает только при повторном получении
13. AnnaKalacheva 6 12.09.16 13:07 Сейчас в теме
(11) olgerd666, да, так и есть... спасибо, что развеяли сомнения!
19. bmk74 81 14.09.16 14:11 Сейчас в теме
(11) olgerd666, Любая прокрутка списка вызывает приполученииданных не только при открытии
7. AnnaKalacheva 6 12.09.16 12:58 Сейчас в теме
Заполнить колонку формы списка программно.
Модуль формы списка. (Накладные - табличная часть документа)
Процедура ДокументСписокПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
	
	
	Счета="";

	Для каждого	Стр из ДанныеСтроки.Ссылка.Накладные Цикл
		 Счета=Счета+Формат(Число(Стр.Реализация.Сделка.Ссылка.Номер),"ЧГ=")+", " ;  
	КонецЦикла;
	
	ОформлениеСтроки.Ячейки.ЗаказПокупателя.Значение = Счета;
		
 КонецПроцедуры
Показать
9. olgerd666 42 12.09.16 13:01 Сейчас в теме
(7) AnnaKalacheva, Но СтатьяДвиженияДенежныхСредств есть не только в ТЧ, есть такой реквизит объекта. и при добавлении в список -он должен отображаться, без программного заполнения
12. AnnaKalacheva 6 12.09.16 13:06 Сейчас в теме
(9) olgerd666, возможно, я работаю с УПП... Просто как вариант....
Если есть реквизит объекта, скорее всего в свойствах колонки, поле "Данные" не заполнено..
14. Antimyslitel 2 14.09.16 12:51 Сейчас в теме
Добрый день всем снова!
Ребята отправляю Вам фото того как я бы хотел это получить!
У меня в документе Заказ покупателя добавлены новые реквизиты такие как Оплата Дизайнеру и Оплата Бригаде
Эти реквизиты я вывел в форму списка документа через Форма---Размещение данных и оттуда выбрал нужные мне реквизиты поставил галочку на вставить надписи и разместил!
Теперь мне нужно по статусу когда к примеру в документе было поставлено значение Оплачено мне нужно что бы закрашивался в светло синий цвет если стоит статус не оплачено тогда в красный цвет как мне это осуществить!
15. Antimyslitel 2 14.09.16 12:56 Сейчас в теме
Что касается ПКО и РКО
То я выбираю статью движения денежных средств в форме документа но хочу что бы она также отображалась в форме списка документа

Через Форма---Размещение данных --- тут выбрал в форму вставил и поставил галочку вставить надписи на форму все село!
Но когда в режиме предприятия открываю список то мне не отображает значение которое выбрано в форме документа!
Помогите плзз!
16. Antimyslitel 2 14.09.16 13:08 Сейчас в теме
И еще чуть не забыл! Мне при закрашивании надо что бы не всю строку целиком закрашивал а именно ту ячейку в которой стоит значение!
17. Antimyslitel 2 14.09.16 13:52 Сейчас в теме
Всем спасибо проблему с закраской решил сам самостоятельно!
18. Antimyslitel 2 14.09.16 13:53 Сейчас в теме
Осталось только решить проблему с отображением статьи движения ДС в форме списка документа!
20. bmk74 81 14.09.16 14:19 Сейчас в теме
(18) Antimyslitel, могу предположить что статья все таки в ТЧ прописана, так как и РКО И ПКО статью могут содержать как в документе так и в ТЧ, а вот на форме документа она ТЧ может быть не показана а просто ее колонки выводяться как реквизиты...там по идее кнопочка должна быть типа показать список или что то там еще, запросом посмотрите заполнен ли реквизит данный у объекта или он всетак в ТЧ
21. Antimyslitel 2 14.09.16 16:29 Сейчас в теме
22. bmk74 81 14.09.16 16:46 Сейчас в теме
(21) Antimyslitel, А кому счас легко, :) выяснили где статья расходовдоходов у вас находиться ?
24. Antimyslitel 2 15.09.16 13:15 Сейчас в теме
(22) bmk74,
Каким только макаром не пробывал все в ноль!
Уже нервов не хватает!
Помоги плззз.
Мне надо значение статьи движения денежных средств из табличной части документа приходный кассовый ордер, вытащить и вставить в форму списка документа!
Заранее благодарен!
25. vadim1011985 56 15.09.16 13:24 Сейчас в теме
(24) Antimyslitel, может в событии ПередЗаписью Документов ПКО и РКО ( или добавить подписку на событие ПриЗаписи или др. вариант) заполнять реквизит Статья ДДС из первой строки ТЧ ?

что-то типа такого -

СтатьяДвиженияДенежныхСредств = РасшифровкаПлатежа[0].СтатьяДвиженияДенежныхСредств
23. Antimyslitel 2 15.09.16 09:34 Сейчас в теме
Да находится в ТЧ! Вот как мне ее вытащить в форме списка документа?
26. Antimyslitel 2 15.09.16 13:46 Сейчас в теме
Эврика методом тыка вспоминая прошлое нахимичил ну вроде как правильно и получилось!
Процедура СписокПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
	
	
	Если ДанныеСтроки <> Неопределено Тогда
		СтатьяДвижения = ДанныеСтроки.Ссылка.РасшифровкаПлатежа[0].СтатьяДвиженияДенежныхСредств; 
		Колонка = ОформлениеСтроки.Ячейки; 
		Колонка.СтатьяДвиженияДенежныхСредств.УстановитьТекст(СтатьяДвижения); 

	КонецЕсли;
	
		СтатьяДвижения = ""; 
		
		Для каждого СтрокаТЧ Из ДанныеСтроки.Ссылка.РасшифровкаПлатежа 
			
	Цикл
		СтатьяДвижения =  СтатьяДвижения + СтрокаТЧ.СтатьяДвиженияДенежныхСредств; 
		
	КонецЦикла;
 
    
	
КонецПроцедуры
Показать



Пример кода для тех кто мучается!
27. Antimyslitel 2 15.09.16 13:47 Сейчас в теме
Процедура СписокПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
	
	
	Если ДанныеСтроки <> Неопределено Тогда
		СтатьяДвижения = ДанныеСтроки.Ссылка.РасшифровкаПлатежа[0].СтатьяДвиженияДенежныхСредств; 
		Колонка = ОформлениеСтроки.Ячейки; 
		Колонка.СтатьяДвиженияДенежныхСредств.УстановитьТекст(СтатьяДвижения); 

	КонецЕсли;
	
		СтатьяДвижения = ""; 
		
		Для каждого СтрокаТЧ Из ДанныеСтроки.Ссылка.РасшифровкаПлатежа 
			
	Цикл
		СтатьяДвижения =  СтатьяДвижения + СтрокаТЧ.СтатьяДвиженияДенежныхСредств; 
		
	КонецЦикла;
 
    
	
КонецПроцедуры
Показать
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Санкт-Петербург
зарплата от 100 000 руб.
Полный день

Руководитель группы сервисов ЭДО, ЭЦП и криптографии
Москва
зарплата от 150 000 руб.
Полный день

Руководитель группы интеграций (1С)
Москва
зарплата от 150 000 руб.
Полный день

Руководитель группы сервисов FRM на 1С
Москва
зарплата от 150 000 руб.
Полный день

Консультант-аналитик 1С (ЗУП)
Санкт-Петербург
Полный день