Публикация базы на веб-сервере, confPath: command not found

1. __guest__ 02.12.22 14:00 Сейчас в теме
Доброе время суток. Utuntu 20.04. Сервер 1С 8.3.19.1399 64 bit, Apache 2.4 . Базу публикую командой:
sudo ./webinst -publish -apache24 -wsdir test_base_1_psql -dir /var/www/test_base_1_psql -connstr “Srvr=localhost;Ref=test_base_1_psql” -confpath /etc/apache2/apache2.conf

Выходит сообщение "Публикация выполнена", а ниже

-confpath: command not found
Не могу понять в чем проблема. В справке к webinst написана команда где "P" большая, но такая же проблема. Пробовал разные варианты написания -confpath, проблему не решает.
Кто сталкивался с этим ?
Ответы
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
2. mnitsi 14 23.08.23 08:00 Сейчас в теме
(1)Добрый день, решился у Вас как то вопрос? Поделитесь решением, пожалуйста
3. mnitsi 14 23.08.23 09:34 Сейчас в теме
(2)Отвечаю сам себе, для Apache версии 24 параметр confpath указывать не нужно, написано в ИТС, единственное уточнение для того кто возможно будет читать данную ветку, почему то после выполнения команды:
./webinst -publish -apache24 -wsdir ut -dir /var/www/ut -connstr “Srvr=srv-data;Ref=psd”
файл default.vrd сформировался с ошибками, пришлось в ручную изменять строку подключения

Может кому пригодится, вот исправленный рабочий вариант:

<?xml version="1.0" encoding="UTF-8"?>
<point xmlns="http://v8.1c.ru/8.2/virtual-resource-system"
xmlns:xs="http://www.w3.org/2001/XMLSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
base="/ut"
ib="Srvr=srv-data; Ref=psd">
<ws pointEnableCommon="true"/>
<standardOdata enable="false"
reuseSessions="autouse"
sessionMaxAge="20"
poolSize="10"
poolTimeout="5"/>
<analytics enable="true"/>
</point>
4. karewka_2 16.10.23 14:59 Сейчас в теме
5. starik-2005 3051 16.10.23 16:18 Сейчас в теме
Ща ж в линухах можно прям с конфигуратора публиковать.
Оставьте свое сообщение

Для получения уведомлений об ответах подключите телеграм бот:
Инфостарт бот