1. HAMMER_59 76 12.02.19 09:42 Сейчас в теме

Реализация товаров, выбрать адрес доставки из грузополучателя

Ситуацию следующая:
- Включена функциональная опция "Управление доставкой", для возможности указания различных адресов доставки в реализациях.
- Есть контрагенты, со множеством грузополучателей, у каждого грузополучателя свой адрес доставки.
При редактировании реализации адрес доставки заполняется по умолчанию из клиента, подставить адрес доставки из грузополучателя мне не удалось.
Ответы
Избранное Подписка Сортировка: Древо
2. lefthander 12.02.19 09:48 Сейчас в теме
(1)В РТУ есть клиент(Партнер) и есть контрагент. По умолчанию берется адрес Клиента(Партнера) В процедурах заполнения перехватите заполнения адреса и возьмите его от контрагента (спр контрагенты)
Или код в студию где идет заполнение адреса доставки.
3. HAMMER_59 76 12.02.19 10:06 Сейчас в теме
(2) Раздельно партнеров и контрагентов не ведем. Т.е. в документах подставляется только партнер.

Отключил функциональную опцию "Управление доставкой" адрес доставки переехал в форму "Реквизиты печати ТОРГ12", но список адресов не изменился, все еще подбирает адреса партнера.
Мне, кажется, ситуация типичная с адресом доставки из грузополучателя, т.е. многие так работают, неужели у всех такая проблема?
4. DNN13 12.02.19 10:34 Сейчас в теме
6. Aspiring_specialist 1 12.02.19 11:54 Сейчас в теме
(1)
можно для клиента добавить несколько адресов получателей. Заходим Виды контактной информации(через поиск наберите). Потом к примеру выбираем партнера, выбираем адрес и ставим галку разрешить ввод нескольких значений. Потом в самом партнере заносим адреса. И все проверяем создаем РТУ
HAMMER_59; +1 Ответить
7. HAMMER_59 76 12.02.19 13:30 Сейчас в теме
(6) Какая хорошая галочка "ввод нескольких значений"
9. Aspiring_specialist 1 12.02.19 13:33 Сейчас в теме
5. d.batovskiy 12.02.19 11:19 Сейчас в теме
А грузополучателя вы заполняете?
8. HAMMER_59 76 12.02.19 13:31 Сейчас в теме
(5) Да, заполняю грузополучателя, и надеюсь увидеть не только адреса клиента, но и грузополучателя. Идеально если бы при выборе грузополучателя подставлялся его почтовый адрес.
10. HAMMER_59 76 13.02.19 13:37 Сейчас в теме
Не понимаю как у других работает, залез в конфигуратор в модуле общей формы "РеквизитыПечатиРеализации" в процедуре ПриСозданииНаСервере вижу следующее:

    ПродажиСервер.ЗаполнитьСписокВыбораАдреса(Элементы.АдресДоставки, Партнер);


Других мест где бы заполнялся СписокВыбора для элемента формы АдресДоставки я не могу найти. Добавил в расширение следующий код

&НаСервере
Процедура ОбновитьСписокАдресовДоставки()
	Если ЗначениеЗаполнено(Грузополучатель) Тогда
		ПродажиСервер.ЗаполнитьСписокВыбораАдреса(Элементы.АдресДоставки, Грузополучатель, Истина, Дата);
		ПродажиСервер.ЗаполнитьСписокВыбораАдреса(Элементы.АдресДоставки, Партнер, Ложь, Дата);		
	Иначе
		ПродажиСервер.ЗаполнитьСписокВыбораАдреса(Элементы.АдресДоставки, Партнер, Истина, Дата);
	КонецЕсли;
	
	Если Элементы.АдресДоставки.СписокВыбора.Количество() > 0 Тогда
		Если ПустаяСтрока(АдресДоставки) Тогда
			АдресДоставки = Элементы.АдресДоставки.СписокВыбора.Получить(0).Значение;
		КонецЕсли;		
	КонецЕсли;
	
КонецПроцедуры


&НаКлиенте
Процедура Расш_ГрузополучательПриИзмененииПосле(Элемент)
	//Вставить содержимое обработчика
	ОбновитьСписокАдресовДоставки();	
КонецПроцедуры
Показать
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Санкт-Петербург
зарплата от 135 000 руб. до 135 000 руб.
Полный день

Программист 1С
Норильск
зарплата от 50 000 руб. до 80 000 руб.
Полный день

Специалист техподдержки 1С
Иркутск
зарплата от 28 000 руб. до 34 000 руб.
Полный день

Программист 1С
Санкт-Петербург
зарплата от 48 000 руб. до 96 000 руб.
По совместительству

Программист 1С
Ставрополь
зарплата от 40 000 руб. до 60 000 руб.
Полный день