Мироненко Андрей | Директор по развитию | Внедренческий Центр "Раздолье"

«Куда и как расти?»

В рамках своего выступления, я хотел бы рассказать о следующем: 1. Как выглядит сейчас рынок труда с точки зрения работодателя - каких специалистов много, кого не хватает. 2. Какие профессиональные навыки наиболее востребованы. 3. Как получить желаемую работу, как обойтись без опыта - директорами не рождаются. 4. Личный опыт построения карьеры. 5. Парадоксы карьеры.

Интеграция ERP 2.0 с 1С Документооборот

1. Sergey-Chelny 27.01.15 13:31 Сейчас в теме
День добрый.
Поставлена задаче на предприятии производить согласование созданных в ERP документов в 1С Документооборот КОРП (все работы проводятся пока что на демонстрационных базах).

Установлено : ERP - 2.0.6.18
Документооборот - 2.0.1.14
Платформа 1С - 8.3.5.1385

На данный момент пытаюсь согласовать документ "Заявка на расходование денежных средств". Создал правило интеграции с 1С Документооборот "Заявка на расходование денежных средств". В нем, на закладке "Получение из 1С Документооборота", в строке "Статус" указал правило заполнения "Состояние согласования".
Теперь создаю в ERP заявку на расходование ДС. Далее "Создать на основании" - "Документооборот: Процесс ...". В 1с Документооборот создается задача. Она согласовывается нужными людьми, далее автор задачи ознакомился с результатом, но результат согласования не возвращается в ERP.
Подскажите где копать или может что не так делаю.

P.S. Сильно не пинать- это мое первое сообщение на этом форуме.
Найденные решения
10. Tavalik 1471 10.08.16 09:56 Сейчас в теме
К сожалению, типовые правила у меня так и не заработали. Решил проблему следующим способом:

В общий модуль "ИнтеграцияС1СДокументооборотПереопределяемый" в пустую процедуру "ПриИзмененииСостоянияСогласования" добавил код:

Если ТипЗнч(ПредметСогласования) = Тип("ДокументСсылка.ЗаявкаНаРасходованиеДенежныхСредств") Тогда
    Объект = ПредметСогласования.ПолучитьОбъект();
    Если Состояние = Перечисления.СостоянияСогласованияВДокументообороте.НаСогласовании Тогда
        Объект.Статус = Перечисления.СтатусыЗаявокНаРасходованиеДенежныхСредств.НЗ_ОтправленаНаСогласование;
    ИначеЕсли Состояние = Перечисления.СостоянияСогласованияВДокументообороте.НеСогласован Тогда
        Объект.Статус = Перечисления.СтатусыЗаявокНаРасходованиеДенежныхСредств.Отклонена;
    ИначеЕсли Состояние = Перечисления.СостоянияСогласованияВДокументообороте.Согласован Тогда
        Объект.Статус = Перечисления.СтатусыЗаявокНаРасходованиеДенежныхСредств.КОплате;
    КонецЕсли;
    Если Объект.Модифицированность() Тогда
        Объект.Записать(РежимЗаписиДокумента.Запись);
    КонецЕсли;
КонецЕсли;
Показать
Mos; Xleo777; +2 Ответить
Остальные ответы
Сортировка: Древо
2. Skromnyi 10 28.01.15 11:41 Сейчас в теме
(1) Sergey-Chelny, нет под рукой сейчас ERP, поэтому не могу проверить, но смысл вкладок "Передача в 1С:Документооборот" и "Получение из 1С:Документооборота" вроде таков (ИМХО):
- если документ создан на стороне Интегрированной системы (ИС), в данном случае это ERP, и "выгружается" в ДО, то поля в карточке создаваемого документа на стороне ДО заполняются по правилам указанным на вкладке "Передача в 1С:Документооборот".
- если документ создан на стороне ДО и "выгружается" в ИС, то поля карточки документа на стороне ИС заполняются по правилам указанным на вкладке "Получение из 1С:Документооборота"
3. Africa 28.01.15 18:03 Сейчас в теме
(1) Sergey-Chelny,Все правильно вы делаете, но вот только есть сильное сомнение, что заявки на расходование ДС можно нынче согласовывать через документооборот. (т.е. согласовать-то можно, а вот получить результат согласования в ERP не уверен)
По-крайней мере в настройках использования согласования, упоминания о заявках на ДС нет - там есть коммерческие предложения, заказы клиентов, соглашения с клиентами и заявки на возврат.
4. Sergey-Chelny 29.01.15 09:03 Сейчас в теме
(3) Africa, подскажите где находятся эти самые настройки использования согласования в 1С Документооборот (программу изучаю, поэтому многое еще не знаю).
5. Africa 29.01.15 11:10 Сейчас в теме
(4) Sergey-Chelny,В ERP Администрирование - Документооборот - Согласование через 1С:Документооборот.
Настройки согласования: Администрирование - СRM и Продажи - там есть целый раздел "согласование" с выбором ответственных.
6. GregRusakov 10 08.11.15 13:34 Сейчас в теме
По поводу согласования документов, вы можете также использовать Модуль "Корпоративные процессы для "1С:Документооборот КОРП". Посмотрите здесь:
http://документооборот.net/kp
7. vlush78 111 23.11.15 21:25 Сейчас в теме
Как настроить обмен НСИ между ERP и ДО описано здесь: http://www.doc-lvv.ru/2015/09/kak-nastroit-obmen-nsi-mezhu-1serp-i-1sdokumentooborot.html
Как настроить бесшовную интеграцию здесь: http://www.doc-lvv.ru/2015/10/besshovnaya-integraciya-1serp-i-1sdokumentooborot.html
8. Tavalik 1471 01.08.16 13:07 Сейчас в теме
Здравствуйте всем.

Столкнулся с такой же проблемой. Бесшовная интеграция между 1С:ERP Управление предприятием 2 (2.1.3.169) и Документооборот 8 ПРОФ, редакция 2.1 (2.1.3.1).

Создаю документ "Заявка на расходование денежных средств" в ERP, отправляю на согласование в Документооборот, там заявка согласовывается и ... все. Статус заявки в ERP не меняется. Пробовал различные правила и настройки, эффекта нет.

vlush78 Как настроить бесшовную интеграцию здесь: http://www.doc-lvv.ru/2015/10/besshovnaya-integraciya-1serp-i-1sdokumentooborot.html

Пробовал по вашей инструкции. Результата также, к сожалению, нет.

Кто-нибудь решил эту проблему?
9. vlush78 111 01.08.16 13:19 Сейчас в теме
(8) Tavalik, В ERP указаны логин и пароль для доступа к 1С:Документооборот (в константах надо искать через все функции)?
10. Tavalik 1471 10.08.16 09:56 Сейчас в теме
К сожалению, типовые правила у меня так и не заработали. Решил проблему следующим способом:

В общий модуль "ИнтеграцияС1СДокументооборотПереопределяемый" в пустую процедуру "ПриИзмененииСостоянияСогласования" добавил код:

Если ТипЗнч(ПредметСогласования) = Тип("ДокументСсылка.ЗаявкаНаРасходованиеДенежныхСредств") Тогда
    Объект = ПредметСогласования.ПолучитьОбъект();
    Если Состояние = Перечисления.СостоянияСогласованияВДокументообороте.НаСогласовании Тогда
        Объект.Статус = Перечисления.СтатусыЗаявокНаРасходованиеДенежныхСредств.НЗ_ОтправленаНаСогласование;
    ИначеЕсли Состояние = Перечисления.СостоянияСогласованияВДокументообороте.НеСогласован Тогда
        Объект.Статус = Перечисления.СтатусыЗаявокНаРасходованиеДенежныхСредств.Отклонена;
    ИначеЕсли Состояние = Перечисления.СостоянияСогласованияВДокументообороте.Согласован Тогда
        Объект.Статус = Перечисления.СтатусыЗаявокНаРасходованиеДенежныхСредств.КОплате;
    КонецЕсли;
    Если Объект.Модифицированность() Тогда
        Объект.Записать(РежимЗаписиДокумента.Запись);
    КонецЕсли;
КонецЕсли;
Показать
Mos; Xleo777; +2 Ответить
12. Skromnyi 10 10.08.16 14:32 Сейчас в теме
(10) Tavalik, нет ERP под рукой, что-бы проверить: "ЗаявкаНаРасходованиеДенежныхСредств" сначала проводится, а потом отправляется на согласование в ДО или нет?
11. capitan 619 10.08.16 10:01 Сейчас в теме
Мне кажется это у 1С некоторый косячок и они его поправят.
Либо действительно где то поменялись настройки.
Раньше работало согласование в обе стороны.
13. barbambiya 03.11.16 15:22 Сейчас в теме
Господа, подскажите, может столкнулись с таким эффектом. Обновили платформу до 8.3.9.1818 и ERP перестало авторизовываться в Документооборот. Форма авторизации появляется, пользователь вводит пароль и ничего не происходит. Форма закрывается, но соединения не устанавливается.
Попробовали еще раз повторить на другом сервере, взяли демо конфигурации ERP и Документооборот, подружили их. Обновили платформу и получили аналогичный основному серверу результат.
14. ekaterinburgg 14.11.16 15:17 Сейчас в теме
Проверьте все настройки Web сервера ДО или просто переопубликуйте его.
15. barbambiya 25.01.17 15:07 Сейчас в теме
(14)Увы, эффект проявляется только на релизах платформы выше 8.3.8.2167. Если платформу вернуть до 2167, все работает. Повторили эксперимент на другом сервере и пере-публикацией базы на IIS. Результат тот-же. ERP не может пройти авторизацию в базе Документооборот.
Оставьте свое сообщение

Вакансии

Удаленный ИТ-журналист
Санкт-Петербург
По совместительству

Программист 1С
Санкт-Петербург
зарплата от 80 000 руб. до 150 000 руб.
Полный день

Консультант-аналитик 1С
Москва
зарплата до 160 000 руб.
Полный день

Удаленный бизнес-аналитик 1С
Санкт-Петербург
Временный (на проект)

Разработчик (эксперт) по направлению 1С:ЗУП 3
Санкт-Петербург
зарплата от 130 000 руб.
Полный день