"Восстановить положение окна" - не помогает. Как я решил проблему.

0. Николай С (niko11s) 349 27.05.17 11:55 Сейчас в теме
Как получилось решить проблему глюков отображения формы документа.

Перейти к публикации

Комментарии
1. Павел Толкачев (ltfriend) 259 28.05.17 13:26 Сейчас в теме
Была такая же проблема. Решилась изменением размера окна в конфигураторе (чуть раздвинул и вернул обратно).
AloneWolf; igrned; maxopik2; METAL; +4 Ответить
2. Николай С (niko11s) 349 28.05.17 13:46 Сейчас в теме
(1) Попробовал, да тоже помогло.
3. Max Morozov (sam1c55) 28.05.17 19:22 Сейчас в теме
Этот глюк появляется, если добавляешь новый элемент на форму. Нужно правильно указывать привязки добавленного элемента и все будет ок.
hame1e00n; Winstoncuk; maxopik2; artik1994; Anton_BooR; srv7; Trancer64; sqncng; KoldunOne; ALagutin; Maxis; rpgshnik; alanto23; IvanovAV; +14 2 Ответить
5. Николай С (niko11s) 349 28.05.17 20:56 Сейчас в теме
(3) Форма была типовая, вообще её не трогал. При сравнении с типовой конфигурацией никаких отличий не было.
ltfriend; +1 Ответить
4. Николай Николай (lisma9) 28.05.17 20:28 Сейчас в теме
Свойства формы - поставить галку "Автоправила" (третий пункт сверху). Тоже помогает.
6. Николай С (niko11s) 349 28.05.17 21:02 Сейчас в теме
(4)Да, помогает, проверил.
7. Алексей Иванов (IvanovAV) 47 29.05.17 03:29 Сейчас в теме
Внешне похоже, как будто, привязки на форме слетели. Я бы вначале в конфигураторе запустил форму в режиме просмотра, и растянул на экран. В момент растягивания, красным блоком был бы выделен, элемент со сбитыми привязками. Конечно, часто бывает что конфа поставщика отваливается, на конфигурациях со снятым "замком", скорее всего этот случай.
srv7; sqncng; MsDjuice; rpgshnik; +4 Ответить
8. Алексей Епанчин (IChe) 29.05.17 17:21 Сейчас в теме
Была такая же ситуация, однако положение осложнялось тем что косяк был только на одном компьютере, а на остальных двух, все работало штатно. Так и не получилось победить.(((
Papilion; +1 Ответить
9. Maxim Kolkin (the1) 289 30.05.17 10:43 Сейчас в теме
(8) Ну тут скорее всего поможет почистить кэш
11. Алексей Епанчин (IChe) 30.05.17 12:07 Сейчас в теме
(9) Не помогает.
(10) Спасибо за подробный ответ. Теперь буду знать в чем корень зла.)))
10. Farsis (Farsis) 17 30.05.17 10:50 Сейчас в теме
Такое поведение системы наблюдается в типовых конфигурациях на платформе 8.3.10.х если пользователь в настройках шрифта Windows установил значение Средний (125) или Крупный (150).

После перехода с 8.2 на 8.3 в некоторых формах поймали такое поведение платформы. Хотя автор написал что менял настройки dpi и ему не помогало, нам это помогло.

Ещё один интересный момент - такое поведение платформы наблюдается только в ОС Windows 7 и выше. Пользователи на Windows XP продолжают нормально работать на новой платформе с увеличенным шрифтом.
dimon_upi; himera; AlexF1983; the1; +4 Ответить
12. Александр П. (tiniji) 148 31.05.17 10:33 Сейчас в теме
(10)
Этот глюк с масштабом текста Windows тянется еще с 8.1 для обычных форм. Решается очень просто, в модуле формы добавляется пробел и убирается, потом обновляется конфигурация (в режиме стандартного масштаба 100%).
На управляемых другаю шляпа, там колонки скачут как сумашедшие, то ширина колонки сумма на пол экрана, то еще что-нибудь.
alexyes; himera; +2 Ответить
14. Константин (const000) 88 31.05.17 13:24 Сейчас в теме
Забавно. Месяц назад пытался полное решение данной проблемы опубликовать тут. Не получилось - сказали текста мало ) Написал на форуме.
(10) правильно написал - причина в неверном масштабном коэффициенте на экране у обновляющего. Вставьте это пожалуйста в основной текст - найти в интернете не особо получится у заинтересованных, а комментарии не все всегда читают.
21. Капитан Немо (capitan) 589 04.10.17 12:00 Сейчас в теме
(10) на на Windows XP по другому работает масштабирование, там увеличивается только системный шрифт.
Все остальные элементы приложений по-прежнему отображаются в масштабе 1:1
Занятно, что при нестандартном масштабировании, например 120% все нормально
13. Нагим Османов (nagimo) 1 31.05.17 10:42 Сейчас в теме
Была такая же проблема. Но на моем компе форма отображалась корректно, а на компе бухгалтера приходилось восстанавливать положение окна. Решил так: зашел в конфигуратор на компе бухгалтера, как бы изменил любой реквизит ("как бы" потому что изменил и вернул сразу в предыдущее состояние) и сохранил-обновил базу. Оказалось у нас разные разрешения экрана.
Понятно, что это решение относится к изменениям настроек dpi, но сами настройки у себя менять не стал, просто сохранил конфу сразу на нужном компе.
15. Андрей Акулов (DrAku1a) 1222 01.06.17 02:14 Сейчас в теме
удалил на форме один из элиментов
16. Andrey Kuznetsov (avkuz) 05.06.17 08:56 Сейчас в теме
Такая проблема в типовых конфигурациях часто встречается -причем по пожеланиям заказчиков -мы не ставим возможность редактирования конфигураций. Масштаб могу сказать у всех стандартный 100%. Проявляется как на всей форме в целом так и отдельно в табличной части документа. Единственно всем советуем на панели окон правой кнопкой- восстановить положение окна.
Пока только так. (учитывая что в конфу не лезем)
17. Ivan Melnikov (details) 16.06.17 07:34 Сейчас в теме
Это возникает при не правильной привязке элементов на форме. Кривые элементы можно увидеть в конфигураторе при проверке отображения формы. Если потянуть форму на расширение, то эти элементы будут перечеркиваться красным крестом, вот в них и надо поправить привязки. Исправлял лично не один раз.
18. Александр Александрович (AlPi) 47 26.07.17 11:21 Сейчас в теме
Коллеги, кому интересно. Вот способ от Soul771 (http://www.forum.mista.ru/topic.php?id=775304), которым воспользовались мы.
Цитирую:
"Наконец-то получилось вернуть прежнее состояние!
Открыла форму документа в конфигураторе, правой кнопкой на рамке->свойства-> состояние окна-> Свободное
Сохранила, окно открывается нормально)))
Долго тыкалась в свойствах формы, не было сначала этого пункта, и не поймала момент, что тыкнула, чтобы появился, какие-то несколько фильтров сразу..
http://s018.radikal.ru/i506/1607/cb/a149a55936d0.jpg"

У нас работает, при открытии формы в режиме 1С Предприятие можно также щелкнув на верхней части окна переключить его в обычный режим, который будет работать корректно.

Удачи.
19. Анастасия Лаптева (laptewanast@mail.ru) 21.09.17 13:21 Сейчас в теме
У меня аналогичная проблема, форма не типовая в не типовом документе, раньше она работала правильно без проблем, позже добавила реквизит и стала открываться на пол экрана, после этого реквизит перенесла в другое место, проверила все привязки, они правильные, в конфигураторе форма открывается на весь экран при проверке, и на моем пк форма открывается нормально, масштабируется, а на всех практически компьютерах кроме моего положение ее так и не изменилось, те она на пол-экрана, причем под моим пользователем на моем компе - все правильно открывается, под моим пользователем на другом компе - уже не правильно. Сто раз чистила все кешы, первый запуск масштабируется, второй запуск формы -уже на пол-экрана. Что делать?
20. Анастасия Лаптева (laptewanast@mail.ru) 22.09.17 11:04 Сейчас в теме
Проблема решена!!
Привязки действительно все нужно проверять и они должны быть впорядке, но если проблема все равно остается с отображением не на весь экран, значит нужно уменьшить размер щрифта, в настройках панели управления виндовс, до самого мелкого, тем самым разрешение опускается до нужных 96dpi, в этом разрешении 1с рекомендует разрабатывать формы. Форму нужно пересохранить в конфигураторе под новым разрешением.
22. Капитан Немо (capitan) 589 04.10.17 13:46 Сейчас в теме
(20) а если типовая конфигурация ? ;)
23. Natalia73 Задор (fktrc171) 09.10.17 14:53 Сейчас в теме
(22) Аналогично ! База типовая , не снятая. Проверили разрешение экрана - все стандартно , пока Только " Восстановить положение окна" ?
24. Капитан Немо (capitan) 589 10.10.17 11:10 Сейчас в теме
25. Natalia73 Задор (fktrc171) 12.10.17 13:40 Сейчас в теме
(24)
(23) вот так решили
https://infostart.ru/public/682596/

это если было расширение 125 , то поставится 120.
А если было 100 (стандартное ) , то как победить 8.3.10 платформу , в которой все формы без восстановления не работают ?
26. Капитан Немо (capitan) 589 12.10.17 14:17 Сейчас в теме
(25) а вы попробуйте поменять на 120 и вернуть на 100 ;)
27. Михаил Рыков (zveruganet) 70 28.11.17 09:49 Сейчас в теме
29. das Ant (dasAnt) 07.12.17 14:11 Сейчас в теме
Имеется УТ 11.1 сменили платформу с 8.3.9 на 8.3.11 и получили этот же глюк, ни один из предложенных методов выше не помог, у кого ещё есть варианты?
Оставьте свое сообщение