INFOSTART EVENT 2018 EDUCATION

Второй тур голосования за доклады.
Окончание 5 сентября.

Котов Дмитрий | Программист-разработчик | ООО "Саянскгазобетон"

«Автоматизация обработки потока документов, на примере разработки "Терминала путевых листов" для диспетчерской службы»

Пример возможности разработки полностью автоматизированного места для получения, обработки и возврата документов через терминал на платформе 1С:Предприятие 8.3, без участия оператора. В примере демонстрирую возможность реализации "Терминала путевых листов" в диспетчерской службе компании ООО "Саянскгазобетон". Основное направление компании - производство автоклавного газобетона. Диспетчерская служба не имеет возможности круглосуточной работы, в связи с чем сложилась проблема в своевременным возврате путевых листов от водителей. «Терминал путевых листов», продемонстрированный в докладе, позволяет решит данную проблему путем создания интерфейса прямого доступа в информационную систему с помощью нового режима запуска 1С – "Киоск". Водитель самостоятельно получает и возвращает путевой лист в прикладном решении 1С: Управление автотранспортом 2.1.

1. Lumis 19.12.16 13:59 Сейчас в теме

Внешняя печатная форма: ПараметрыПечати

Всем добрый день! Прошу помочь с созданием внешней печатной формы.
Конфигурация Розница 2.1.5, есть типовой документ РасходныйКассовыйОрдер. У документа в модуле менеджера определены 3 печатных формы. Нам требуется по каждой из них сделать внешнюю печатную форму.

Процедура Печать(МассивОбъектов, ПараметрыПечати, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
	
	Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "РКО") Тогда
	
		УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "РКО",
				"Расходный кассовый ордер",
				СформироватьПечатнуюФормуКО2(МассивОбъектов, ОбъектыПечати));
	
	КонецЕсли;
	
	Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "ПечатьПрепроводительнаяВедомостьНакладнаяКСумке") Тогда
		
		УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "ПечатьПрепроводительнаяВедомостьНакладнаяКСумке",
				"Препроводительная ведомость к сумке",
				СформироватьПечатнуюФормуПрепроводительнаяВедомостьНакладная­КСумке(МассивОбъектов, ОбъектыПечати, ПараметрыПечати));
	
	КонецЕсли;
	
	Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "КвитанцияКСумке") Тогда
		
		УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "КвитанцияКСумке",
				"Квитанция к сумке",
				СформироватьПечатнуюФормуКвитанцияКСумке(МассивОбъектов, ОбъектыПечати));
	
	КонецЕсли;
	
КонецПроцедуры
Показать


По двум макетам проблем не возникло, но при попытке создать ВПФ для макета ПечатьПрепроводительнаяВедомостьНакладнаяКСумке (второй в списке) возникла сложность. Дело в том, что там помимо прочих передается параметром ПараметрыПечати - это структура, которая содержит некоторые данные формы документа. Эти данные как раз и требуются при печати, поскольку они не сохраняются в объекте, а присутствуют только на форме.

Но по стандартам БСП, насколько я понимаю, если я делаю ВПФ с вариантом использования ВызовСерверногоМетода, то моя процедура печати должна иметь такой вид:

Процедура Печать(МассивОбъектов,
				КоллекцияПечатныхФорм,
				ОбъектыПечати,
				ПараметрыВывода) Экспорт


Соответственно, доступа к ПараметрыПечати я не имею, и данные вытащить не могу. Подскажите, как грамотно нужно выстроить структуру моей внешней обработки, чтобы такая печать стала возможной.
Спасибо!
Сортировка: Древо
В этой теме еще нет сообщений.
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Программист 1С
Одесса (Украина)
зарплата от 40 000 руб.
Полный день

Программист 1С
Санкт-Петербург
Полный день

Аналитик 1С
Москва
зарплата от 80 000 руб. до 120 000 руб.
Полный день

1С Developer
Одесса (Украина)
зарплата от 60 000 руб. до 120 000 руб.
Полный день

Бизнес-аналитик 1С
Санкт-Петербург
зарплата от 70 000 руб. до 90 000 руб.
Полный день