Внешняя печатная форма: ПараметрыПечати

1. 19.12.16 13:59 Сейчас в теме
Всем добрый день! Прошу помочь с созданием внешней печатной формы.
Конфигурация Розница 2.1.5, есть типовой документ РасходныйКассовыйОрдер. У документа в модуле менеджера определены 3 печатных формы. Нам требуется по каждой из них сделать внешнюю печатную форму.

Процедура Печать(МассивОбъектов, ПараметрыПечати, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт
	
	Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "РКО") Тогда
	
		УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "РКО",
				"Расходный кассовый ордер",
				СформироватьПечатнуюФормуКО2(МассивОбъектов, ОбъектыПечати));
	
	КонецЕсли;
	
	Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "ПечатьПрепроводительнаяВедомостьНакладнаяКСумке") Тогда
		
		УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "ПечатьПрепроводительнаяВедомостьНакладнаяКСумке",
				"Препроводительная ведомость к сумке",
				СформироватьПечатнуюФормуПрепроводительнаяВедомостьНакладная­КСумке(МассивОбъектов, ОбъектыПечати, ПараметрыПечати));
	
	КонецЕсли;
	
	Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "КвитанцияКСумке") Тогда
		
		УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(КоллекцияПечатныхФорм, "КвитанцияКСумке",
				"Квитанция к сумке",
				СформироватьПечатнуюФормуКвитанцияКСумке(МассивОбъектов, ОбъектыПечати));
	
	КонецЕсли;
	
КонецПроцедуры
Показать


По двум макетам проблем не возникло, но при попытке создать ВПФ для макета ПечатьПрепроводительнаяВедомостьНакладнаяКСумке (второй в списке) возникла сложность. Дело в том, что там помимо прочих передается параметром ПараметрыПечати - это структура, которая содержит некоторые данные формы документа. Эти данные как раз и требуются при печати, поскольку они не сохраняются в объекте, а присутствуют только на форме.

Но по стандартам БСП, насколько я понимаю, если я делаю ВПФ с вариантом использования ВызовСерверногоМетода, то моя процедура печати должна иметь такой вид:

Процедура Печать(МассивОбъектов,
				КоллекцияПечатныхФорм,
				ОбъектыПечати,
				ПараметрыВывода) Экспорт


Соответственно, доступа к ПараметрыПечати я не имею, и данные вытащить не могу. Подскажите, как грамотно нужно выстроить структуру моей внешней обработки, чтобы такая печать стала возможной.
Спасибо!
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
В этой теме еще нет сообщений.
Оставьте свое сообщение
Вакансии
Автор новостей об 1С, налогах и бухучете на INFOSTART.RU
Санкт-Петербург
По совместительству

Программист 1С
Екатеринбург
зарплата от 50 000 руб.
По совместительству

Ведущий разработчик 1С (техлид внутреннего учета)
Новосибирск
зарплата от 230 000 руб.
Полный день

Программист 1С
Рязань
зарплата от 150 000 руб. до 250 000 руб.
Полный день

Архитектор 1С
Обнинск
зарплата от 150 000 руб. до 350 000 руб.
Полный день