Клиент событий в «бесконечном» HTTP-соединении для 1С: Предприятие 8

0. 9 02.12.19 08:20 Сейчас в теме
Native Компонента в отдельном потоке обрабатывает пакеты событий, в "бесконечном" http соединении и передаёт данные в очередь внешних событий.

Перейти к публикации

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. sergvagner2018 02.12.19 14:03 Сейчас в теме
(0) а где такое на практике у себя применяли?
Очень интересно было бы про опыт услышать.
2. starovton 9 02.12.19 14:38 Сейчас в теме
(1)Есть сервер видеонаблюдения Macroscop, у него есть HTTP API, он клиенту отсылает chanked пакеты в которых описывает события которые произошли ( распознание номера, распознание лица и т.д.) по этим событиям обработка 1С формирует картинку для охранников.
sergvagner2018; +1 Ответить
3. sergvagner2018 04.12.19 07:53 Сейчас в теме
4. Matematik 09.12.19 06:24 Сейчас в теме
Судя по параметрам вы конкретно событие распознавание автомобильного номера запрашиваете. Изображение с данной камеры в виде стоп-кадра за этот момент времени получали?
5. starovton 9 09.12.19 09:12 Сейчас в теме
Нет не получал, но по событию, можно запросить у сервера архив распознанных номеров
6. oaohkk 13.11.20 16:50 Сейчас в теме
Привет коллегам!
Есть задача, через форму документа при нажатии кнопки, распознать в Macroscop и получить номер авто и записать его в реквизит документа.
Как я понял, эта обработка работает в режиме онлайн и с потоком самостоятельно "прилетающих" данных?
7. starovton 9 17.11.20 09:08 Сейчас в теме
(6)Да обработка пишет события в базу "прилетающие" от сервера видеонаблюдения. В вашем случае можно отправлять HTTPЗапрос со строкой из API Macroscop для получения нужного события.
8. oaohkk 17.11.20 09:50 Сейчас в теме
(7)примерно напишите какой код, еще ни разу с этим не сталкивался.
9. starovton 9 17.11.20 10:32 Сейчас в теме
//autovprs_export - параметр из API Macroscop, после знака = установить свои значения

СтрокаЗапроса = "192.168.1.1:6060/autovprs_export?login=&password=&channelid=&startTime=&finishTime="

HTTPЗапрос = Новый HTTPЗапрос();

HTTPСоединение = Новый HTTPСоединение(СтрокаЗапроса);
	
Попытка
	Ответ = HTTPСоединение.Получить(HTTPЗапрос);
Исключение
	Возврат Ложь;
КонецПопытки;

стрОтвет = Ответ.ПолучитьТелоКакСтроку("UTF-8");


Если Ответ.КодСостояния = 200 Тогда
	Если Не ПустаяСтрока(стрОтвет ) Тогда
		Попытка	
			ЧтениеJSON = Новый ЧтениеJSON;
			ЧтениеJSON.УстановитьСтроку(стрОтвет);
			Событие = ПрочитатьJSON(ЧтениеJSON);
			ЧтениеJSON.Закрыть();
		Исключение
		КонецПопытки;

                Если Событие.EventId <> "e9e7a69c-7ee2-3fee-a530-9f8a88124fcc" 
                КонецЕсли;
КонецЕсли;
КонецЕсли;

Показать
10. viki_glebova 25.12.20 07:43 Сейчас в теме
А ваша компонента Server-sent events обработает?
11. starovton 9 02.01.21 08:26 Сейчас в теме
(10)
Server-sent events

Тут нужно разобраться, если это соединение по HTTP, то обработает...
Оставьте свое сообщение
Вопросы с вознаграждением