Удаление спящих сеансов

0. &-rey 71 16.12.19 18:30 Сейчас в теме
Удаление сеансов, имеющих статус "спящий".

Перейти к публикации

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. cherva 96 18.12.19 11:09 Сейчас в теме
На платформе 8.3.14.1779 не работает
{ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма.Форма(31)}: Метод объекта не обнаружен (ConnectAgent)
АгентСервера = COMСоединитель.ConnectAgent(ИдентификаторАгентаСервера);
2. &-rey 71 18.12.19 14:50 Сейчас в теме
COM не зарегистрирован, странно, может подключаетесь через тонкий клиент и пытается не на самом сервере искать подключение к серверу 1С?
3. cherva 96 18.12.19 16:09 Сейчас в теме
Предыдущую ошибку победили теперь это:


{ВнешняяОбработка.ВнешняяОбработка1.Форма.Форма.Форма(31)}: Ошибка при вызове метода контекста (ConnectAgent)
АгентСервера = COMСоединитель.ConnectAgent(ИдентификаторАгентаСервера);
по причине:
Произошла исключительная ситуация (V83.COMConnector.1): server_addr=tcp://mos1csrv:1540 descr=192.168.1.142:1540:10061(0x0000274D): Подключение не установлено, т.к. конечный компьютер отверг запрос на подключение. ;
line=1056 file=d:\jenkins\ci_builder\windowsbuild2\platform\src\rtrsrvc\src\d­ataexchangetcpclientimpl.cpp


У нас сервер на портах 17ХХ
4. &-rey 71 19.12.19 08:51 Сейчас в теме
порт у вас вроде бы стандартный 1540, все верно определилось, на 17хх у вас не сервер 1с наверное? Это видно по строке
"C:\Program Files\1cv8\8.3.15.1700\bin\ragent.exe" -srvc -agent -regport 1541 -port 1540 -range 1560:1591 -d "C:\Program Files\1cv8\srvinfo"
в свойствах службы агента сервера 1с, строка запуска....
тут вобщем то код пятиминутный, почти полностью дернут из общего модуля СоединенияИБКлиентСервер, функция ПолучитьАктивныеСеансыИБ. Затем из полученных перебираю и закрываю только спящие...


Процедура КнопкаВыполнитьНажатие(Кнопка)
	ПараметрыАдминистрированияИБ = СоединенияИБ.ПолучитьПараметрыАдминистрированияИБ(); 
	НастройкаБлокировки = ПараметрыАдминистрированияИБ;
	ВсеКромеТекущего = Истина;
	Результат = Новый Структура("АгентСервера,КластерСерверов,Сеансы", Неопределено, Неопределено, Новый Массив);
	
	ПодстрокиСтрокиСоединения = СтроковыеФункцииКлиентСервер.РазложитьСтрокуВМассивПодстрок(
	СтрокаСоединенияИнформационнойБазы(), ";");	
	ИмяСервера = СтроковыеФункцииКлиентСервер.СократитьДвойныеКавычки(Сред(ПодстрокиСтрокиСоединения[0], 7));
	ИмяИБ      = СтроковыеФункцииКлиентСервер.СократитьДвойныеКавычки(Сред(ПодстрокиСтрокиСоединения[1], 6));
	COMСоединитель = Новый COMОбъект(ОбщегоНазначения.ИмяCOMСоединителя());	
	РазделительПорта = Найти(ИмяСервера, ":");
	Если РазделительПорта > 0 Тогда
		ИмяИПортСервера = ИмяСервера;
		ИмяСервера = Сред(ИмяИПортСервера, 1, РазделительПорта - 1);
		НомерПортаКластера = Число(Сред(ИмяИПортСервера, РазделительПорта + 1));
	ИначеЕсли НастройкаБлокировки.ПортКластераСерверов <> 0 Тогда
		НомерПортаКластера = НастройкаБлокировки.ПортКластераСерверов;
	Иначе
		НомерПортаКластера = COMСоединитель.RMngrPortDefault;
	КонецЕсли;
	
	ИдентификаторАгентаСервера = ИмяСервера;
	Если НастройкаБлокировки.ПортАгентаСервера <> 0 Тогда
		ИдентификаторАгентаСервера = ИдентификаторАгентаСервера + ":" + 
			Формат(НастройкаБлокировки.ПортАгентаСервера, "ЧГ=0");
	КонецЕсли;
	
	// Подключение к агенту сервера
	АгентСервера = COMСоединитель.ConnectAgent(ИдентификаторАгентаСервера);
	Результат.АгентСервера = АгентСервера; 
	
	// Найдем необходимый нам кластер
	Для каждого Кластер Из АгентСервера.GetClusters() Цикл		
		Если Кластер.MainPort <> НомерПортаКластера Тогда
			Продолжить;
		КонецЕсли;		
		Результат.КластерСерверов = Кластер; 
		АгентСервера.Authenticate(Кластер, НастройкаБлокировки.ИмяАдминистратораКластера, 
			НастройкаБлокировки.ПарольАдминистратораКластера);		
		// Получаем список сеансов
		НомерТекущегоСеанса = СоединенияИБПовтИсп.ПараметрыОтключенияСеансов().НомерСеансаИнформационнойБазы;
		СписокСеансов = АгентСервера.GetSessions(Кластер);
		Для Каждого Сеанс из СписокСеансов Цикл
			Если ВРег(Сеанс.InfoBase.Name) <> ВРег(ИмяИБ) Тогда
				Продолжить;
			КонецЕсли;
			Если НЕ ВсеКромеТекущего ИЛИ (НомерТекущегоСеанса <> Сеанс.SessionID) Тогда
				Результат.Сеансы.Добавить(Сеанс);
			КонецЕсли;
		КонецЦикла;		
	КонецЦикла;

   //Теперь пройдемся по сеансам и если он спящий - выкинем
   Для каждого сеанс из Результат.Сеансы цикл
	   Если Сеанс.Hibernate тогда
		    СоединенияИБКлиентСервер.ОтключитьСеанс(сеанс.SessionID, "Злой админ послал вас на ...")
	   КонецЕсли;
   КонецЦикла;
   Предупреждение("ВСЕ ДЕМОНЫ УБИТЫ!!!", 5,"Удаление зависших сеансов");
   ЭтаФорма.Закрыть();
КонецПроцедуры
Показать
5. cherva 96 19.12.19 12:42 Сейчас в теме
нет сервер 1с у нас на портах 17Х. И в строка запуска 1С
\\ххххххх\1ce\1cestart.exe enterprise /Sхххххх:1741\gsiupp1 /RunModeOrdinaryApplication

Просто на 15ХХ стоит сервер 1С 8.2 , но он не запущен. А сервер 8.1 стоит именно на 17ХХ портах, может ваша обработка неправильно цепляет не тот сервер?
7. &-rey 71 19.12.19 17:00 Сейчас в теме
(5) Не путайте, это строка запуска толстого клиента. Если у вас два сервера установлено, вполне возможно он находит 8.2. В крайнем случае, посмотрите текст, там сперва поиск сервера формируется текстовая строка, задайте ее напрямую. К примеру НомерПортаКластера = "17хх", ИдентификаторАгентаСервера = "mos1csrv" и сразу пошло со строк // Подключение к агенту сервера

(6) Если бы это еще работало всегда... к сожалению, иногда какое время не ставь на засыпание и выкидывание, а они так и висят, да еще и с блокировками!... или ручками выкидывать, что надоело, сделал кнопку чтобы до переустановки сервера на НГ праздники юзеры сами могли очищать спящих
6. nomad_irk 49 19.12.19 12:50 Сейчас в теме
(0)Чем не устраивает типовой настраиваемый механизм завершения сеансов?
Оставьте свое сообщение
Вопросы с вознаграждением