1. GeraltSnow 117 08.10.19 11:10 Сейчас в теме

КД 2.1, не работают поля поиска

Выгружаю из УПП 1.3 в БП 3.0 документ подтверждение отгрузки. На стороне БП этот документ должен сопоставиться по номеру и дате с существующей реализацией и изменить в ней некоторые реквизиты. Почему-то сопоставление не работает, при загрузке создается новый документ с идентичными номером и датой. В чем может быть проблема?
Прикрепленные файлы:
Найденные решения
10. GeraltSnow 117 08.10.19 14:06 Сейчас в теме

Отключил, теперь при загрузке в БП такая ошибка:

{Обработка.КонвертацияОбъектовИнформационныхБаз.МодульОбъекта(7570)}: Ошибка при вызове метода контекста (Выполнить)
Результат = ЗапросПоиска.Выполнить();
по причине:
{(1, 80)}: Синтаксическая ошибка "="
ВЫБРАТЬ Ссылка ИЗ Документ.РеализацияТоваровУслуг ГДЕ {КлючПоискаВИБИсточнике} <<?>>= &{КлючПоискаВИБИсточнике} И {ИмяТипаВИБПриемнике} = &{ИмяТипаВИБПриемнике} И {ИмяТипаВИБИсточнике} = &{ИмяТипаВИБИсточнике} И Номер = &Номер И Дата = &Дата


В БП 3.0 прошелся отладкой по обработке КонвертацияОбъектовИнформационныхБаз и внутри функции НайтиЭлементЗапросом(...) нашел код, обрабатывающий параметры вида {*}
// Не по всем параметрам можно искать.
Если ИмяПараметра = "{УникальныйИдентификатор}" Или ИмяПараметра = "{ИмяПредопределенногоЭлемента}" Тогда
	Продолжить;
КонецЕсли;


Добавил по аналогии следующую конструкцию и обмен заработал без ошибок.
Если ИмяПараметра = "{КлючПоискаВИБИсточнике}" Или ИмяПараметра = "{ИмяТипаВИБПриемнике}" Или ИмяПараметра = "{ИмяТипаВИБИсточнике}" Тогда
	Продолжить;
КонецЕсли;
nomad_irk; +1 Ответить
6. nomad_irk 40 08.10.19 11:32 Сейчас в теме
(5)да, прошу пардону, не правильно прочитал (3)
Отключите совсем поиск по внутреннему идентификатору в таком случае.
Остальные ответы
Избранное Подписка Сортировка: Древо
2. nomad_irk 40 08.10.19 11:18 Сейчас в теме
как дата/номер обрабатываются в правилах?
3. GeraltSnow 117 08.10.19 11:22 Сейчас в теме
(2)
Номер: Значение = Источник.ДокументОтгрузки.Номер;
Дата: Значение = Источник.ДокументОтгрузки.Дата;

В реквизите ДокументОтгрузки хранится ссылка на реализацию УПП.
4. nomad_irk 40 08.10.19 11:24 Сейчас в теме
для чего вы это делаете, если по умолчанию так?
5. GeraltSnow 117 08.10.19 11:29 Сейчас в теме
(4)Чтобы номер и дата брались из привязанной к документу реализации, а не из самого документа.
6. nomad_irk 40 08.10.19 11:32 Сейчас в теме
(5)да, прошу пардону, не правильно прочитал (3)
Отключите совсем поиск по внутреннему идентификатору в таком случае.
7. GeraltSnow 117 08.10.19 12:05 Сейчас в теме
(6) Отключил, теперь при загрузке в БП такая ошибка:

{Обработка.КонвертацияОбъектовИнформационныхБаз.МодульОбъекта(7570)}: Ошибка при вызове метода контекста (Выполнить)
Результат = ЗапросПоиска.Выполнить();
по причине:
{(1, 80)}: Синтаксическая ошибка "="
ВЫБРАТЬ Ссылка ИЗ Документ.РеализацияТоваровУслуг ГДЕ {КлючПоискаВИБИсточнике} <<?>>= &{КлючПоискаВИБИсточнике} И {ИмяТипаВИБПриемнике} = &{ИмяТипаВИБПриемнике} И {ИмяТипаВИБИсточнике} = &{ИмяТипаВИБИсточнике} И Номер = &Номер И Дата = &Дата
8. nomad_irk 40 08.10.19 12:12 Сейчас в теме
(7)
Эээ....Я не знаю, что есть Обработка.КонвертацияОбъектовИнформационныхБаз и как она обрабатывает правила, сформированные КД 2.1.
9. betrezen 08.10.19 12:12 Сейчас в теме
Обмен через файл? Если да, посмотрите в файле какие значения при выгрузке у Даты и Номер
10. GeraltSnow 117 08.10.19 14:06 Сейчас в теме

Отключил, теперь при загрузке в БП такая ошибка:

{Обработка.КонвертацияОбъектовИнформационныхБаз.МодульОбъекта(7570)}: Ошибка при вызове метода контекста (Выполнить)
Результат = ЗапросПоиска.Выполнить();
по причине:
{(1, 80)}: Синтаксическая ошибка "="
ВЫБРАТЬ Ссылка ИЗ Документ.РеализацияТоваровУслуг ГДЕ {КлючПоискаВИБИсточнике} <<?>>= &{КлючПоискаВИБИсточнике} И {ИмяТипаВИБПриемнике} = &{ИмяТипаВИБПриемнике} И {ИмяТипаВИБИсточнике} = &{ИмяТипаВИБИсточнике} И Номер = &Номер И Дата = &Дата


В БП 3.0 прошелся отладкой по обработке КонвертацияОбъектовИнформационныхБаз и внутри функции НайтиЭлементЗапросом(...) нашел код, обрабатывающий параметры вида {*}
// Не по всем параметрам можно искать.
Если ИмяПараметра = "{УникальныйИдентификатор}" Или ИмяПараметра = "{ИмяПредопределенногоЭлемента}" Тогда
	Продолжить;
КонецЕсли;


Добавил по аналогии следующую конструкцию и обмен заработал без ошибок.
Если ИмяПараметра = "{КлючПоискаВИБИсточнике}" Или ИмяПараметра = "{ИмяТипаВИБПриемнике}" Или ИмяПараметра = "{ИмяТипаВИБИсточнике}" Тогда
	Продолжить;
КонецЕсли;
nomad_irk; +1 Ответить
11. vsesam80 08.10.19 21:50 Сейчас в теме
В КД 2 есть такая замечательная бага. Если в обработчике Поля Поиска че нить написать и закоменитить, то поиск нормально не работает. В обработчике этом у тебя есть что то?
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Консультант-аналитик 1С
Набережные Челны
зарплата до 90 000 руб.
Полный день

Программист 1С
Набережные Челны
зарплата от 40 000 руб. до 110 000 руб.
Полный день

Программист 1С
Казань
зарплата от 40 000 руб. до 110 000 руб.
Полный день

Программист, аналитик, эксперт 1С
Санкт-Петербург
По совместительству

Бизнес-аналитик 1С
Санкт-Петербург
зарплата от 100 000 руб.
Полный день