Выгрузка номенклатуры в социальную сеть Вконтакте

0. kaliuzhnyi 14.08.19 14:40 Сейчас в теме
Обработка для быстрой и легкой выгрузки товаров Вконтакт. Так просто еще не было)))

Перейти к публикации

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. spy-83 187 14.08.19 15:41 Сейчас в теме
Очень неплохое решение.
Отличная работа!
Nefilimus; +1 Ответить
2. kaliuzhnyi 14.08.19 15:49 Сейчас в теме
(1) О, это моя первая похвала на инфостарте ;) Спасибо.
SinglCOOLer; +1 Ответить
3. kaliuzhnyi 14.08.19 16:40 Сейчас в теме
Товарищи!
Если обнаружите косяки в работе обработки - пишите.
Будем исправлять ;)
23. ex_digital 17.11.19 23:23 Сейчас в теме
(3) Здравствуйте! Подскажите, пожалуйста, я правильно понимаю, что для данной обработки необходимо, чтобы 1с размещался на хостинге а не на пк? Извиняюсь, если вопрос глупый, не особо еще разбираюсь в 1с. Просто одна из задач внедрения 1с стоит как раз в выгрузке товаров на сайт и в вк. Спасибо!
24. fantoma 18.12.19 14:23 Сейчас в теме
(3) Добрый день. Цены вводятся только вручную ?
4. Dzenn 434 15.08.19 17:44 Сейчас в теме
Выглядит с первого взгляда, как что-то интересное :-) Правда, лично у меня есть сомнения в её востребованности, по той простой причине, что ВКонтакте не воспринимается большинством людей как торговая площадка, по моему скромному мнению.
5. kaliuzhnyi 15.08.19 17:58 Сейчас в теме
(4) Отчасти, согласен. Лично я тоже не особо воспринимаю магазин(категория - товары, в группе). Однако у нас в ДНР, очень много розничных предприятий которые заводят группы и публикуют там свои товары, вот и подумал может кроме "наших", в мире тоже кто-то так делает))) Ну, за одно и познакомился с API ВКонтакте...
user1174805; +1 Ответить
6. Dzenn 434 15.08.19 18:02 Сейчас в теме
(5) осталось правильно оформить, подробно расписать возможности, и выложить на продажу :-) Вот моё, например https://infostart.ru/public/627500/ - если бы не моя лень, продаж было бы раз в пять больше, но и то, что продаётся, тоже приятно ;-)
7. kaliuzhnyi 15.08.19 18:03 Сейчас в теме
Сейчас кстати поступила задачка сделать аналогичное для facebook. Так, что кому интересно - следите... А потом вернусь к этой обработке, и переделаю, так как там ещё нужно код оптимизировать...
Nefilimus; +1 Ответить
8. user1267557 15.08.19 21:04 Сейчас в теме
25. sergemiko 19.12.19 00:21 Сейчас в теме
(8) а если товаров несколько тысяч? Спрашиваю, потому что не знаком с инстой. Там есть отдельный сервис Товаров как в ВК?
9. Yashazz 3582 16.08.19 00:04 Сейчас в теме
У всех таких публикаций есть общая беда - они косячат при попытке подключиться к ВК. На этапе авторизации. Я 2-3 таких скачал, обломался и плюнул. Автор, если не сложно, можете подробнее описать, как в вашем случае сделана авторизация?
10. kaliuzhnyi 16.08.19 00:27 Сейчас в теме
(9)
Доброй ночи. Авторизацию, а именно получение "токена", делал просто:
На форме создаем поле HTML документа, указываем у него ПутьКДанным - ссылаемся на реквизит формы/объекта(не важно с типом строка).
Ну далее отправляем по нужно url, а короче вот код, думаю разберешься:
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	ПЕРЕМ ИДПриложения;
	
	//
	Если НЕ Параметры.Свойство("ИДПриложения", ИДПриложения)
		ИЛИ НЕ ЗначениеЗаполнено(ИДПриложения) Тогда
		Отказ = Истина;
	КонецЕсли;
	
	//
	АдресURL = "https://oauth.vk.com/authorize"
			 + "?client_id=" + ИДПриложения + "" // Идентификатор Вашего приложения.
			 + "&redirect_uri=https://api.vk.com/blank.html" // Адрес, на который будет переадресован пользователь после прохождения авторизации
			 + "&display=page" // Указывает тип отображения страницы авторизации. (page — форма авторизации в отдельном окне; popup — всплывающее окно; mobile — авторизация для мобильных устройств (без использования Javascript))
			 + "&scope=wall,groups,photos,market,offline" // Битовая маска настроек доступа приложения (https://vk.com/dev/permissions)
			 + "&response_type=token" // Тип ответа, который необходимо получить. Укажите token.
			 + "&state=" // Произвольная строка, которая будет возвращена вместе с результатом авторизации.
			 + "&revoke=1" // Параметр, указывающий, что необходимо не пропускать этап подтверждения прав, даже если пользователь уже авторизован.
			 + ""
			 ;
	
КонецПроцедуры // ПриСозданииНаСервере

&НаКлиенте
Процедура HTMLДокументСформирован(Элемент)
	ПЕРЕМ КлючДоступаПользователя;
	
	//
	Если Элемент.Документ.Location.host = "api.vk.com" Тогда

		//маПараметры = СтроковыеФункцииКлиентСервер.РазложитьСтрокуВМассивПодстрок(Сред(Элемент.Документ.Location.hash, 2), "&");
		маПараметры = СтрРазделить(Сред(Элемент.Документ.Location.hash, 2), "&");
        Для Каждого Параметр ИЗ маПараметры Цикл
            Сообщить(Параметр);
			Позиция = СтрНайти(Параметр, "=");
			Если Позиция > 0
				И НРег(СокрЛП(Лев(Параметр, Позиция - 1))) = "access_token" Тогда

				КлючДоступаПользователя = СокрЛП(Сред(Параметр, Позиция + 1));
				Прервать;
			КонецЕсли;

        КонецЦикла;
		
        Закрыть(КлючДоступаПользователя);

    КонецЕсли;
	
КонецПроцедуры // HTMLДокументСформирован
Показать


P.S. У меня кстати тоже не сразу, вышло... Но голова уже забита другим, не помню в чем была проблема, а не кажись вспомнил, где-то я подглядел и там был в url указан такой параметр &redirect_uri=http://api.vk.com/blank.html, а нужно указать так - &redirect_uri=https://api.vk.com/blank.html, как говорится найди 10 отличий :D
11. Yashazz 3582 16.08.19 12:26 Сейчас в теме
(10) Блин, да, точно, там от секьюрности могло зависеть... Спасибо, попробую!
12. FreeArcher 98 29.08.19 11:20 Сейчас в теме
Есть в обработке возможность выгружать товар частями? Не увидел каких-либо отборов. Смотрел в УТ11.
13. kaliuzhnyi 29.08.19 14:22 Сейчас в теме
(12) Добрый день. Да есть. если я правильно понял вопрос.
Заходим в обработку - Еще(над табличной частью) - Настройка списка - Отбор.
Прикрепленные файлы:
14. FreeArcher 98 29.08.19 15:29 Сейчас в теме
(13) Да правильно. Не интуитивно понятно, надпись может сделать где то на форме, что отбор стандартными средствами списка.
Но на УТ11 все равно сыпятся ошибки, видать есть отличия в метаданных.
15. kaliuzhnyi 29.08.19 15:31 Сейчас в теме
(14) На недельке "потестю". Отпишусь.
16. Igogo 3 01.09.19 15:24 Сейчас в теме
Добрый день, пытаюсь авторизоваться, пишет ваш браузер устарел, не подскажете как можно обойти, режим эмуляции IE 11 в реестре добавлен. спасибо
17. Igogo 3 01.09.19 15:46 Сейчас в теме
(16) решил через открытие ссылки авторизации в стороннем браузере, и ручным заполнением токена
18. user817592 18.09.19 10:21 Сейчас в теме
Здравствуйте, пробовал вашу обработку на Рознице редакция 2.2 (2.2.11.24) выходит ошибка при выгрузке товаров без изображений
Ошибка выполнения запроса, код ошибки - 100 (One of the parameters specified was missing or invalid: main_photo_id is undefined). Подробности см. на: https://vk.com/dev/errors
Далее идет информация для программиста.
{"error":{"error_code":100,"error_msg":"One of the parameters specified was missing or invalid: main_photo_id is undefined","request_params":[{"key":"method","value":"market.add"},{"key":"oauth","value":"1"},{"key":"","value":""},{"key":"owner_id","value":"-166466472"},{"key":"name","value":"Валик-резинка черный\n40"},{"key":"description","value":"Валик-резинка черный\n40"},{"key":"category_id","value":"103"},{"key":"price","value":"40.00"},{"key":"main_photo_id","value":""},{"key":"photo_ids","value":""},{"key":"v","value":"5.101"}]}}
Возможно ли сделать выгрузки без изображений?
20. kaliuzhnyi 18.09.19 23:45 Сейчас в теме
(18) по ошибке посмотрю на выходных, отпишусь.
Нет, ВК запрещает создавать товары без фотографии.
19. user817592 18.09.19 10:23 Сейчас в теме
P.S. Выгружаю в товары группы ВКонтакте
21. artyom19051989 29.10.19 16:59 Сейчас в теме
Как с вами связаться по электронке или другим месенеджерам?
22. chyvasok 14.11.19 11:17 Сейчас в теме
Если учет по характеристикам? можно без них выгружаться Вконтакте?
26. user1303354 11.03.20 12:42 Сейчас в теме
Добрый день!
Отличная обработка , в УТ 11,4 работает, авторизуется без проблем

Но есть , тем не менее, несколько нюансов
1. У нас товар с характеристиками.
В прайсе для розницы цена указана на характеристику ( размер)
В рамках артикула - все цены на размеры одинаковы
- Можно сделать, чтобы цена цеплялась из характеристики?

2, Выгрузка изображений
Изображения из уТ выгружаются .
Но - Превью в товарах и (на странице и в альбоме) - обрезанные
То есть - картинка из 1с некорректно обрабатывается в ВК
можно это как-то побороть?

И отбор желательно сделать более понятным для сотрудника - менеджера

Готов пообщаться в личке

спасибо
Прикрепленные файлы:
пример загрузки изображений.pdf
27. market 16.03.20 23:48 Сейчас в теме
В УТ11 общие для вида номенклатуры характеристики не загружаются.
28. proger.1c 8 24.03.20 07:56 Сейчас в теме
Выгрузить ссылку на сайт возможно?
29. JIexa_74 25.03.20 08:43 Сейчас в теме
Здравствуйте. Помогите пожалуйста скачать данную обработку! Нет стартмани(
30. JIexa_74 25.03.20 11:30 Сейчас в теме
При открытии в 1с 8.3.14.1565 УТ 10.3.47.3:

ОШИБКА:

{ВнешняяОбработка.ПубликацияТоваровВСоциальнуюСетьVK.МодульОбъекта(27,25)}: Переменная не определена (ДополнительныеОтчетыИОбработки)
ПараметрыРегистрации = <<?>>ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке();
{ВнешняяОбработка.ПубликацияТоваровВСоциальнуюСетьVK.МодульОбъекта(34,39)}: Переменная не определена (ДополнительныеОтчетыИОбработкиКлиентСервер)
ПараметрыРегистрации.Вставить("Вид", <<?>>ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиДополнительнаяОбработка());
{ВнешняяОбработка.ПубликацияТоваровВСоциальнуюСетьVK.МодульОбъекта(42,6)}: Переменная не определена (ДополнительныеОтчетыИОбработкиКлиентСервер)
<<?>>ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыОткрытиеФормы());
{ВнешняяОбработка.ПубликацияТоваровВСоциальнуюСетьVK.МодульОбъекта(485,21)}: Процедура или функция с указанным именем не определена (СтрСоединить)
СтрокаПараметров = <<?>>СтрСоединить(МассивПараметров, "&");
{ВнешняяОбработка.ПубликацияТоваровВСоциальнуюСетьVK.МодульОбъекта(561,23)}: Процедура или функция с указанным именем не определена (СтрНайти)
ПротоколПозиция = <<?>>СтрНайти(Гиперссылка, "://");
{ВнешняяОбработка.ПубликацияТоваровВСоциальнуюСетьVK.МодульОбъекта(569,18)}: Процедура или функция с указанным именем не определена (СтрНайти)
СерверПозиция = <<?>>СтрНайти(Гиперссылка, "/", , нПозиция);
{ВнешняяОбработка.ПубликацияТоваровВСоциальнуюСетьVK.МодульОбъекта(581,15)}: Процедура или функция с указанным именем не определена (СтрНайти)
ХешПозиция = <<?>>СтрНайти(Гиперссылка, "#");
31. market 26.03.20 21:34 Сейчас в теме
32. proger.1c 8 29.03.20 16:54 Сейчас в теме
Подборки товаров в магазин выгружает?
33. artyom19051989 02.04.20 21:10 Сейчас в теме
Здравствуйте. Готовы купить, но нет стартмани. На прямую как то можно? вотс апп 89101786557
34. grgkgs 5 04.04.20 13:56 Сейчас в теме
Здравствуйте! Попробовал Вашу обработку на УТ 11.4.7.128. После попытки публикации единственного товара на стене выдает ошибку Ошибка выполнения запроса, код ошибки - 100 (One of the parameters specified was missing or invalid: photos_list is invalid). Подробности см. на: https://vk.com/dev/errors
Далее идет информация для программиста.
{"error":{"error_code":100,"error_msg":"One of the parameters specified was missing or invalid: photos_list is invalid","request_params":[{"key":"method","value":"photos.saveWallPhoto"},{"key":"oauth","value":"1"},{"key":"","value":""},{"key":"photo","value":"[]"},{"key":"server","value":"204824"},{"key":"hash","value":"359cfe289cea3aeb8a0895332d666710"},{"key":"caption","value":"Тестовая выгрузка"},{"key":"v","value":"5.101"}]}}. Куда смотреть?
35. grgkgs 5 05.04.20 10:11 Сейчас в теме
(34) Разобрались. Имена файлов изображений должны быть на латинице. Но возникла другая проблема. При двухфакторной аутентификации не показывается окно от ВК, а 1с генерирует окно с вводом имени пользователя и пароля. Вводим, жмем на ок и вновь появляется окно ввода пользователя и пароля от 1с... Ни приглашения ввести код доступа, ничего.
36. grgkgs 5 05.04.20 18:02 Сейчас в теме
(35) Отбой, и с этим разобрались. Как оказалось немного неправильно создали приложение ВК
37. pkv11 18 08.04.20 09:40 Сейчас в теме
Иван, большое спасибо за обработку!
Возможно добавить в выгрузку возможность формирования имен изображений подходящих для VK, чтобы не вываливалось в ошибку?
38. pkv11 18 08.04.20 13:33 Сейчас в теме
В общем, сам уже добавил. )

Необходимо строки
ЗаписьДанных.ЗаписатьСтроку(СтрШаблон("Content-Disposition: form-data; name=photo; filename=%1.%2",  ИзображениеНоменклатуры.Наименование, ИзображениеНоменклатуры.Расширение));

Заменить на
ЗаписьДанных.ЗаписатьСтроку(СтрШаблон("Content-Disposition: form-data; name=photo; filename=%1.%2",  ВычислитьMD5(ИзображениеНоменклатуры.Наименование), ИзображениеНоменклатуры.Расширение));


и добавить функцию
&НаСервере
Функция ВычислитьMD5(Данные) 
 
 ХэшированиеДанных = Новый ХешированиеДанных(ХешФункция.MD5);
 ХэшированиеДанных.Добавить(Данные);
 Хэш = НРег(СтрЗаменить(ХэшированиеДанных.ХешСумма, " ", ""));

 Возврат Хэш;

КонецФункции
Показать
39. user1038503 24.04.20 13:49 Сейчас в теме
Добрый день! Розница, редакция 2.2 (2.2.13.12), 1С:Предприятие 8.3 (8.3.15.1830). Не могу найти у товара параметр "Характеристика". Куда копать?
Прикрепленные файлы:
40. user1038503 24.04.20 17:41 Сейчас в теме
(39) Разобрался. Нужно было включить характеристики номенклатуры.
41. draiver12@yandex.ru 27.05.20 10:23 Сейчас в теме
Добрый день! Скажите пожалуйста чем вызвана эта ошибка?
Прикрепленные файлы:
Шаблон.docx
42. VKuser96827091 27.05.20 15:44 Сейчас в теме
Здравствуйте!
Интересует заказать разработку более широкой интеграции 1С с Вконтакте и Одноклассниками.
Можем это обсудить?)
43. draiver12@yandex.ru 28.05.20 13:25 Сейчас в теме
Добрый день! Как с Вами можно связаться. Есть вопросы по обработке.
44. apatyukov 904 28.09.20 08:15 Сейчас в теме
Добрый день. В вашей обработке кадрирование превью решено?
45. user1476745 13.10.20 12:51 Сейчас в теме
Здравствуйте. Ваша обработка работает с Далионом?
46. VKuser620430096 23.10.20 15:34 Сейчас в теме
Добрый день! Как с Вами можно связаться. Есть вопросы по обработке.
Оставьте свое сообщение
Вопросы с вознаграждением