0. kalyuzhny 36 14.08.19 14:40 Сейчас в теме

Выгрузка номенклатуры в социальную сеть Вконтакте

Обработка для быстрой и легкой выгрузки товаров Вконтакт. Так просто еще не было)))

Перейти к публикации

Комментарии
Избранное Подписка Сортировка: Древо
1. spy-83 183 14.08.19 15:41 Сейчас в теме
Очень неплохое решение.
Отличная работа!
2. kalyuzhny 36 14.08.19 15:49 Сейчас в теме
(1) О, это моя первая похвала на инфостарте ;) Спасибо.
SinglCOOLer; +1 Ответить
3. kalyuzhny 36 14.08.19 16:40 Сейчас в теме
Товарищи!
Если обнаружите косяки в работе обработки - пишите.
Будем исправлять ;)
4. Dzenn 317 15.08.19 17:44 Сейчас в теме
Выглядит с первого взгляда, как что-то интересное :-) Правда, лично у меня есть сомнения в её востребованности, по той простой причине, что ВКонтакте не воспринимается большинством людей как торговая площадка, по моему скромному мнению.
5. kalyuzhny 36 15.08.19 17:58 Сейчас в теме
(4) Отчасти, согласен. Лично я тоже не особо воспринимаю магазин(категория - товары, в группе). Однако у нас в ДНР, очень много розничных предприятий которые заводят группы и публикуют там свои товары, вот и подумал может кроме "наших", в мире тоже кто-то так делает))) Ну, за одно и познакомился с API ВКонтакте...
6. Dzenn 317 15.08.19 18:02 Сейчас в теме
(5) осталось правильно оформить, подробно расписать возможности, и выложить на продажу :-) Вот моё, например https://infostart.ru/public/627500/ - если бы не моя лень, продаж было бы раз в пять больше, но и то, что продаётся, тоже приятно ;-)
7. kalyuzhny 36 15.08.19 18:03 Сейчас в теме
Сейчас кстати поступила задачка сделать аналогичное для facebook. Так, что кому интересно - следите... А потом вернусь к этой обработке, и переделаю, так как там ещё нужно код оптимизировать...
8. user1267557 15.08.19 21:04 Сейчас в теме
9. Yashazz 2486 16.08.19 00:04 Сейчас в теме
У всех таких публикаций есть общая беда - они косячат при попытке подключиться к ВК. На этапе авторизации. Я 2-3 таких скачал, обломался и плюнул. Автор, если не сложно, можете подробнее описать, как в вашем случае сделана авторизация?
10. kalyuzhny 36 16.08.19 00:27 Сейчас в теме
(9)
Доброй ночи. Авторизацию, а именно получение "токена", делал просто:
На форме создаем поле HTML документа, указываем у него ПутьКДанным - ссылаемся на реквизит формы/объекта(не важно с типом строка).
Ну далее отправляем по нужно url, а короче вот код, думаю разберешься:
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	ПЕРЕМ ИДПриложения;
	
	//
	Если НЕ Параметры.Свойство("ИДПриложения", ИДПриложения)
		ИЛИ НЕ ЗначениеЗаполнено(ИДПриложения) Тогда
		Отказ = Истина;
	КонецЕсли;
	
	//
	АдресURL = "https://oauth.vk.com/authorize"
			 + "?client_id=" + ИДПриложения + "" // Идентификатор Вашего приложения.
			 + "&redirect_uri=https://api.vk.com/blank.html" // Адрес, на который будет переадресован пользователь после прохождения авторизации
			 + "&display=page" // Указывает тип отображения страницы авторизации. (page — форма авторизации в отдельном окне; popup — всплывающее окно; mobile — авторизация для мобильных устройств (без использования Javascript))
			 + "&scope=wall,groups,photos,market,offline" // Битовая маска настроек доступа приложения (https://vk.com/dev/permissions)
			 + "&response_type=token" // Тип ответа, который необходимо получить. Укажите token.
			 + "&state=" // Произвольная строка, которая будет возвращена вместе с результатом авторизации.
			 + "&revoke=1" // Параметр, указывающий, что необходимо не пропускать этап подтверждения прав, даже если пользователь уже авторизован.
			 + ""
			 ;
	
КонецПроцедуры // ПриСозданииНаСервере

&НаКлиенте
Процедура HTMLДокументСформирован(Элемент)
	ПЕРЕМ КлючДоступаПользователя;
	
	//
	Если Элемент.Документ.Location.host = "api.vk.com" Тогда

		//маПараметры = СтроковыеФункцииКлиентСервер.РазложитьСтрокуВМассивПодстрок(Сред(Элемент.Документ.Location.hash, 2), "&");
		маПараметры = СтрРазделить(Сред(Элемент.Документ.Location.hash, 2), "&");
        Для Каждого Параметр ИЗ маПараметры Цикл
            Сообщить(Параметр);
			Позиция = СтрНайти(Параметр, "=");
			Если Позиция > 0
				И НРег(СокрЛП(Лев(Параметр, Позиция - 1))) = "access_token" Тогда

				КлючДоступаПользователя = СокрЛП(Сред(Параметр, Позиция + 1));
				Прервать;
			КонецЕсли;

        КонецЦикла;
		
        Закрыть(КлючДоступаПользователя);

    КонецЕсли;
	
КонецПроцедуры // HTMLДокументСформирован
Показать


P.S. У меня кстати тоже не сразу, вышло... Но голова уже забита другим, не помню в чем была проблема, а не кажись вспомнил, где-то я подглядел и там был в url указан такой параметр &redirect_uri=http://api.vk.com/blank.html, а нужно указать так - &redirect_uri=https://api.vk.com/blank.html, как говорится найди 10 отличий :D
11. Yashazz 2486 16.08.19 12:26 Сейчас в теме
(10) Блин, да, точно, там от секьюрности могло зависеть... Спасибо, попробую!
Оставьте свое сообщение
Новые вопросы с вознаграждением
Автор темы объявил вознаграждение за найденный ответ, его получит тот, кто первый поможет автору.

Вакансии

Автор новостных обзоров на тему 1С и бухучета
Санкт-Петербург
По совместительству

Руководитель проекта, аналитик, консультант
Санкт-Петербург
По совместительству

Программист 1С
Москва
зарплата от 120 000 руб.
Полный день

Удаленный программист 1С
Рига
зарплата от 70 000 руб. до 100 000 руб.
Полный день

Программист 1С
Самара
зарплата от 100 000 руб. до 150 000 руб.
Полный день